Closed Bug 1167964 Opened 5 years ago Closed 5 years ago

Wrong display of the option "search" with deactivated OneOff Search Buttons

Categories

(Firefox :: Preferences, defect)

38 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1160076

People

(Reporter: ef1a0498, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150513174244

Steps to reproduce:

0. I've set browser.search.showOneOffButtons to false to show the old search bar. (More information here: https://support.mozilla.org/de/questions/1035503)
1. Let's go to the settings (about:preferences)
2. Now you can see that there is the "tab" "search" at the left - however this tab is only used for the new search bar is used - for the old search bar only the old window is used for customising.
6. Click on the "search" "tab".


Actual results:

Strangely the settings page is shown - in an empty state without any search engines.
And the "search" tab disappears.

If you reload the settings page you can reproduce it again.


Expected results:

The "search" tab shouldn't be shown at all if browser.search.showOneOffButtons is set to false or a click on it should open the old search engine options in this case.
Severity: normal → minor
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Severity: minor → normal
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Component: Untriaged → Preferences
OS: Windows 7 → All
Hardware: x86_64 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1160076
You need to log in before you can comment on or make changes to this bug.