Closed Bug 1160076 Opened 5 years ago Closed 5 years ago

Broken in-content preferences Search tab with browser.search.showOneOffButtons = false

Categories

(Firefox :: Preferences, defect)

37 Branch
defect
Not set
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 40
Iteration:
40.3 - 11 May
Tracking Status
firefox38 --- wontfix
firefox38.0.5 --- verified
firefox39 --- verified
firefox40 --- verified
firefox-esr38 --- fixed

People

(Reporter: skyler.o.sully, Assigned: florian)

References

()

Details

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

I'm currently running Mac OS X 10.9.5 (Mavericks) and just installed Firefox 37.0.2.  I installed add-ons for aesthetics and for functionality related to Web Development tools.  I'm not sure how to perform a dump of any crucial information you may need to fix this issue--but here's a little background:

1) After the initial install of Firefox, going to the Preferences (Firefox -> Preferences [Cmd+,]) produced the typical window containing all settings.  Nothing new here.
2) After installing all of the add-ons I needed (13 in total) as well as the Plugins I needed (5 in total), I took the time to configure the browser to my liking.  It looks perfect.
3) After finishing my configuration, going back to the Preferences window creates a new tab, whether I use the keyboard shortcut or go through the context menu.  Everything works fine with the exception of the 'Search' tab.

Steps to reproduce:

a. Go to Preferences [Cmd+,] or through context menu
b. A new tab opens containing the Preferences (this was new for me, but impressed)
c. Click on the 'Search' tab
d. Click on the "Default Search Engine" dropdown
e. Look at the "One-click search engines" table
f. (Optional) Click on the "Restore Default Search Engines" buttons


Actual results:

Actual Results:

[Steps a. and b. are skipped]
c. The Search tab (on left), the tab itself disappears, but the settings still appear
d. The dropdown is not populated, so an empty dropdown occurs
e. The "One-click search engines" table is empty
f.  No effect (that I noticed) after clicking the "Restore Default Search Engines" button

#NOTE: doing a refresh on the page returns the Search tab.


Expected results:

Expected Results:

[Steps a. and b. are skipped]
c. The Search tab (on left) shouldn't disappear
d. The dropdown is populated with the current default; onClick shows all engines
e. The "One-click search engines" table is populated with all installed Engines
f.  The default should be Yahoo, as this was the default engine after a fresh install
Related: bug 1157186.

Do you have the same problem when you start Firefox in a brand new profile?
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles

(In reply to Skyler Sully from comment #0)
> I'm not sure how to perform a dump of any crucial information you may need

1. Type about:support into the location bar and press Enter.
2. Click the Copy Text to Cliboard button.
3. Paste the clipboard contents in the comment reply box here, but don't submit the reply just yet.
4. Type about:plugins into the location bar and press Enter.
5. Select everything and copy it to the clipboard.
6. Paste the clipboard contents at the end of the comment reply box, then submit the comment.

> 3) After finishing my configuration, going back to the Preferences window
> creates a new tab

That shouldn't be happening until Firefox 38, which will be released around May 12. Did you at any point install a test version of Firefox like Beta or Nightly? If so, going back and forth between versions with the same profile probably mucked it up.
Component: Untriaged → Preferences
Flags: needinfo?(skyler.o.sully)
This can be caused by disabling one-click searches by setting browser.search.showOneOffButtons to false.
Video is corrupted when uploading to bugzilla. Here it is in gfycat:
https://gfycat.com/ZealousAmpleAfricanelephant
Attachment #8600616 - Attachment is obsolete: true
(In reply to Gingerbread Man from comment #1)
> Related: bug 1157186.

> 1. Type about:support into the location bar and press Enter.
> 2. Click the Copy Text to Cliboard button.
> 3. Paste the clipboard contents in the comment reply box here, but don't
> submit the reply just yet.

Application Basics
------------------

Name: Firefox
Version: 37.0.2
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:37.0) Gecko/20100101 Firefox/37.0
Multiprocess Windows: 0/1

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: AdBlock for YouTube™
Version: 0.1.0
Enabled: true
ID: jid1-q4sG8pYhq8KGHs@jetpack

Name: Classic Theme Restorer
Version: 1.3.1.1
Enabled: true
ID: ClassicThemeRestorer@ArisT2Noia4dev

Name: ColorZilla
Version: 2.8
Enabled: true
ID: {6AC85730-7D0F-4de0-B3FA-21142DD85326}

Name: Firebug
Version: 2.0.9
Enabled: true
ID: firebug@software.joehewitt.com

Name: Free Memory
Version: 0.95
Enabled: true
ID: jid1-n85lxPv1NAWVTQ@jetpack

Name: Menu Icons Plus
Version: 3.2
Enabled: true
ID: menuiconsplus@codedawn.com

Name: Menu Wizard
Version: 2.08
Enabled: true
ID: s3menu@wizard

Name: Restart
Version: 1.2.3
Enabled: true
ID: Restart@schuzak.jp

Name: Restart application
Version: 1.2.1
Enabled: true
ID: {c0af4d2f-2ce4-9471-49e2-1e5ca8a57dd2}

Name: Speed Test Add-on
Version: 0.1
Enabled: true
ID: jid1-pXkkWYQQvYa3iA@jetpack

Name: Tab Groups Button
Version: 0.52
Enabled: true
ID: tabgroupsbtn@char101.github.com

Name: Tab Memory Usage
Version: 0.1.4
Enabled: true
ID: jid1-fRvgLzKONCsPew@jetpack

Name: Web Developer
Version: 1.2.5
Enabled: true
ID: {c45c406e-ab73-11d8-be73-000a95be3b12}

Graphics
--------

Device ID: 0x a16
GPU Accelerated Windows: 0/1 Basic
Vendor ID: 0x8086
WebGL Renderer: Intel Inc. -- Intel Iris Pro OpenGL Engine
windowLayerManagerRemote: false
AzureCanvasBackend: quartz
AzureContentBackend: quartz
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.browsewithcaret: true
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 1
browser.places.smartBookmarksVersion: 7
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20150415140819
browser.startup.homepage_override.buildID: 20150415140819
browser.startup.homepage_override.mstone: 37.0.2
browser.tabs.loadInBackground: false
browser.urlbar.suggest.openpage: false
dom.mozApps.used: true
extensions.lastAppVersion: 37.0.2
layers.offmainthreadcomposition.enabled: false
media.gmp-gmpopenh264.lastUpdate: 1430169511
media.gmp-gmpopenh264.version: 1.3
media.gmp-manager.lastCheck: 1430580890
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1430601688
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateFx3Prefs: true
security.disable_button.openCertManager: false
security.disable_button.openDeviceManager: false
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1430221146

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.8
Version in use: 4.10.8

NSS
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSSMIME
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSSSL
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSUTIL
Expected minimum version: 3.17.4
Version in use: 3.17.4

Experimental Features
---------------------

> 4. Type about:plugins into the location bar and press Enter.
> 5. Select everything and copy it to the clipboard.
> 6. Paste the clipboard contents at the end of the comment reply box, then
> submit the comment.


Installed plugins
Find updates for installed plugins at mozilla.com/plugincheck
OpenH264 Video Codec provided by Cisco Systems, Inc.

    File: 1.3
    Path: /Users/skyler/Library/Application Support/Firefox/Profiles/lt2naoia.default/gmp-gmpopenh264/1.3
    Version: 1.3
    State: Enabled
    Play back web video and use video chats.

MIME Type	Description	Suffixes
Default Browser Helper

    File: Default Browser.plugin
    Path: /Library/Internet Plug-Ins/Default Browser.plugin
    Version: 537
    State: Enabled
    Provides information about the default web browser

MIME Type	Description	Suffixes
application/apple-default-browser	Provides information about the default web browser	
QuickTime Plug-in 7.7.3

    File: QuickTime Plugin.plugin
    Path: /Library/Internet Plug-Ins/QuickTime Plugin.plugin
    Version: 7.7.3
    State: Enabled
    The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

MIME Type	Description	Suffixes
video/x-msvideo	Video For Windows	avi,vfw
video/3gpp2	3GPP2 media	3g2,3gp2
audio/mpeg3	MP3 audio	mp3,swa
audio/mp3	MP3 audio	mp3,swa
audio/x-caf	CAF audio	caf
audio/mpeg	MPEG audio	mpeg,mpg,m1s,m1a,mp2,mpm,mpa,m2a,mp3,swa
video/quicktime	QuickTime Movie	mov,qt,mqv
audio/x-mpeg3	MP3 audio	mp3,swa
video/mp4	MPEG-4 media	mp4
application/x-sdp	SDP stream descriptor	sdp
audio/wav	WAVE audio	wav,bwf
video/avi	Video For Windows	avi,vfw
audio/mp4	MPEG-4 media	mp4
video/x-m4v	Video	m4v
audio/x-wav	WAVE audio	wav,bwf
application/sdp	SDP stream descriptor	sdp
audio/x-aiff	AIFF audio	aiff,aif,aifc,cdda
video/x-mpeg	MPEG media	mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa
video/3gpp	3GPP media	3gp,3gpp
video/msvideo	Video For Windows	avi,vfw
audio/x-mpeg	MPEG audio	mpeg,mpg,m1s,m1a,mp2,mpm,mpa,m2a,mp3,swa
audio/vnd.qcelp	QUALCOMM PureVoice audio	qcp
audio/x-mp3	MP3 audio	mp3,swa
application/x-rtsp	RTSP stream descriptor	rtsp,rts
audio/amr	AMR audio	AMR
video/sd-video	SD video	sdv
audio/aiff	AIFF audio	aiff,aif,aifc,cdda
video/mpeg	MPEG media	mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa
audio/3gpp2	3GPP2 media	3g2,3gp2
audio/aac	AAC audio	aac,adts
audio/x-m4b	AAC audio book	m4b
audio/x-m4p	AAC audio	m4p
audio/x-gsm	GSM audio	gsm
application/x-mpeg	AMC media	amc
audio/x-aac	AAC audio	aac,adts
audio/basic	uLaw/AU audio	au,snd,ulw
audio/x-m4a	AAC audio	m4a
audio/3gpp	3GPP media	3gp,3gpp
Java Applet Plug-in

    File: JavaAppletPlugin.plugin
    Path: /System/Library/Java/Support/CoreDeploy.bundle/Contents/JavaAppletPlugin.plugin
    Version: 14.9.0
    State: Enabled
    Displays Java applet content, or a placeholder if Java is not installed.

MIME Type	Description	Suffixes
application/x-java-applet;version=1.1.3	Java applet	
application/x-java-applet	Basic Java Applets	javaapplet
application/x-java-applet;version=1.2.2	Java applet	
application/x-java-applet;version=1.5	Java applet	
application/x-java-vm	Java applet	
application/x-java-applet;version=1.3.1	Java applet	
application/x-java-applet;version=1.3	Java applet	
application/x-java-applet;version=1.1.2	Java applet	
application/x-java-applet;version=1.1	Java applet	
application/x-java-vm-npruntime	Java applet	
application/x-java-applet;version=1.2.1	Java applet	
application/x-java-applet;jpi-version=1.6.0_65	Java applet	
application/x-java-applet;version=1.4.2	Java applet	
application/x-java-applet;version=1.6	Java applet	
application/x-java-applet;version=1.4	Java applet	
application/x-java-applet;version=1.1.1	Java applet	
application/x-java-applet;version=1.2	Java applet	
Shockwave Flash

    File: Flash Player.plugin
    Path: /Library/Internet Plug-Ins/Flash Player.plugin
    Version: 17.0.0.169
    State: Enabled
    Shockwave Flash 17.0 r0

MIME Type	Description	Suffixes
application/x-shockwave-flash	Shockwave Flash	swf
application/futuresplash	FutureSplash Player	spl

> That shouldn't be happening until Firefox 38, which will be released around
> May 12. Did you at any point install a test version of Firefox like Beta or
> Nightly? If so, going back and forth between versions with the same profile
> probably mucked it up.

I'm running 37.0.2.  After seeing what e10s is capable of, now I'm interested in messing with some of the betas/nightlies.  Still, I suspect that one of the Extensions I installed is responsible.  It wasn't until after I installed the Classic Theme Restorer 1.3.1.1 (which was required for the Plugin Tabs Groups 0.52 I installed).  Hold on, more info to come after seeing the recent comments.
(In reply to Fanolian from comment #2)
> Created attachment 8600616 [details]
> Video showing the disappearing of Search preference
> 
> This can be caused by disabling one-click searches by setting
> browser.search.showOneOffButtons to false.

Turns out that this fixed the problem. However, I never disabled that config value, but it was indeed set to false (user set).  I'm not sure if one of my plugins was responsible, but I need to do some additional testing as to how this happened.  I need to reinstall Mac OS X anyway, so I'll be able to track down where the issue was invoked.

I also have to try this from a different profile as was suggested previously.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150429135941

Steps to reproduce:
1. In about:config, set browser.search.showOneOffButtons to false.
2. In about:config, set browser.preferences.inContent to true (already the default in Firefox 38 and later).
3. Restart Firefox.
4. Open the Options/Preferences tab.
5. Click the Search category on the left.

Actual results:
Blank Default Search Engine drop-down menu.
Disabled Provide Search Suggestions checkbox.
Blank One-click Search Engines list.
Non-functional Restore Default Search Engines button.

(In reply to Fanolian from comment #2)
> This can be caused by disabling one-click searches by setting
> browser.search.showOneOffButtons to false.

Thank you for tracking this down.

(In reply to Skyler Sully from comment #5)
> Turns out that this fixed the problem. However, I never disabled that config
> value, but it was indeed set to false (user set).  I'm not sure if one of my
> plugins was responsible, but I need to do some additional testing as to how
> this happened.

I installed Classic Theme Restorer 1.3.2beta1 in Firefox 38, and it didn't touch either browser.search.showOneOffButtons or browser.preferences.inContent. So it — the latest version at least — doesn't break this functionality by default, though users can break it manually from the extension's preferences, Advanced category.
Blocks: 718011
Status: UNCONFIRMED → NEW
Depends on: 1119250
Ever confirmed: true
Flags: needinfo?(skyler.o.sully)
OS: Unspecified → All
Hardware: Unspecified → All
Summary: The Search tab disappears and doesn't display any installed search engines in the Preferences Tab (not the modal dialog box) for Mac OS X 10.9.5 → Broken in-content preferences Search tab with browser.search.showOneOffButtons = false
Attached patch PatchSplinter Review
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #8601435 - Flags: review?(gijskruitbosch+bugs)
This regressed with bug 1012223. A patch for bug 1119250 would be large enough that I would prefer not to uplift it.
Blocks: 1012223
Attachment #8601435 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 8601435 [details] [diff] [review]
Patch

Not sure which approval flags are actually needed here. I think we want to get this low risk fix into 38.0.5, 39 and possibly also 38.1esr, as I would expect some corporate users to be more resistant to change, and so to be more likely to have flipped that pref.

Approval Request Comment
[Feature/regressing bug #]: regression caused by bug 1012223
[User impact if declined]: when browser.search.showOneOffButtons is false, a broken preference pane will be visible until it is selected.
[Describe test coverage new/current, TreeHerder]: QA will verify
[Risks and why]: low risk
[String/UUID change made/needed]: none.
Attachment #8601435 - Flags: approval-mozilla-release?
Attachment #8601435 - Flags: approval-mozilla-esr38?
Attachment #8601435 - Flags: approval-mozilla-beta?
Attachment #8601435 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/273580797d9b
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Hi Florian, can you provide a point value.
Iteration: --- → 40.3 - 11 May
Flags: qe-verify?
Flags: needinfo?(florian)
Flags: firefox-backlog+
Points: --- → 2
Flags: qe-verify?
Flags: qe-verify+
Flags: needinfo?(florian)
QA Contact: camelia.badau
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.5 using latest Nightly 40.0a1 (buildID: 20150508030204).
Status: RESOLVED → VERIFIED
Comment on attachment 8601435 [details] [diff] [review]
Patch

Let's take it for 38.0.5 & 38.1.0esr.
Attachment #8601435 - Flags: approval-mozilla-release?
Attachment #8601435 - Flags: approval-mozilla-release+
Attachment #8601435 - Flags: approval-mozilla-esr38?
Attachment #8601435 - Flags: approval-mozilla-esr38+
Attachment #8601435 - Flags: approval-mozilla-beta?
Attachment #8601435 - Flags: approval-mozilla-aurora?
Attachment #8601435 - Flags: approval-mozilla-aurora+
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.5 using Firefox 38.0.5 Beta 1 (buildID: 20150511143336).
A workaround for Firefox 38.0 users is to load the "old" Manage Search Engines dialog in a tab using:

chrome://browser/content/search/engineManager.xul
Duplicate of this bug: 1167964
Verified fixed on Firefox 39 Beta 1 (buildID: 20150523155636).
You need to log in before you can comment on or make changes to this bug.