[NFC] System app unable to re-dispatch NFC event

VERIFIED FIXED in Firefox 41

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ashiue, Assigned: allstars.chh)

Tracking

({regression})

unspecified
2.2 S13 (29may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox39 wontfix, firefox40 wontfix, firefox41 fixed, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(8 attachments)

(Reporter)

Description

4 years ago
Build ID               20150525160205
Gaia Revision          5bcc08a732163087999251b523e3643db397412c
Gaia Date              2015-05-24 14:44:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b6623a27fa64
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150525.192755
Firmware Date          Mon May 25 19:28:07 EDT 2015
Bootloader             L1TC100118D0

STR:
1. Enable NFC
2. Tap a tag which contains URL on device

Expected result:
Open the URL via browser

Actual result:
Nothing happened
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
Basic function broken
blocking-b2g: --- → 3.0?
QA Whiteboard: [COM=NFC]
Assignee: nobody → allstars.chh
Blocks: b2g-nfc
[Blocking Requested - why for this release]:
blocking-b2g: 3.0? → spark?
Keywords: regression
Attachment #8611140 - Flags: review?(dlee)
Attachment #8611141 - Flags: review?(dlee)
Attachment #8611142 - Flags: review?(dlee)

Comment 6

4 years ago
Spark triage team decided that this bug is not a Spark blocker: moving this to 3.0?
blocking-b2g: spark? → 3.0?
request to v2.2+ as this is the regression from Bug 1165841, which is v2.2+.
blocking-b2g: 3.0? → 2.2?
per comment 7, let's block this on 2.2
blocking-b2g: 2.2? → 2.2+

Updated

4 years ago
Status: NEW → ASSIGNED
Attachment #8611140 - Flags: review?(dlee) → review+
Attachment #8611141 - Flags: review?(dlee) → review+
Attachment #8611142 - Flags: review?(dlee) → review+
https://hg.mozilla.org/mozilla-central/rev/a16ea3be66e5
https://hg.mozilla.org/mozilla-central/rev/222ada9adef3
https://hg.mozilla.org/mozilla-central/rev/047f199393d8
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S13 (29may)
Please request b2g37 approval on these patches when you get a chance.
Flags: needinfo?(allstars.chh)

Comment 12

4 years ago
This bug has been verified as pass on latest Nightly build of Flame 3.0 & Nexus 5_3.0 by the STR 

in Comment 0.

Actual result:
The Browser will be launched automatically and URL will be loaded successfully.

See attachment:Verify_30.3gp
Reproducing rate: 0/5

Device: Flame 3.0 build(Pass)
Build ID               20150531160203
Gaia Revision          e6dc0f4c583407a4a52a66ce7cb11f058302a762
Gaia Date              2015-05-29 17:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f8d21278244b
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150531.192324
Firmware Date          Sun May 31 19:23:35 EDT 2015
Bootloader             L1TC000118D0

Device:Nexus5_3.0 build(Pass):
Build ID               20150531160203
Gaia Revision          e6dc0f4c583407a4a52a66ce7cb11f058302a762
Gaia Date              2015-05-29 17:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f8d21278244b
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150531.192050
Firmware Date          Sun May 31 19:21:07 EDT 2015
Bootloader             HHZ12f
QA Whiteboard: [COM=NFC] → [COM=NFC],[MGSEI-Triage+]

Comment 13

4 years ago
Posted video Verify_30.3GP
Flags: needinfo?(allstars.chh)
Comment on attachment 8613965 [details] [diff] [review]
(v2.2) Part 1:update SYSTEM_APP_ID

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
Bug 1165841.

User impact if declined: 
Cannot read NFC tags

Testing completed: 
Manually

Risk to taking this patch (and alternatives if risky): 
no

String or UUID changes made by this patch:
UUID change in internal IDL (nsINfcContentHelper.idl)
Attachment #8613965 - Flags: approval-mozilla-b2g37?
Comment on attachment 8613966 [details] [diff] [review]
(v2.2) Part 2: notify listener with correct tabId.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
Bug 1165841.

User impact if declined: 
Cannot read NFC tags

Testing completed: 
Manually

Risk to taking this patch (and alternatives if risky): 
no

String or UUID changes made by this patch:
UUID change in internal IDL (nsINfcContentHelper.idl)
Attachment #8613966 - Flags: approval-mozilla-b2g37?
Comment on attachment 8613976 [details] [diff] [review]
(v2.2) Part 3: add tabId in notifyUserAccepted.


NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
Bug 1165841.

User impact if declined: 
Cannot read NFC tags

Testing completed: 
Manually

Risk to taking this patch (and alternatives if risky): 
no

String or UUID changes made by this patch:
UUID change in internal IDL (nsINfcContentHelper.idl)
Attachment #8613976 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
Attachment #8613965 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+

Updated

4 years ago
Attachment #8613976 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+

Updated

4 years ago
Attachment #8613966 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+

Updated

4 years ago
Keywords: verifyme
(Reporter)

Comment 21

4 years ago
Verified on v2.2:
Build ID               20150607162503
Gaia Revision          8fc797527a3eca7665bc1d1828848f2fb77ca99f
Gaia Date              2015-06-04 07:46:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d213237e11e9
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150607.201513
Firmware Date          Sun Jun  7 20:15:24 EDT 2015
Bootloader             L1TC100118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.