Closed Bug 1168429 Opened 5 years ago Closed 5 years ago

Jitter when zooming while location bar is showing/hiding

Categories

(Firefox for iOS :: General, defect)

Other
iOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1165587
Tracking Status
fennec + ---

People

(Reporter: st3fan, Assigned: sleroux)

References

()

Details

(Keywords: reproducible)

Attachments

(1 obsolete file)

STR:

1) Open a page that can be zoomed
2) Slowly zoom in/out with a two finger gesture

You will see the location bar hide/show but it will 'jitter' (for lack of better word) a lot. It looks like it is quickly alternating between two offsets.

(Is it possible that we look at some tap offset in a gesture recognizer and that the taps are being randomized by iOS? Like first the touch at index 0 is the first finger and then at the next invocation it is the other finger?)
I think we could probably live with this (IMO), but tracking for now.
Assignee: nobody → sleroux
tracking-fennec: ? → +
Added a small patch for this where we disable toolbar scrolling while the user is zooming so the toolbars don't get all janky.
Attachment #8613650 - Flags: review?(wjohnston)
Closing this patch and bug and marking it as a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1165587 as this issue is a sub issue of that issue.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1165587
Attachment #8613650 - Attachment is obsolete: true
Attachment #8613650 - Flags: review?(wjohnston)
You need to log in before you can comment on or make changes to this bug.