Closed Bug 1168570 Opened 5 years ago Closed 5 years ago

Enable add-on signing support in Android

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

defect
Not set

Tracking

(firefox41 fixed)

RESOLVED FIXED
mozilla41
Tracking Status
firefox41 --- fixed

People

(Reporter: mossop, Assigned: mossop)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Turn on add-on signing support in Android. For now following the same scheme as desktop, pref controlled in aurora/nightly and required in beta/release.

Currently this is preffed off by default (same as Desktop) since AMO add-ons aren't signed. We plan to turn on by default on desktop around June 15th (bug 1167652)
Blocks: 1168577
Attachment #8610792 - Flags: review?(margaret.leibovic)
Comment on attachment 8610792 [details] [diff] [review]
patch

Review of attachment 8610792 [details] [diff] [review]:
-----------------------------------------------------------------

I didn't test this, but it looks reasonable to me.
Attachment #8610792 - Flags: review?(margaret.leibovic) → review+
Depends on: 1170043
https://hg.mozilla.org/mozilla-central/rev/78059d73a934
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
No longer depends on: 1170043
Duplicate of this bug: 1170119
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 41 → mozilla41
You need to log in before you can comment on or make changes to this bug.