[Aries] Not able to share a picture using NFC

VERIFIED FIXED in Firefox 41

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: marcia, Assigned: dimi)

Tracking

unspecified
2.2 S14 (12june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox39 wontfix, firefox40 wontfix, firefox41 fixed, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [spark])

Attachments

(7 attachments)

[Blocking Requested - why for this release]: Functionality should work


Gaia-Rev        18f7c340f970991a10c288310bbfd4d105a1430c
Gecko-Rev       b7aed25b94251ea192021885323f15e87fc39321
Build-ID        20150528210322
Version         41.0a1
Device-Name     aries
FW-Release      4.4.2
FW-Incremental  eng.worker.20150528.204812
FW-Date         Thu May 28 20:48:20 UTC 2015
Bootloader      s1

STR:
1. Take some pictures with the Z3
2. Turn on NFC and pick a picture to share
3. Touch the device to another NFC Device (I tried Flame and 2 different Android devices)
4. Swipe to share

Expected: I would get a notification on the other phone that the picture has been shared
Actual: nothing happens

I am able to receive a picture from another device, but just not the other way around.

logcat attached.
(Assignee)

Comment 1

4 years ago
Maybe this bug is already fixed in Bug 1168292, could you help test with latest build ? (both sender and receiver)
Thanks!
I flashed the latest build on Z3:

Gaia-Rev        85e6fcef45c0cb2c017739df42b68b96cf5bb9c3
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/666b584fb521
Build-ID        20150601152553
Version         41.0a1
Device-Name     aries
FW-Release      4.4.2
FW-Incremental  eng.worker.20150601.151141
FW-Date         Mon Jun  1 15:11:48 UTC 2015
Bootloader      s1

I can still receive files from another device, but I am unable to send them.
(Assignee)

Updated

4 years ago
Assignee: nobody → dlee
(Assignee)

Comment 3

4 years ago
Posted patch Patch v1Splinter Review
This patch reverts commit in Bug 1168292 - Part 3
Attachment #8614546 - Flags: review?(allstars.chh)
Attachment #8614546 - Flags: review?(allstars.chh) → review+
should be regression from Bug 1168292.
blocking-b2g: spark? → 2.2?
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
It is broken on my V2.2 FLAME-KK & NEXUS-5-L.

V2.2 NEXUS=5-L (affected)
Build ID               20150531162502
Gaia Revision          b4582cc394e0919623263997c0cdb0b4751a1403
Gaia Date              2015-05-31 11:06:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/78d8b0a4303d
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150531.195626
Firmware Date          Sun May 31 19:56:44 EDT 2015
Bootloader             HHZ12f


V2.2 FLAME-KK (affected)
Build ID               20150602162502
Gaia Revision          a9aeb08263f1a727136e8ae78425e52431c82770
Gaia Date              2015-06-02 13:04:40
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5b3f1796ddf6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150602.195401
Firmware Date          Tue Jun  2 19:54:11 EDT 2015
Bootloader             L1TC100118D0
https://hg.mozilla.org/mozilla-central/rev/dcb7f4814c61
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S14 (12june)
Hi, Norry, Could you help to check status of master and v2.2, thank you.
Flags: needinfo?(fan.luo)
Hi Josh, We might also need this into master and v2.2. thanks.
Flags: needinfo?(jocheng)
Posted video video_0148.mp4
This bug can be reproduced on latest build of Flame 2.2,Nexus5 2.2 by the STR in comment 0.
Actually: Nothing happens.
Reproduce rate: 10/10
See attachment: verify_2.2.mp4 & logcat_0148.txt

Device: Flame v2.2 build(Affected)
Build ID               20150603162502
Gaia Revision          b92e782ca12397acc3eb52f2e237522c0213f4e0
Gaia Date              2015-06-03 21:02:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/74421c778aff
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150603.195036
Firmware Date          Wed Jun  3 19:50:46 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 v2.2 build(Affected)
Build ID               20150603162502
Gaia Revision          b92e782ca12397acc3eb52f2e237522c0213f4e0
Gaia Date              2015-06-03 21:02:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/74421c778aff
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150603.194836
Firmware Date          Wed Jun  3 19:48:52 EDT 2015
Bootloader             HHZ12f
Flags: needinfo?(fan.luo)
Posted video video_master.mp4
This bug has been verified as pass on latest build of Flame master,Nexus5 master by the STR in comment 0.
Actually result: Other device can recived the picture.
Reproduce rate: 0/10
See attachment: verify_master.mp4

Device: Flame v3.0 build(pass)
Build ID               20150603160203
Gaia Revision          45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Gaia Date              2015-06-03 17:32:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0920f2325a6d
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150603.192042
Firmware Date          Wed Jun  3 19:20:53 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 v3.0 build(pass)
Build ID               20150603160203
Gaia Revision          45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Gaia Date              2015-06-03 17:32:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0920f2325a6d
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150603.193140
Firmware Date          Wed Jun  3 19:31:59 EDT 2015
Bootloader             HHZ12f
QA Whiteboard: [MGSEI-Triage+]
Hi Dimi,
Please also help to raise uplift request for 2.2 thanks!
Flags: needinfo?(jocheng) → needinfo?(dlee)

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 14

4 years ago
Posted patch [2.2]PatchSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

Bug 1168292.

User impact if declined: 

NFC basic functions not work

Testing completed:

Test locally

Risk to taking this patch (and alternatives if risky): 

None

String or UUID changes made by this patch:

dom/nfc/nsINfcContentHelper.idl interface nsINfcContentHelper
from f0ed35c5-3f59-4806-b6bb-e77b879887af
to 75f0c8c0-2e5a-491f-a75d-4f3849c4feec
Flags: needinfo?(dlee)
Attachment #8615121 - Flags: review+
Attachment #8615121 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
Attachment #8615121 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+

Updated

4 years ago
Keywords: verifyme
Posted video verify_2.2.mp4
This bug has been verified as pass on latest build of Flame V2.2,Nexus5 V2.2 by the STR in comment 0.
Actually result: Other device can recived the picture.
Reproduce rate: 0/10
See attachment: verify_2.2.mp4

Device: Flame v2.2 build(pass)
Build ID               20150604162503
Gaia Revision          8fc797527a3eca7665bc1d1828848f2fb77ca99f
Gaia Date              2015-06-04 07:46:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f2157a04d75b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150604.195708
Firmware Date          Thu Jun  4 19:57:20 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 v2.2 build(pass)
Build ID               20150604162503
Gaia Revision          8fc797527a3eca7665bc1d1828848f2fb77ca99f
Gaia Date              2015-06-04 07:46:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f2157a04d75b
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150604.195634
Firmware Date          Thu Jun  4 19:56:49 EDT 2015
Bootloader             HHZ12f
See Also: → 1172823

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.