[RTL][First Time Experience]The Wi-Fi name is not right-aligned at Select a network view.

VERIFIED FIXED in 2.2 S14 (12june)

Status

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: sfoster)

Tracking

({regression})

unspecified
2.2 S14 (12june)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master unaffected)

Details

(Whiteboard: [2.2-nexus-5-l] [systemsfe])

Attachments

(5 attachments)

Reporter

Description

4 years ago
[1.Description]:
[RTL][Flame v2.2][Nexus5 2.2][First Time Experience]The Wi-Fi name is left-aligned and locats at right side of Wi-Fi icon at Select a network view in FTE.
See attachment:Select a network view.png

[2.Testing Steps]: 
1. Flash device and set system language as Arabic at FTE.
2. Tap "Next" button until navigating to "Select a network" view.
3. Observe this view.

[3.Expected Result]: 
3. The Wi-Fi name should be right-aligned.

[4.Actual Result]: 
3. The Wi-Fi name is left-aligned.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150531162502
Gaia Revision          b4582cc394e0919623263997c0cdb0b4751a1403
Gaia Date              2015-05-31 11:06:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/78d8b0a4303d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150531.195816
Firmware Date          Sun May 31 19:58:28 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (unaffected)
Build ID               20150531160203
Gaia Revision          e6dc0f4c583407a4a52a66ce7cb11f058302a762
Gaia Date              2015-05-29 17:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f8d21278244b
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150531.192324
Firmware Date          Sun May 31 19:23:35 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150531002502
Gaia Revision          0a46394dbee0ed2eb71a136cee38ddd8549dd597
Gaia Date              2015-05-30 14:50:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ed2f6aeb1d81
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150531.043812
Firmware Date          Sun May 31 04:38:27 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (unaffected)
Build ID               20150531160203
Gaia Revision          e6dc0f4c583407a4a52a66ce7cb11f058302a762
Gaia Date              2015-05-29 17:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f8d21278244b
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150531.192050
Firmware Date          Sun May 31 19:21:07 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Assignee

Comment 1

4 years ago
Possibly regression from bug 1161456? Nominating to block on this, I'll look into it asap.
Assignee: nobody → sfoster
blocking-b2g: --- → 2.2?
Triage: P1. Adding regression keyword. Sam do you want a regression window for this?
Flags: needinfo?(sfoster)
Keywords: regression
Priority: -- → P1
Assignee

Comment 3

4 years ago
Posted image ftu-rtl-wifi-v22.png
I couldn't reproduce this just now, using the v2.2 branch on my flame. If you can confirm and if necessary get a regression window that would be great
Flags: needinfo?(sfoster)
Seems like I can repro on Flame 2.2 pvt user build from today. Asking for regression window
QA Contact: pcheng
b2g-37 (v2.2) branch regression window:

Last Working
Device: Flame
BuildID: 20150526211213
Gaia: 8084264c4d1e28bc33220bc7443c7425bb76dbcc
Gecko: 19fcc06fb7ab
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken
Device: Flame
BuildID: 20150527102113
Gaia: 246851a4c68102df9828c1a75f9dcabef35ffe9b
Gecko: 2e52880a8889
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Last Working Gaia First Broken Gecko - issue does NOT repro
Gaia: 8084264c4d1e28bc33220bc7443c7425bb76dbcc
Gecko: 2e52880a8889

Last Working Gecko First Broken Gaia - issue DOES repro
Gaia: 246851a4c68102df9828c1a75f9dcabef35ffe9b
Gecko: 19fcc06fb7ab

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/8084264c4d1e28bc33220bc7443c7425bb76dbcc...246851a4c68102df9828c1a75f9dcabef35ffe9b

Caused by the patch for bug 1161456.

Note that the patch also landed on central but I checked a 5/27 central build and issue doesn't reproduce there. There might be something unique on v2.2 branch and that patch reveals the issue, or vice versa on central.
Blocks: 1161456
QA Whiteboard: [rtl-impact] → [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Sam, can you take a look at this please? This might have been caused by the uplift for bug 1161456.
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(sfoster)
Assignee

Updated

4 years ago
Flags: needinfo?(sfoster)
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l] [systemsfe]
Assignee

Comment 7

4 years ago
This works out differently on v2.2 vs. master. On both branches, the network names (which might be ltr or rtl) have a text-align: start. But on v2.2 the start edge is determined by the immediate context - the dir="auto" paragraph container, which in the case of a latin-characterset network name is LTR. On master, with the same markup and CSS, the start edge is determined by the document direction? This may be a regression on master, but regardless, the patch applies the correct fix for v2.2 - per the spec, we want the labels always right-aligned for RTL.
Assignee

Comment 8

4 years ago
Comment on attachment 8614170 [details] [review]
PR to right-align RTL wifi list item labels in v2.2

Ted, can you look this over? Its a trivial patch, but I want to get this on your radar anyway as it might point out a bidi issue on master. We're very tight on time obviously - so I'm also assigning to Fernando in case you don't get to it.
Attachment #8614170 - Flags: review?(tclancy)
Attachment #8614170 - Flags: review?(fernando.campo)
Comment on attachment 8614170 [details] [review]
PR to right-align RTL wifi list item labels in v2.2

Looks fine to me.
Attachment #8614170 - Flags: review?(tclancy) → review+
Comment on attachment 8614170 [details] [review]
PR to right-align RTL wifi list item labels in v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL/Bidi bug in FTU, regression caused by 1161456.
[User impact] if declined: Network names on the wifi screen are badly misaligned
[Testing completed]: Tested on device with both LTR and RTL languages, with both LTR and RTL network names
[Risk to taking this patch] (and alternatives if risky): V. low, css-only fix that only impacts these list items
[String changes made]: None
Attachment #8614170 - Flags: review?(fernando.campo) → approval-gaia-v2.2?
blocking-b2g: 2.2? → 2.2+

Updated

4 years ago
Attachment #8614170 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Updated

4 years ago
Keywords: verifyme
Target Milestone: --- → 2.2 S14 (12june)
v2.2: https://github.com/mozilla-b2g/gaia/commit/390177bd93b4b95c5a9c8b753d1ce54631fe3ea4
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Reporter

Comment 12

4 years ago
Posted image verify_v2.2_pass.png
This issue has been verified as pass on latest build of Flame 2.2 by STRs in comment 0.
Result: The Wi-Fi name is right-aligned.
See attachment:verify_v2.2_pass.png
Rate: 0/5

Device: Flame 2.2 (pass)
Build ID               20150604162503
Gaia Revision          8fc797527a3eca7665bc1d1828848f2fb77ca99f
Gaia Date              2015-06-04 07:46:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f2157a04d75b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150604.195708
Firmware Date          Thu Jun  4 19:57:20 EDT 2015
Bootloader             L1TC000118D0
Reporter

Comment 13

4 years ago
This issue also has been verified as pass on latest build of Nexus5 2.2 by STRs in comment 0.
Result: The Wi-Fi name is right-aligned.
Rate: 0/5

Device: Nexus 5 2.2 (pass)
Build ID               20150604162503
Gaia Revision          8fc797527a3eca7665bc1d1828848f2fb77ca99f
Gaia Date              2015-06-04 07:46:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f2157a04d75b
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150604.195634
Firmware Date          Thu Jun  4 19:56:49 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact][QAnalyst-Triage+] → [rtl-impact][QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.