Closed Bug 1170371 Opened 5 years ago Closed 2 years ago

[Aries] Device takes 30+ seconds to establish a connection with AT&T cell network.

Categories

(Firefox OS Graveyard :: Hardware, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog, b2g-master unaffected)

RESOLVED WONTFIX
tracking-b2g backlog
Tracking Status
b2g-master --- unaffected

People

(Reporter: Marty, Unassigned)

References

()

Details

(Whiteboard: [3.0-Daily-Testing][Spark])

Attachments

(3 files)

Attached file logcat-SIM-Connect.txt
Description:
After booting up the device, or entering SIM PIN, network status will list as zero bars of connectivity strength. This lasts for about 30-35 seconds.

The device will display a "No Network Connection" error if the user attempts to make a call during this time.

Note: This does not occur with T-Mobile SIMs

Repro Steps:
1) Update a Xperia Z3 Compact (B2G) to 20150601153918
2) Boot up the phone and note the cell connectivity strength.
3) Wait approximately 30 seconds.

Actual:
The device takes 30+ seconds to connect to the AT&T cell network.

Expected:
The device connects to the AT&T cell network in <2 seconds.

Environmental Variables:
Device: Xperia Z3 Compact (B2G) 3.0
Build ID: 20150601153918
Gaia: Unknown
Gecko: 666b584fb521
Version: 41.0a1 (3.0)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Repro frequency: 5/5
See attached: Video (URL), Logcat
This does not occur on Flame 3.0 builds.
Flame device connects to the AT&T cell network in approximately 1-2 seconds.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150601010203
Gaia: e6dc0f4c583407a4a52a66ce7cb11f058302a762
Gecko: f8d21278244b
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]: Basic functionality which will affect many dogfooders.
blocking-b2g: --- → spark?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Hei Gabriele,

do you have a spark device to test this? Is something that can be reproduced in flame?
Flags: needinfo?(gsvelto)
I don't have an aries yet, I'm still waiting for mine. That being said even if I had one I don't have acccess to an AT&T network. Tamara does however IIRC, Tamara did you ever encounter this behavior on the Flame?
Flags: needinfo?(gsvelto) → needinfo?(thills)
BTW I don't think this is a dialer issue, it's most likely a RIL one.
Naoki, could you try reproing this with RIL debugging enabled?
blocking-b2g: spark? → spark+
Flags: needinfo?(nhirata.bugzilla)
Attached file logcat.log
It took a while for the AT&T to connect after the ftu.  I think 30 seconds is about right.  Logcat with the ril debug on in a private build (self made).
Flags: needinfo?(nhirata.bugzilla)
Gecko/gaia of build in comment 7.

Build ID               20150603185314
Gaia Revision          0b00f058eeee79a05345b793eb5efa19f166ab3f
Gaia Date              2015-06-03 21:20:31
Gecko Revision         2b848889f879dd017906f0f41e8dc3e2f9f9a507
Gecko Version          41.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.naoki.20150603.173316
Firmware Date          Wed Jun  3 17:34:21 PDT 2015
Bootloader             s1
Hsin-Yi, since you are looking at bug 1170215; could you look at this bug too?  logcat with ril-debug turned on in the second logcat.
Flags: needinfo?(htsai)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #9)
> Hsin-Yi, since you are looking at bug 1170215; could you look at this bug
> too?  logcat with ril-debug turned on in the second logcat.

Edgar, can you kindly help this?
Flags: needinfo?(htsai) → needinfo?(echen)
I saw device connect to network in line#1307, but I don't know how much time it takes.

> I/Gecko   (  320): MobileConnectionService: notifyNetworkInfoChanged for 0: {"rilMessageType":"networkinfochanged","rilMessageClientId":0,"signal":{"voice":{"signalStrength":-83,"relSignalStrength":100},"data":{"signalStrength":-83,"relSignalStrength":100},"rilMessageType":"signalstrengthchange"},"voiceRegistrationState":{"regState":1,"state":"registered","connected":true,"roaming":false,"emergencyCallsOnly":false,"cell":{"gsmLocationAreaCode":56994,"gsmCellId":796398},"radioTech":3,"type":"umts","rilMessageType":"voiceregistrationstatechange"},"dataRegistrationState":{"regState":1,"state":"registered","connected":true,"roaming":false,"emergencyCallsOnly":false,"cell":{"gsmLocationAreaCode":56994,"gsmCellId":796398},"radioTech":3,"type":"umts","rilMessageType":"dataregistrationstatechange"},"operator":{"rilMessageType":"operatorchange","longName":"AT&T","shortName":"","mcc":"310","mnc":"410"}}

Naoki, could you help to capture log again (at the beginning of device boot-up) with displaying time information? And also dump the log from radio buffer in case we need more information. Thank you.
 
`adb logcat -v threadtime -b main -b radio`
Flags: needinfo?(echen) → needinfo?(nhirata.bugzilla)
Attached file logcat.log
Per request.  New Build used, you can find it here: 
https://drive.google.com/a/mozilla.com/file/d/0B_0LdM1CVycIS3lsX1NhZ0lieHc/view?usp=sharing
Flags: needinfo?(nhirata.bugzilla)
On my AT&T SIM, I see the bars show up about 6 seconds after bootup.  I immediately go and make a phone call and this call completes successfully.  

This is on my flame.

LEt me know if you need logs or anything.

Thanks,

-tamara
Flags: needinfo?(thills)
From the RIL perspective, I didn't find any obvious error in the logs. Modem reports connected at 15:33:30.254. Before that gecko didn't receive any connected event from modem. It more look like a device/modem behaviour to me. (And as mentioned in comment #0: This does not occur with T-Mobile SIMs, it seems this only occurs on AT&T SIMs)

> 06-04 15:33:30.254   318   807 I Gecko   : RIL Worker: [0] Handling parcel as REQUEST_VOICE_REGISTRATION_STATE
> 06-04 15:33:30.254   318   807 I Gecko   : RIL Worker: [0] Received voiceRegistrationState network info.
> 06-04 15:33:30.254   318   807 I Gecko   : RIL Worker: [0] Still missing some more network info, not notifying main thread.
> 06-04 15:33:30.254   318   807 I Gecko   : RIL Worker: [0] voice registration state: 1,de84,00446238,3,,,,0,,,,,,0,1e6
> 06-04 15:33:30.274   318   318 I Gecko   : MobileConnectionService: notifyNetworkInfoChanged for 0: {"rilMessageType":"networkinfochanged","rilMessageClientId":0,"signal":{"voice":{"signalStrength":-73,"relSignalStrength":100},"data":{"signalStrength":-73,"relSignalStrength":100},"rilMessageType":"signalstrengthchange"},"voiceRegistrationState":{"regState":1,"state":"registered","connected":true,"roaming":false,"emergencyCallsOnly":false,"cell":{"gsmLocationAreaCode":56964,"gsmCellId":4481592},"radioTech":3,"type":"umts","rilMessageType":"voiceregistrationstatechange"},"dataRegistrationState":{"regState":1,"state":"registered","connected":true,"roaming":false,"emergencyCallsOnly":false,"cell":{"gsmLocationAreaCode":56964,"gsmCellId":4481592},"radioTech":3,"type":"umts","rilMessageType":"dataregistrationstatechange"},"operator":{"rilMessageType":"operatorchange","longName":"AT&T","shortName":"","mcc":"310","mnc":"410"}}
Flags: needinfo?(echen)
Edgar, Hsin-Yi, can one of you take this please?
Flags: needinfo?(htsai)
Flags: needinfo?(echen)
Assignee: nobody → echen
Component: Gaia::Dialer → RIL
Flags: needinfo?(htsai)
Flags: needinfo?(echen)
Summary: [Aries][Dialer] Device takes 30+ seconds to establish a connection with AT&T cell network. → [Aries] Device takes 30+ seconds to establish a connection with AT&T cell network.
I cannot reproduce this with my chunghwa sim, either, aries takes just few seconds to establish connection.

Hi Naoki, could you try Android version with same AT&T sim card to see if this occurs on Android version? Thank you.
Flags: needinfo?(nhirata.bugzilla)
Smells like some roaming/frequency scanning ?
(In reply to Alexandre LISSY :gerard-majax from comment #18)
> Smells like some roaming/frequency scanning ?

I guess so, but we don't know the behaviour exactly, it is controlled by modem.
Alexandre, I believe that to be the case.

It took me awhile to find a kk build to test with and I then had some issues with flashing.  (apparantly the flashtool uses no instead of yes... for flashing)

I flashed Android KK and Android L version of aries and they are both showing the same issue of taking 30 seconds to connect.  I'm not sure we can do anything about this?
Flags: needinfo?(nhirata.bugzilla) → needinfo?(echen)
Except RESOLVED:INVALID ? I know the SIM card exposes values for the HPLMN and the time we should spend trying. At some point in MozRIL we did not support this, I'm unsure of the current status ...
[Blocking Requested - why for this release]:
Renoming this issue as Android KK and Android L version of aries are both showing the same behaviour with AT&T sim.
blocking-b2g: spark+ → spark?
Unfortunately, without device manufacturer support, there is nothing we can do.
Assignee: echen → nobody
Component: RIL → Hardware
Flags: needinfo?(echen)
(In reply to Edgar Chen [:edgar][:echen] from comment #23)
> Unfortunately, without device manufacturer support, there is nothing we can
> do.

It's sad but true. I can foresee we will encounter issues that can't be fixed by ourselves on Spark.
Alin, could you help us out here?
Flags: needinfo?(alin.jerpelea)
I don't hava AT&T sim
I have tested AOSP with 3 sims and i get GSM in <10sec
Flags: needinfo?(alin.jerpelea)
blocking-b2g: spark? → 2.5?
blocking-b2g: 2.5? → 2.5+
Keywords: qawanted
This issue is still occurring on the latest Spark Aries builds when using AT&T SIM cards. After booting up and inputting a SIM Pin, the device displays no cellular signal (greyed-out signal strength with an 'x' over it) for about 35 seconds before finally establishing a proper connection to the cellular network. During this time, the user is unable to send or receive phone calls, SMS messages, or use cellular data.

This issue does not occur using T-Mobile SIM cards.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150814042814
Gaia: 39b121515ab8a8c3ea07f26d3ba1dd792e90217c
Gecko: 4e883591bb5dff021c108d3e30198a99547eed1e
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: mshuman
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
P2 priority for 2.5 Release
Priority: -- → P2
[Tracking Requested - why for this release]:

As its Network/vendor dependent issue, removing as 2.5 blocker. Adding it as part of backlog. 

Needs more test with At&t. Hsin-Yi reports issue is found with Android too.
blocking-b2g: 2.5+ → ---
(In reply to Mahendra Potharaju [:mahe] from comment #29)
> [Tracking Requested - why for this release]:
> 
> As its Network/vendor dependent issue, removing as 2.5 blocker. Adding it as
> part of backlog. 
> 
> Needs more test with At&t. Hsin-Yi reports issue is found with Android too.

Actually, not reported by me, but by our QA, see comment 20 :)
See Also: → 1221051
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.