Candy Crush Saga is not loading on the first try when using a new profile

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: VarCat, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(firefox40 ?)

Details

(Reporter)

Description

2 years ago
Environment:

FF 39.0b2
Build Id: 20150601171003
OS: Win 7 x64, Mac Os X 10.9.5

STR:

1. Create a new FF profile.
2. Start FF using the newly created profile.
3. Login to facebook and start Candy Crush Saga.

Issue:
On the first try Candy Crush Saga remains stuck on 100% load, however if you are refreshing the page the game successfully loads.

Note:
The bug is not reproducible with dom.ipc.plugins.asyncInit set on false
The bug is not reproducible on FF 41 Nightly.
(Reporter)

Updated

2 years ago
Blocks: 1116806

Updated

2 years ago
Flags: needinfo?(aklotz)
This is an odd one. It's not so much that the profile is new, it's that the game's assets are not in the cache. It's reproducible the first time you run Candy Crush Saga after clearing the cache.
Flags: needinfo?(aklotz)

Comment 2

2 years ago
I belive I found this bug on Firefox 40 beta 7

1.-Open https://www.facebook.com/login.php?skip_api_login=1&api_key=210831918949520&signed_next=1&next=https%3A%2F%2Fwww.facebook.com%2Fv2.1%2Fdialog%2Foauth%3Fredirect_uri%3Dhttps%253A%252F%252Fapps.facebook.com%252Fcandycrush%252F%253Ffb_locale%253Des_LA%2526ref%253Dbookmarks%2526count%253D0%2526fb_source%253Dbookmark%2526fb_bmpos%253D_0%2526_retry%253D1%26scope%3Demail%252Cuser_friends%26response_type%3Dtoken%26client_id%3D210831918949520%26ret%3Dlogin&cancel_url=https%3A%2F%2Fapps.facebook.com%2Fcandycrush%2F%3Ffb_locale%3Des_LA%26ref%3Dbookmarks%26count%3D0%26fb_source%3Dbookmark%26fb_bmpos%3D_0%26_retry%3D1%26error%3Daccess_denied%26error_code%3D200%26error_description%3DPermissions%2Berror%26error_reason%3Duser_denied%23_%3D_&display=page 

2.-when the game was loading flash 18_0_0_209 crashes  
like https://crash-stats.mozilla.com/report/index/4a993ef9-3002-4e3a-8469-817942150725

Catalin,

Is this the same bug or a new one?
status-firefox40: --- → ?
Flags: needinfo?(catalin.varga)
(Reporter)

Comment 3

2 years ago
This is not the same bug this is a crash, but it appears, based on Socorro that you are the only one that suffered this crash.
Flags: needinfo?(catalin.varga)
I am no longer able to reproduce this on 40 Beta or on Nightly with e10s off and asyncInit on. Catalin, could you please verify?
Flags: needinfo?(catalin.varga)
(Reporter)

Comment 5

2 years ago
I tried reproducing this bug as part of the beta sign-off testing of async plugin feature and could not reproduce it. Another bug I could not reproduce was bug 1171948 .
Flags: needinfo?(catalin.varga)
Should we resolve this bug and bug 1171948, then?
Flags: needinfo?(catalin.varga)
(Reporter)

Comment 7

2 years ago
Yeah I'll mark them as Resolved worksforme.

This bug is not reproducible on build:

FF 40 
Build Id: 20150730171029
OS: Win 7 x64
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(catalin.varga)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.