[REPRO]Screen and scrollbar gets messed up in print preview

VERIFIED FIXED in mozilla0.9.9

Status

()

--
major
VERIFIED FIXED
17 years ago
12 years ago

People

(Reporter: joonas, Assigned: dcone)

Tracking

({regression})

Trunk
mozilla0.9.9
x86
Windows 98
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [driver:blizzard] has reviewed patch)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Screen gets messed up in print preview. It can be reproduced with any page.
(Reporter)

Comment 1

17 years ago
Created attachment 62838 [details]
Picture of the messed up screen.

Comment 2

17 years ago
Adding info from attachment (screenshot of 'about:'): 

Mozilla 0.9.7
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7) Gecko/20011221
This was also mentioned in bug 116343.  Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 4

17 years ago
confirming..I see the problem also...

Comment 5

17 years ago
*** Bug 117083 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
scrollbar also gets messed up...

nominating nsbeta1
Severity: normal → critical
Keywords: nsbeta1
Summary: Screen gets messed up in print preview → Screen and scrollbar gets messed up in print preview

Comment 7

17 years ago
*** Bug 117095 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Severity: critical → major
Confirmed for Build 2001122611.

The scrollbars are completely messed up, but also the margins.

Comment 9

17 years ago
How the heck did M0.9.7 manage to ship with this bug???
Colin, print preview currently has no functioning keyboard shortcuts and broken 
scrolling.  The browser UI is effectively severely crippled in this mode...  I 
think it's being treated as an experimental feature for milestone testing 
purposes...

Comment 11

17 years ago
Boris, I understand that this feature is still under development, but this is a 
major regression in M0.9.6 where it worked pretty well.

Comment 12

17 years ago
... and I cannot select/copy text in print preview mode ...

Comment 13

17 years ago
I am not sure why this is all screwed up......

Roland, you won't ever be able to select and copy text in PP
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.8

Comment 14

17 years ago
rods@netscape.com wrote:
> Roland, you won't ever be able to select and copy text in PP

Why ? Why isn't "print preview" just another browser "mode" ?
*** Bug 117333 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Roland, are there other apps that you can select/copy while in Print Preview?
Although, I see that it would be useful I don't think there is much of a
precedent for it. And right now selection and the rendering of selection just
doesn't work at all in PP. Feel free to file RFE, but it won't get looked at for
a very long time.

Comment 17

17 years ago
Is this reproducable onWin98 with a specific page. I haven't see it do this.

Updated

17 years ago
Summary: Screen and scrollbar gets messed up in print preview → [REPRO]Screen and scrollbar gets messed up in print preview

Comment 18

17 years ago
*** Bug 117860 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
Rod, happens with any page...

Comment 20

17 years ago
*** Bug 117969 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
Using Mozilla build ID 2002010303 on Windows 2000, I get very inconsistent
results with Print Preview.

On page http://java.sun.com/, the screen image is completely distored when Print
Preview is selected, and the browser freezes completely.  (Windows Task Manager
indicates Mozilla is 'not responding'.)   It is necessary to terminate Mozilla
via Task Manager.

On page http://www.visitor.calgary.ab.ca/, the screen image appears normal when
Print Preview is selected, and Windows Task Manager indicates that Mozilla is
'running'.   However, neither the Refresh button nor the Back button work
properly after Print Preview is selected.   Refresh does not return the screen
image to its normal state; Back does not go back to a prior page.   The only way
to leave the Print Preview mode is to terminate Mozilla in Windows Task Manager.

On page http://www.netscape.com/, Print Preview appears to work normally.   
Both the Back and Reload buttons work properly following the selection of Print
Preview.
(Assignee)

Comment 22

17 years ago
Taking
Assignee: rods → dcone
Status: ASSIGNED → NEW
(Assignee)

Comment 23

17 years ago
Created attachment 63498 [details] [diff] [review]
Small patch to set the background paint to true before painting.

Patch to fix all the blackness in PrintPreview when the background painting is
turned off.

Comment 24

17 years ago
PLEASE check this in!!!!!
r=rods
(Assignee)

Comment 25

17 years ago
Created attachment 63818 [details] [diff] [review]
fixed some small.. problems from the last patch.
Attachment #63498 - Attachment is obsolete: true

Comment 26

17 years ago
*** Bug 118519 has been marked as a duplicate of this bug. ***

Comment 27

17 years ago
Comment on attachment 63818 [details] [diff] [review]
fixed some small.. problems from the last patch.

sr=attinasi
Attachment #63818 - Flags: superreview+
(Assignee)

Comment 28

17 years ago
*** Bug 118888 has been marked as a duplicate of this bug. ***

Comment 29

17 years ago
related to comment #16,

> Roland, are there other apps that you can select/copy while in Print Preview?

WordPerfect 9 and 10, and maybe even wordperfect 8

I agree though that this behaviour isn't common, a "print preview" is usually to
show what your print would look like, not to manipulate the content.
(Assignee)

Comment 30

17 years ago
Created attachment 65069 [details] [diff] [review]
Temporary fix for print peview.. will make sure print preview always has backgrounds turned on.

Comment 31

17 years ago
compiled and test - look good r=rods

Comment 32

17 years ago
Comment on attachment 65069 [details] [diff] [review]
Temporary fix for print peview.. will make sure print preview always has backgrounds turned on.

sr=attinasi

Fix the comment though, it is incomplete and has a typo: 
+  // only turn of background printing if its a

Also, won't this turn on backgrounds for printing to printer as well? Is that
what you want?
Attachment #65069 - Flags: superreview+
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Comment 33

17 years ago
it seems that the patch worked ... :)
not seeing this bug anymore (up to now).

+Adding myself to CC
Whiteboard: [driver:blizzard]
Whiteboard: [driver:blizzard] → [driver:blizzard] has reviewed patch, needs checkin?
(Assignee)

Comment 34

17 years ago
fixed.. and checked in.. actually before the close.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 35

17 years ago
looks fine to me now...

marking verified-fixed..

Joonas, REOPEN if you still see a problem...shoud work now in latest build.
Status: RESOLVED → VERIFIED

Updated

12 years ago
Whiteboard: [driver:blizzard] has reviewed patch, needs checkin? → [driver:blizzard] has reviewed patch
You need to log in before you can comment on or make changes to this bug.