Make it clear a password is not required when setting up a new IRC account

RESOLVED DUPLICATE of bug 741566

Status

Chat Core
IRC
RESOLVED DUPLICATE of bug 741566
3 years ago
2 years ago

People

(Reporter: Svetlana A. Tkachenko, Unassigned)

Tracking

trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Please, when setting Thunderbird chat users with an IRC account, please do not ask them to enter a password; connecting to irc, unlike XMPP, does not require a password, and typing a wrong password has the abovementioned misconfiguration which users fail to spot and hence start annoying other users.

Many many many thunderbird chat users don't even know that they are connected to IRC. pming them ascii art of flying foxes does nothing. Meanwhile these thunderbird chat clients are misconfigured and bother legitimate irc users with failed auth attempt notices from NickServ.

This ought to be fixed. Thanks.
(Reporter)

Updated

3 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
(In reply to Svetlana A. Tkachenko from comment #0)
> connecting to irc, unlike XMPP, does not require a password,
This depends on the network and account you're connecting.

> and typing a wrong password has the abovementioned
> misconfiguration
sorry, I'm not sure what this is referring to.

> pming them ascii art of flying foxes does nothing.
I have no idea what this is referring to.

> Meanwhile these thunderbird chat clients are misconfigured and bother
> legitimate irc users with failed auth attempt notices from NickServ.
This shouldn't bother legitimate users, it should force them to change their nick (assuming you have your IRC account configured in a sane way in NickServ).

> This ought to be fixed. Thanks.
I don't see what there is to fix. The password field is a legitimate field that is necessary to authenticate with NickServ.

It sounds to me that you're annoyed if someone else chooses your nick (and then NickServ tells you someone else failed to authenticate or something)? I'd suggest setting KILL to ON or QUICK or IMMED: tell NickServ "SET KILL ON" when authenticated as your account.
(Reporter)

Comment 2

3 years ago
> > connecting to irc, unlike XMPP, does not require a password,
> This depends on the network and account you're connecting.

When the user connects to irc first time, they usually do not have a password. This fact should be recognized: right now the thunderbird new irc account wizard prompts for the password before the user even figures out whether he has an account on the irc server or not, and does not explain the user that they should leave the field empty if they don't have an account. The impression an average user gets is that they need to set the password now in order to register on the server. This is *wrong*.

(If a user does not notice a message from nickserv saying that they failed to authenticate, and does not notice hundreds of new lines received in pms, then they won't notice a message from the server saying that they are disconnected. I prefer to make the users aware of the issue instead of putting head in sand.)
(Reporter)

Comment 3

3 years ago
In other words:

str:
1) Create an IRC account

expected:
1) The program tells me that the password is only required if I have an existing IRC account

actual results:
1) The program has a password box which does not explain what the password is for


--

str:
1) Log in to IRC with a wrong password

expected:
1) visible notification

actual:
1) no notification

Comment 4

3 years ago
clokep, in your opinion this is not a thunderbird problem and therefore close bug invalid?
Flags: needinfo?(clokep)
(Reporter)

Comment 5

3 years ago
Please stop misinforming people.

Having users specify a password without telling them that they're 99% likely not registered and that specifying the password won't register them is inadequate and is the client software problem.

Updated

3 years ago
Status: UNCONFIRMED → NEW
Component: Instant Messaging → IRC
Ever confirmed: true
Product: Thunderbird → Chat Core
Summary: Thunderbird chat should not ask for a password when creating IRC connections → Make it clear a password is not required when setting up a new IRC account
Version: unspecified → trunk

Comment 6

3 years ago
(In reply to Svetlana A. Tkachenko from comment #3)
> In other words:
> 
> str:
> 1) Create an IRC account
> 
> expected:
> 1) The program tells me that the password is only required if I have an
> existing IRC account
> 
> actual results:
> 1) The program has a password box which does not explain what the password
> is for

Thanks for this report. The IRC account creation process could indeed be improved in various ways for inexperienced users.

> str:
> 1) Log in to IRC with a wrong password
> 
> expected:
> 1) visible notification
> 
> actual:
> 1) no notification

There is in fact a report in the account manager if the fact that the password is incorrect means the connection cannot be established.
(Reporter)

Comment 7

3 years ago
I am assuming that (following my inadequate filing of the bug) one half of the report is confirmed as a valid bug, and there is no need in the needinfo request anymore.
Flags: needinfo?(clokep)
Making it more obvious that the password is optional is probably OK. I don't think any of that is customizable right now, unfortunately.
Just realized we had a bug filed for this: bug 741566.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741566
You need to log in before you can comment on or make changes to this bug.