Crash after right-clicking picture

VERIFIED DUPLICATE of bug 114377

Status

()

--
critical
VERIFIED DUPLICATE of bug 114377
17 years ago
11 years ago

People

(Reporter: erik.fornoff, Assigned: hyatt)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Environment:
==============
OS: Win NT 4.0 SP-6
Mozilla BuildID:    2001112703



Summary:
=========
After right-clicking a picture which contains a link on above named site mozilla
crashes...

Reproducible: always


Steps to Reproduce:
====================

- start mozilla and enter www.web.de in location bar

- on the upper left side right-click the yellow picture labeled "web.de"


Actual Results:  
================
Mozilla crashes.



Expected Results:  
==================
Context menu appears...



Additional Information:
========================
Perhaps this is a duplicate of #114377 but as I don't have a stack trace I can't
tell whether it's a duplicate one or not...

Comment 1

17 years ago
As you mention, it must be dupe of bug 114377 (same crash on map area).
Do you have a Talkback ID for this crash ?
Keywords: crash
I hate mid-airs :-)

very nice bug report !

win2k stack trace : 
nsIFrame::GetStyleData(nsStyleStructID eStyleStruct_UserInterface, const 
nsStyleStruct * & 0x0012deb0) line 561 + 3 bytes
XULPopupListenerImpl::FireFocusOnTargetContent(nsIDOMNode * 0x03b66724) line 334
XULPopupListenerImpl::PreLaunchPopup(nsIDOMEvent * 0x03ca0a88) line 298
XULPopupListenerImpl::ContextMenu(XULPopupListenerImpl * const 0x037e2550, 
nsIDOMEvent * 0x03ca0a88) line 204 + 15 bytes
nsEventListenerManager::HandleEvent(nsEventListenerManager * const 0x037e25a0, 
nsIPresContext * 0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x0012f084, 
nsIDOMEventTarget * 0x037ac5c8, unsigned int 2, nsEventStatus * 0x0012f6b4) line 
1485 + 41 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x037ac5c0, nsIPresContext * 
0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x0012f084, unsigned int 2, 
nsEventStatus * 0x0012f6b4) line 3449
nsXULElement::HandleChromeEvent(nsXULElement * const 0x037ac5d0, nsIPresContext 
* 0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x0012f084, unsigned int 2, 
nsEventStatus * 0x0012f6b4) line 4657 + 36 bytes
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x0386eb78, 
nsIPresContext * 0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x0012f084, 
unsigned int 2, nsEventStatus * 0x0012f6b4) line 659
nsDocument::HandleDOMEvent(nsDocument * const 0x03af4a78, nsIPresContext * 
0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x0012f084, unsigned int 2, 
nsEventStatus * 0x0012f6b4) line 3091
nsGenericElement::HandleDOMEvent(nsGenericElement * const 0x03ada100, 
nsIPresContext * 0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x0012f084, 
unsigned int 2, nsEventStatus * 0x0012f6b4) line 1676 + 39 bytes
nsGenericElement::HandleDOMEvent(nsGenericElement * const 0x03b57e50, 
nsIPresContext * 0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x0012f084, 
unsigned int 2, nsEventStatus * 0x0012f6b4) line 1669 + 50 bytes
nsGenericElement::HandleDOMEvent(nsGenericElement * const 0x03b5f048, 
nsIPresContext * 0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x0012f084, 
unsigned int 2, nsEventStatus * 0x0012f6b4) line 1669 + 50 bytes
nsGenericElement::HandleDOMEvent(nsGenericElement * const 0x03b5f308, 
nsIPresContext * 0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x0012f084, 
unsigned int 2, nsEventStatus * 0x0012f6b4) line 1669 + 50 bytes
nsGenericElement::HandleDOMEvent(nsGenericElement * const 0x03b66700, 
nsIPresContext * 0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x0012f084, 
unsigned int 1, nsEventStatus * 0x0012f6b4) line 1669 + 50 bytes
nsGenericHTMLElement::HandleDOMEventForAnchors(nsIContent * 0x03b66700, 
nsIPresContext * 0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x00000000, 
unsigned int 1, nsEventStatus * 0x0012f6b4) line 1312 + 32 bytes
nsHTMLAreaElement::HandleDOMEvent(nsHTMLAreaElement * const 0x03b66700, 
nsIPresContext * 0x03affac8, nsEvent * 0x0012f7bc, nsIDOMEvent * * 0x00000000, 
unsigned int 1, nsEventStatus * 0x0012f6b4) line 223
PresShell::HandleEventInternal(nsEvent * 0x0012f7bc, nsIView * 0x03b5c3d0, 
unsigned int 1, nsEventStatus * 0x0012f6b4) line 6065 + 38 bytes
PresShell::HandleEvent(PresShell * const 0x03b018bc, nsIView * 0x03b5c3d0, 
nsGUIEvent * 0x0012f7bc, nsEventStatus * 0x0012f6b4, int 0, int & 1) line 5984 + 
25 bytes
nsView::HandleEvent(nsView * const 0x03b5c3d0, nsGUIEvent * 0x0012f7bc, unsigned 
int 0, nsEventStatus * 0x0012f6b4, int 0, int & 1) line 387
nsView::HandleEvent(nsView * const 0x03b5b028, nsGUIEvent * 0x0012f7bc, unsigned 
int 0, nsEventStatus * 0x0012f6b4, int 0, int & 1) line 344
nsView::HandleEvent(nsView * const 0x03b01410, nsGUIEvent * 0x0012f7bc, unsigned 
int 0, nsEventStatus * 0x0012f6b4, int 1, int & 1) line 344
nsViewManager::DispatchEvent(nsViewManager * const 0x03b011d0, nsGUIEvent * 
0x0012f7bc, nsEventStatus * 0x0012f6b4) line 1930
HandleEvent(nsGUIEvent * 0x0012f7bc) line 83
nsWindow::DispatchEvent(nsWindow * const 0x03b5b0e4, nsGUIEvent * 0x0012f7bc, 
nsEventStatus & nsEventStatus_eIgnore) line 846 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f7bc) line 867
nsWindow::DispatchMouseEvent(unsigned int 500, nsPoint * 0x00000000) line 4420 + 
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 500, nsPoint * 0x00000000) line 
4672
nsWindow::ProcessMessage(unsigned int 123, unsigned int 197094, long 12255938, 
long * 0x0012fbb0) line 3355 + 26 bytes
nsWindow::WindowProc(HWND__ * 0x000301e6, unsigned int 123, unsigned int 197094, 
long 12255938) line 1111 + 27 bytes
USER32! 77e02e98()
USER32! 77e04876()
USER32! 77e0474c()
USER32! 77e04ef0()
USER32! 77e02e98()
USER32! 77e06a72()
USER32! 77e06aee()
nsWindow::WindowProc(HWND__ * 0x000301e6, unsigned int 517, unsigned int 0, long 
4784832) line 1118 + 31 bytes
USER32! 77e02e98()
USER32! 77e030e0()
USER32! 77e05824()
nsAppShellService::Run(nsAppShellService * const 0x00e2bd60) line 303
main1(int 2, char * * 0x003c6c70, nsISupports * 0x00000000) line 1264 + 32 bytes
main(int 2, char * * 0x003c6c70) line 1594 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e87d08()


*** This bug has been marked as a duplicate of 114377 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
Hmmm - how do I get such nice stack traces like Matti does? :o)

Well I have a TB-Id - here it is: TB980431G

Cheers, Erik

Comment 4

17 years ago
the stack trace above can be had if you build it yourself.
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.