Trunk Crash when attempting to attach something to a mail [@ nsFileView::GetSelectedFile]

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: loft74, Assigned: bryner)

Tracking

({crash, topcrash})

Trunk
x86
Linux
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20011222
BuildID:    20011222

When attaching something to an email, the file windows opens, displaying no
files at all. It just sits there empty, until you click on it, no matter where
you point your cursor. Then the whole thing just exits, and the Netscape -
talkback windows emerges.

Reproducible: Always
Steps to Reproduce:
1.Open "Mail & newsgroups"
2.Select "Compose"
3.Click "Attach"
4.Click somewhere on the attachment windows
5.Bye, bye Mozilla...;o)

Actual Results:  Mozilla crashed resulting in the Netscape talkback window being
activated.

Expected Results:  Should have displayed the contents of my "root" folder,
allowing me to select which file to attach to my email.

Comment 1

17 years ago
What was the talkback id? Run mozilla/components/talkback/talkback if you
already closed the talkback program.

Thanks
Keywords: crash

Updated

17 years ago
Summary: Exits when attempting to attach something to a mail → Crash when attempting to attach something to a mail

Comment 2

17 years ago
I can confirm this, with a bit more info. Using
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20011228

I have found that if I click Cancel in the file open dialog, and then reclick
the attachments button, this time the file dialog opens and has the normal list
there, and works fine.

Comment 3

17 years ago
Reporters talkback was: TB924192Y (reported via email). I also crashed
reproducing this using Linux 2001123021, talkback TB1076096Q.

CC: stephend@netscape.com, for talkback retrieval, please (TB924192Y, TB1076096Q)

Moving to Composition.
Assignee: sspitzer → ducarroz
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Composition
Ever confirmed: true
QA Contact: esther → sheelar

Comment 4

17 years ago
Created attachment 63121 [details]
Stacktrace, from cvs build

Attached a stacktrace. This is the first time I've made one, so I want to
compare this with the talkback.

Comment 5

17 years ago
*** Bug 116406 has been marked as a duplicate of this bug. ***
Stack Signature  nsFileView::GetSelectedFile() 0a79b6f1
Trigger Time 2001-12-26 15:34:17
Email Address
URL visited
User Comments
Build ID 2001122221
Product ID MozillaTrunk
Platform
Operating System LinuxIntel
Module
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
Stack Trace
nsFileView::GetSelectedFile()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Invoke()
js_InternalInvoke()
JS_CallFunctionValue()
nsJSContext::CallEventHandler()
nsJSEventListener::HandleEvent()
nsEventListenerManager::HandleEventSubType()
nsEventListenerManager::HandleEvent()
nsXULElement::HandleDOMEvent()
nsEventStateManager::SendFocusBlur()
nsEventStateManager::SetContentState()
nsXULElement::SetFocus()
nsEventStateManager::ChangeFocus()
nsEventStateManager::PostHandleEvent()
PresShell::HandleEventInternal()
PresShell::HandleEvent()
nsView::HandleEvent()
nsView::HandleEvent()
nsViewManager::DispatchEvent()
HandleEvent()
nsWidget::DispatchEvent()
nsWidget::DispatchWindowEvent()
nsWidget::DispatchMouseEvent()
nsWidget::OnButtonPressSignal()
nsWindow::HandleGDKEvent()
dispatch_superwin_event()
handle_gdk_event()
libgdk-1.2.so.0 + 0x17d7f (0x40358d7f)
libglib-1.2.so.0 + 0x11773 (0x4038c773)
libglib-1.2.so.0 + 0x11d39 (0x4038cd39)
libglib-1.2.so.0 + 0x11e1e (0x4038ce1e)
nsAppShell::DispatchNativeEvent()
nsXULWindow::ShowModal()
nsWebShellWindow::ShowModal()
nsContentTreeOwner::ShowAsModal()
nsWindowWatcher::OpenWindowJS()
GlobalWindowImpl::OpenInternal()
GlobalWindowImpl::OpenDialog()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Invoke()
nsXPCWrappedJSClass::CallMethod()
nsXPCWrappedJS::CallMethod()
PrepareAndDispatch()
nsXPTCStubBase::Stub14()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Invoke()
nsXPCWrappedJSClass::CallMethod()
nsXPCWrappedJS::CallMethod()
PrepareAndDispatch()
nsXPTCStubBase::Stub5()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Invoke()
js_InternalInvoke()
JS_CallFunctionValue()
nsJSContext::CallEventHandler()
nsJSEventListener::HandleEvent()
nsEventListenerManager::HandleEventSubType()
nsEventListenerManager::HandleEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
PresShell::HandleEventInternal()
PresShell::HandleEventWithTarget()
nsEventStateManager::CheckForAndDispatchClick()
nsEventStateManager::PostHandleEvent()
PresShell::HandleEventInternal()
PresShell::HandleEvent()
nsView::HandleEvent()
nsViewManager::DispatchEvent()
HandleEvent()
nsWidget::DispatchEvent()
nsWidget::DispatchWindowEvent()
nsWidget::DispatchMouseEvent()
nsWidget::OnButtonReleaseSignal()
nsWindow::HandleGDKEvent()
dispatch_superwin_event()
handle_gdk_event()
libgdk-1.2.so.0 + 0x17d7f (0x40358d7f)
libglib-1.2.so.0 + 0x11773 (0x4038c773)
libglib-1.2.so.0 + 0x11d39 (0x4038cd39)
libglib-1.2.so.0 + 0x11eec (0x4038ceec)
libgtk-1.2.so.0 + 0x94333 (0x402a7333)
nsAppShell::Run() 

Updated

17 years ago
QA Contact: sheelar → esther
this is a toolkit problem, reasign...
Assignee: ducarroz → hyatt
Component: Composition → XP Toolkit/Widgets
Product: MailNews → Browser
QA Contact: esther → jrgm

Comment 8

17 years ago
I can't reproduce this with either the mozilla 12-28 build, or with a trunk 
build pulled 2am this morning, on linux redhat 6.1. The file list always comes
up completely, and I don't crash. 
Assignee: hyatt → bryner

Comment 9

17 years ago
Are you exiting and restarting Mozilla? To get this, I leave an email in my
inbox, exit and restart Mozilla, select the email and click reply, and then
click attach. Broken every time. And I also tried completely blowing away my
entire Mozilla profile, and rebuilt it from scratch. The problem is still there,
Redhat 6.2, kernel 2.2.19-6.2.1, Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:0.9.7+) Gecko/20020102.

Comment 10

17 years ago
The 2001123108 Linux trunk build still crashes for me.  However I noticed that
if I click Cancel on the original File Window, then click attach again,
everything works fine. My linux version is RH 7.1

Comment 11

17 years ago
This one is on the Trunk topcrash lists. It shows up first in build 2001122306 
and has incidents through 2002010208 (yesterday).

Amending summary and keywords for talkback tracking.
Keywords: topcrash
Summary: Crash when attempting to attach something to a mail → Trunk Crash when attempting to attach something to a mail [@ nsFileView::GetSelectedFile]

Comment 12

17 years ago
A little more info.  If you have used the file select widget to do anything
else, prior to attempting to attach to an email, the bug is not pressent.  If I
click 'save link as' from a webpage and use the file select widget, I can attach
to an email without crashing.  But if the first thing I do after launching
Mozilla is attempt to attach to an email, it crashes every time.  It looks like
something is not being initialized correctly when the email front end calls the
file widget for the first time.
(Assignee)

Comment 13

17 years ago
*** Bug 118059 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

17 years ago
This should be fixed now, please reopen if it's not.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 15

17 years ago
I can verify this is fixed for me with the 2002010506 trunk build.
Crash Signature: [@ nsFileView::GetSelectedFile]
You need to log in before you can comment on or make changes to this bug.