ibm.com - Voice Systems - images not shown due to wrong doctype

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED WORKSFORME
17 years ago
3 years ago

People

(Reporter: Daniel Straessle, Assigned: bc)

Tracking

({testcase})

Details

(Whiteboard: [DOCTYPE-IMG][COMMENT-SYNTAX-FIXED], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

At the top of http://www-3.ibm.com/software/speech/ appear no images or text
belonging to those images. In Internet Explorer they do appear.

Reproducible: Always
Steps to Reproduce:
1. open http://www-3.ibm.com/software/speech/
2. look at the top of the page
3.

Comment 1

17 years ago
I see this problem too, win98SE, 2001122703.

This MIGHT be tech evang, but I can't see any obvious problem.

Confirming, and I'll go dig around in the source to see what I can find...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
OK, there are a couple of JS files referenced in the <head> of the page, which
document.write() different <link ...> tags for style sheets, and I think the JS
browser sniffing in them is duff.  But I DON'T think that's the problem.

There's a slab of code, which is meant to draw these images, and it looks like
Moz is _completely_ ignoring it.  The images don't show up in the right
click->view page info window at all.

Still digging...

Comment 3

17 years ago
Oh, Yuck.  That page hangs the DOM inspector on my build.  I'll log a new bug
for that...

Comment 4

17 years ago
OK, after much digging, a reduced testcase (I'll attach this as a file in a mo):

<!DOCTYPE html SYSTEM "http://www.ibm.com/data/dtd/v11/ibmxhtml1-transitional.dtd">
<html>
  <head>
    <title>IBM Voice Systems: ViaVoice Software</title>
  </head>
<body>
<table border="1">
  <tbody>
    <tr>
      <td>
<!-- Start: Body Content ------------------------->
        <img
src="http://t1d.www-4.cacheibm.com/software/speech/images/vs-home-title.gif"/>
      </td>
    </tr>
  </tbody>
</table>
</body>
</html>

The image doesn't appear.  Removing the doctype declaration will make the image
appear, as will either removing the HTML comment, or amending the comment so
that it terminates with " -->" instead of "------>"

My SWAG is that the doctype is triggering standards mode, which is then barfing
because of the incorrect html comment termination.  When it barfs, it wipes out
a huge slab of the following code, but recovers sufficiently to continue further
down the source file.

Any HTML/XHTML gurus out there willing to confirm that I'm (hopefully) not
talking rubbish?

Comment 5

17 years ago
Created attachment 62958 [details]
Reduced testcase

Comment 6

17 years ago
You are right Gavin, see bug 102127 for details.
This bug is INVALID. Reassigning to Evangelism.
Assignee: attinasi → doronr
Component: Layout → US General
Keywords: testcase
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Hardware: PC → All
Version: other → unspecified

Comment 7

17 years ago
Bingo!  For those that are interested, read 

http://bugzilla.mozilla.org/show_bug.cgi?id=102127#c16
and
http://bugzilla.mozilla.org/show_bug.cgi?id=102127#c17

for details of what's going on.

Contact details at: http://www.ibm.com/contact/, and a webmail feedback form at
http://www.ibm.com/contact/query  

Assuming Mozilla.org doesn't have better routes thanks to IBM contributors...

Updated

17 years ago
Whiteboard: aok
(Assignee)

Updated

16 years ago
Blocks: 114157
Keywords: evang500
Summary: different layout than in internet explorer; images won't be shown → ibm.com - different layout than in internet explorer; images won't be shown
(Assignee)

Comment 8

16 years ago
taking, DOCTYPE issues have been communicated to IBM.
Assignee: doronr → bclary
Whiteboard: aok → [DOCTYPE][COMMENT-SYNTAX]
I can't see somthing diffent to other IBM problems..
(Assignee)

Comment 10

16 years ago
there is still a gap under the IBM image in the top left. They have not fixed
the image inline box model in the table although they were notified of it.

old summary - different layout than in internet explorer; images won't be shown
Comment fixed.

Whiteboard: [DOCTYPE][COMMENT-SYNTAX] → [DOCTYPE-IMG][COMMENT-SYNTAX-FIXED]

Updated

16 years ago
Summary: ibm.com - different layout than in internet explorer; images won't be shown → ibm.com - Voice Systems - images not shown due to wrong doctype
(Assignee)

Comment 11

16 years ago
wfm due to bug 153032
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.