Closed Bug 1171973 Opened 5 years ago Closed 5 years ago

[e10s] blur event does not fire on <select> element with e10s

Categories

(Core :: DOM: Events, defect)

x86
Windows
defect
Not set
Points:
1

Tracking

()

RESOLVED FIXED
mozilla41
Tracking Status
e10s m7+ ---
firefox41 --- fixed

People

(Reporter: alice0775, Assigned: enndeakin)

References

(Blocks 1 open bug)

Details

(Whiteboard: [dupe me][parity-chrome][parity-IE])

Attachments

(2 files)

Attached file select_onblur.html
The problem does not happen without e10s.
The problem does not happen on IE11 and Chrome43

Steps To Reproduce:
1. Open attached
2. Click dropdown arrow of <select> element
3. Click input field of <input> element
   or
   Click empty area of <body> element

Actual Results:
  blur event does not fire on <select> element

Expected Results:
  blur event should fire
I'm guessing that you mean that the mouse click outside the popup should not be consumed (not sent to the page) while the menulist popup is open, and results in the <select> not being blurred on click. The blur event itself does fire properly.

So this is a minor polish bug, and only affects Windows, since this is the expected behaviour elsewhere.
OS: Unspecified → Windows
Hardware: Unspecified → x86
It is easy to fix though.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #8616111 - Flags: review?(dao)
Attachment #8616111 - Flags: review?(dao) → review+
Points: --- → 1
https://hg.mozilla.org/mozilla-central/rev/7ccc403458ff
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Depends on: 1182607
Depends on: 1186972
You need to log in before you can comment on or make changes to this bug.