Closed Bug 1186972 Opened 5 years ago Closed 5 years ago

[e10s] Clicking a select doesn't collapse when clicking on the dropmarker on HiDPI

Categories

(Core :: Layout: Form Controls, defect)

41 Branch
defect
Not set
Points:
2

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
e10s m8+ ---
firefox41 - affected
firefox42 + fixed
firefox43 --- fixed

People

(Reporter: arni2033, Assigned: enndeakin)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

STR:
1. Open page data:text/html,<select><option>First<option>Second
2. Click on <select> element
3. Click on dropmarker

RESULT: (on clear Nightly profile)
The drop-down list hasn't collapsed

EXPECTATIONS:
It should've collapsed
Component: General → Layout: Form Controls
Product: Firefox → Core
Blocks: e10s
Whiteboard: DUPEME
Blocks: e10s-select
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1153586
(In reply to Towkir Ahmed [:Towkir] from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 1153586 ***

I have to disagree with this. That bug was fixed in April, but still is presented in Fx Release 39.0
THIS bug is about <select> behavior in latest Nightly in e10s mode.
Try this page with e10s: data:text/html,<select><option>First
Flags: needinfo?(towkir17)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Flags: needinfo?(towkir17)
Sorry about that arni, but you filed it against e10s and the version was trunk, so I tested on latest nightly and got nothing like that, but actually this exists on release version 39 (not reproducible each time)
Build ID 	20150630154324
User Agent 	Mozilla/5.0 (Windows NT 6.1; rv:39.0) Gecko/20100101 Firefox/39.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [e10s] Clicking a select doesn't collapse when clicking on the dropmarker. → Clicking a select doesn't collapse when clicking on the dropmarker
Version: Trunk → 39 Branch
It's present in FF42 with e10s enabled, not present with e10s disabled.

About FF39, we don't care because e10s is off by default (and FF39 is almost EOLed, so no bug fix like that).
Summary: Clicking a select doesn't collapse when clicking on the dropmarker → [e10s] Clicking a select doesn't collapse when clicking on the dropmarker
Version: 39 Branch → 42 Branch
It regressed and it's similar to bug 1182607 which has been recently fixed.
I guess it's an edge case due to style="position:fixed; bottom:200px".

Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0093691d3715&tochange=b7ee8e13145a

suspected: bug 1171973
Blocks: 1171973
Flags: needinfo?(enndeakin)
Keywords: regression
Whiteboard: DUPEME
Version: 42 Branch → 41 Branch
Is this not fixed, or just a duplicate of 1182607?
Flags: needinfo?(enndeakin)
On my side, testcase of bug 1182607 is not fixed with e10s on, so this current bug is probably a dupe of bug 1182607.

Do you know why bug 1182607 appears unfixed?
I tested it more carefully

I have default font size on my Win7 = 125%. When I launch Nightly with layout.css.devPixelsPerPx = -1.0 [default] then I can't close <select> by clicking on it. You can test it by setting that pref to 1.25

If I set layout.css.devPixelsPerPx = 1.0 then I can close <select> if I do the following:
1. Click on <select>
2. Wait 2 seconds
3. Click on <select>
BUT if I DoubleClick <select> (that is initially closed) then it isn't closed. It just causes selected option in list to lose blue background.
I confirm that, it's not fixed on HiDPI screens. Mine is Win 7 at 125%, it's not fixed with e10s enabled, if I revert to 100%, it works.

Title modified according to that.
Summary: [e10s] Clicking a select doesn't collapse when clicking on the dropmarker → [e10s] Clicking a select doesn't collapse when clicking on the dropmarker on HiDPI
(In reply to Loic from comment #9)
> Title modified according to that.

How about DoubleClick on dropmarker not collapsing the list?
I guess everybody got that. ^^
Are double clicks supposed to collapse a dropdown list ???
Jared, you've got a Win10 Hi-DPI device, right? Could you try to reproduce this bug?
Flags: needinfo?(jaws)
(In reply to :Felipe Gomes from comment #13)
> Jared, you've got a Win10 Hi-DPI device, right? Could you try to reproduce
> this bug?

Yeah, I can reproduce this on Windows with Windows set to 150% DPI. Clicking on the text within the <select> element (to open the dropdown) then clicking on the dropdown marker causes the dropdown to flicker (I believe it is closing then reopening very quickly).
Flags: needinfo?(jaws)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #14)
> (In reply to :Felipe Gomes from comment #13)
> > Jared, you've got a Win10 Hi-DPI device, right? Could you try to reproduce
> > this bug?
> 
> Yeah, I can reproduce this on Windows with Windows set to 150% DPI. Clicking
> on the text within the <select> element (to open the dropdown) then clicking
> on the dropdown marker causes the dropdown to flicker (I believe it is
> closing then reopening very quickly).

(repro'd on Windows 8.1 with 150% DPI and Nightly 42 2015-07-28)
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #8640616 - Flags: review?(tnikkel)
Attachment #8640616 - Flags: review?(tnikkel) → review+
Points: --- → 2
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/fd0e8165c50f8b58e50d59b7abb629cdb62beb72
changeset:  fd0e8165c50f8b58e50d59b7abb629cdb62beb72
user:       Neil Deakin <neil@mozilla.com>
date:       Mon Aug 10 08:31:37 2015 -0400
description:
Bug 1186972, use correct coordinates when comparing mouse position with menu anchor rectangle so that select element popups close properly, r=tn
See Also: → 1192907
https://hg.mozilla.org/mozilla-central/rev/fd0e8165c50f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Brad, this bug is marked FF41+ tracking. Given that the fix has been in Nightly for a week, do you think it is safe to uplift the fix (seems simple enough) to Beta and Aurora? Thanks!
Flags: needinfo?(blassey.bugs)
redirecting to Neil
Flags: needinfo?(blassey.bugs) → needinfo?(enndeakin)
Removing tracking for FF41 as it is not enabled by default. It is already tracked for FF42.
Comment on attachment 8640616 [details] [diff] [review]
Convert mouse coordinates from device to css pixels

Approval Request Comment
[Feature/regressing bug #]: revealed by 1171973
[User impact if declined]: select popup reopens when clicking twice
[Describe test coverage new/current, TreeHerder]: mochitest isn't currently able to handle testing this, but tested manually, and fixes an obvious incorrect usage of coordinates
[Risks and why]: e10s only, only affects high DPI screen modes
[String/UUID change made/needed]: none
Flags: needinfo?(enndeakin)
Attachment #8640616 - Flags: approval-mozilla-aurora?
Comment on attachment 8640616 [details] [diff] [review]
Convert mouse coordinates from device to css pixels

Improve e10s, taking it as it is now the default in aurora.
Attachment #8640616 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: 1194027
Has STR: --- → yes
You need to log in before you can comment on or make changes to this bug.