this web page causes mozilla crash every attempt to load it

VERIFIED DUPLICATE of bug 105619

Status

()

Core
CSS Parsing and Computation
--
critical
VERIFIED DUPLICATE of bug 105619
16 years ago
15 years ago

People

(Reporter: robert somerville, Assigned: dbaron)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.7+) Gecko/20011228
BuildID:    2001122806

this web page causes a CRASH every time mozilla tres to load it

Reproducible: Always
Steps to Reproduce:
1.point browser at www.iht.com
2.
3.

Actual Results:  crash , after 10 seconds of trying to load the web page!

Updated

16 years ago
Keywords: crash

Comment 1

16 years ago
WFM, win98SE, 2001122703

Comment 2

16 years ago
Crashes also on Linux 2.4.16/0.9.7 release.

Comment 3

16 years ago
If you are crashing in Mozilla the best thing you can do to help the developers
fix your bug is to attach a stacktrace. If you're not building yourself you are
not out of luck.  Mozilla (thanks to a very cool donation from Netscape)
releases nightly and milestone builds with Full Circle's Talkback. Talkback
should catch most crashes and offer to send in a crash report. I can retrieve
that crash report and attach it to your bug report if you provide either the
Incident ID (you can get it by running the talkback program from
/components/talkback/) or you can let me know the email address you used to
submit the report and the time of sending. Thanks for your help in testing
Mozilla and reporting bugs.

Comment 4

16 years ago
worksforme with 122803 winddows, 122808 linux and 122808 OS X mozilla builds. 

Comment 5

16 years ago
OK. after repeated attempts with 0.9.7 I was able to crash at this site. I still
can't crash with a current nightly build so this may be cured. I've spun off the
back button history problem at this site as bug 117259

Comment 6

16 years ago
2001122806-trunk, Win32 (Windows 98)

Confirming. Changing platform and OS to All.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: SunOS → All
Hardware: Sun → All

Comment 7

16 years ago
Created attachment 62959 [details]
talkback from 0.9.6

Comment 8

16 years ago
Basil, did you crash? did you have a talkback ID? Mine is from an old build and
not very good. 

Comment 9

16 years ago
See also TBID TB1002090X.

Comment 10

16 years ago
Created attachment 62960 [details]
basil's talkback with line numbers :)

Thanks basil.
Attachment #62959 - Attachment is obsolete: true

Comment 11

16 years ago
GKLAYOUT.DLL + 0xca138 (0x6041a138)
nsAString::AssignFromReadable
[d:\builds\seamonkey\mozilla\string\src\nsAString.cpp, line 758]
nsFont::operator= [d:\builds\seamonkey\mozilla\gfx\src\nsFont.cpp, line 104]
nsFontMetricsWin::Init
[d:\builds\seamonkey\mozilla\gfx\src\windows\nsFontMetricsWin.cpp, line 469]
nsFontCache::GetMetricsFor
[d:\builds\seamonkey\mozilla\gfx\src\nsDeviceContext.cpp, line 676]
DeviceContextImpl::GetMetricsFor
[d:\builds\seamonkey\mozilla\gfx\src\nsDeviceContext.cpp, line 329]
nsRenderingContextWin::SetFont
[d:\builds\seamonkey\mozilla\gfx\src\windows\nsRenderingContextWin.cpp, line 995]
nsLineLayout::VerticalAlignFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 2157]
nsLineLayout::VerticalAlignLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 1886]
nsBlockFrame::PlaceLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 4076]
nsBlockFrame::DoReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3722]
nsBlockFrame::DoReflowInlineFramesAuto
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3572]
nsBlockFrame::ReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3517]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2550]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2179]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 846]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 766]
nsTableCellFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableCellFrame.cpp, line 943]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 766]
nsTableRowFrame::IR_TargetIsChild
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 1263]
<snip>

-->Layout 
Assignee: asa → attinasi
Component: Browser-General → Layout
QA Contact: doronr → petersen

Comment 12

16 years ago
Windows Font stuff in the stack here... rbs, shanjian?

Comment 13

16 years ago
> 1.point browser at www.iht.com

Is bug 105619 still around?
(Assignee)

Comment 14

16 years ago
There was another report of it being still around, on that bug.
(Assignee)

Comment 15

16 years ago
This should be style system.
Assignee: attinasi → dbaron
Component: Layout → Style System
QA Contact: petersen → ian
(Assignee)

Comment 18

16 years ago

*** This bug has been marked as a duplicate of 105619 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 19

15 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.