Closed Bug 1172211 Opened 5 years ago Closed 4 years ago

Flash causes Firefox 38 to hang on OS X

Categories

(Firefox :: General, defect)

38 Branch
x86_64
macOS
defect
Not set

Tracking

()

RESOLVED INCOMPLETE
Tracking Status
firefox38 --- wontfix
firefox38.0.5 + wontfix
firefox39 + wontfix
firefox40 - ---

People

(Reporter: vladan, Unassigned)

References

()

Details

Attachments

(5 files, 2 obsolete files)

Sylvestre Ledru says there are reports (nothing formal yet) that Firefox 38 is slow and freezes sometimes.

William Chen captured hang stacks from a reproducible Firefox 38 hang on OS X on the following page: http://thedailyshow.cc.com/full-episodes/h97vrk/june-4--2015---steve-buscemi

He says it looks like we're calling CallHasProperty and it's hanging waiting on getting an IPC message back from a flash plugin container. See attachments for hang stacks. 

The hang reproduces on this Mac in safe-mode as well.
Attached file Hang #1: XUL stack
Attached file Hang #1: JS stack
Attached file Hang #2: XUL stack (obsolete) —
Attached file Hang #2: JS stack (obsolete) —
Attached file about:support
Attachment #8616338 - Attachment is obsolete: true
Attachment #8616339 - Attachment is obsolete: true
I'm going to need stacks from both parent and child processes to properly diagnose this.
[Tracking Requested - why for this release]:
Tracking as it might be important.

and also for the good choice of the URL to reproduce the bug ;)
Tracking enabled for 38.0.5, 39, and 40, although I don't know if 40 is affected. If anyone can verify if 40 and 41 are affected, please advise.
Attached file plugin container stack
On one of the attempts trying to get the stack we got this crash report: https://crash-stats.mozilla.com/report/index/107b01f4-689b-4b54-8d8b-8c8222150610
Flags: needinfo?(aklotz)
(In reply to William Chen [:wchen] from comment #9)
> Created attachment 8617678 [details]
> plugin container stack
> 
> On one of the attempts trying to get the stack we got this crash report:
> https://crash-stats.mozilla.com/report/index/107b01f4-689b-4b54-8d8b-
> 8c8222150610

http://bsmedberg.github.io/socorro-toolbox/html/multiple-minidumps.html?crashID=107b01f4-689b-4b54-8d8b-8c8222150610

This one is for CallHandleEvent. I don't see anything in here that is known to me.
Flags: needinfo?(aklotz)
Jeromie, could Adobe please take a look at the hang in this report? It is 100% reproducible to a user. https://crash-stats.mozilla.com/report/index/107b01f4-689b-4b54-8d8b-8c8222150610
Flags: needinfo?(jeclark)
I'm unable to reproduce a hang with Flash Player 18.0.0.160 on MacOS 10.10.3 with Firefox 38.0.5.  Are there additional STRs beyond just loading the video?

It seems like this was very prominent in Flash Player 16.0.0.305, but drops off significantly in Flash Player 17, and I see zero reports for Flash Player 18.  There *is* a weird jitter with this specific video (my guess is that there's an encoding problem), but it's not crashing or hanging.

https://crash-stats.mozilla.com/api/SuperSearch/?signature=~libsystem_kernel.dylib%400x177b6&date=%3E03%2F01%2F2015&flash_version=0.0.0.0&_facets=signature&_facets=flash_version&_facets=plugin_version&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform

My guess is that this has already been fixed, with only 19 recent reports (and less unique users) in the current stats.

If Mozilla feels that this is something we should prioritize, I'm always happy to file a bug, but I think the sensible thing to do given the supporting data is to let this one ride.  I'm sure we can find issues with a better ROI to focus on.
Flags: needinfo?(jeclark)
Weird, that crash-stats link got mangled.  This one works.  See plug-in version facet... 

http://bit.ly/1FbQ1IR
I just reproduced a crash/plugin hang using the same steps to reproduce from my bug against nightly (bug 1174008), but with Firefox 38.0.5, this time -- here's the report for that crash/hang: https://crash-stats.mozilla.com/report/index/598e0457-6798-4d0d-97f0-991672150611
What version of Flash Player?
(In reply to Jeromie Clark from comment #15)
> What version of Flash Player?

18.0.0.160
Weird.  It actually looks *way* better to me in nightly than it did in Firefox 38, and I watched it through the commercial transitions, which is where things usually get weird.  We *have* seen some Mac video driver bugs, particularly on older models that moved to Yosemite.

Do you continue to see this if you disable Hardware Acceleration in Flash?  Just trying to narrow it down. 

Right-click on the video and choose Settings, then click the left-most tab and uncheck Enable Hardware Acceleration

The output of System Information would also be useful, I'd like to track down the exact model in our lab.
(In reply to Jeromie Clark from comment #17)
> Weird.  It actually looks *way* better to me in nightly than it did in
> Firefox 38, and I watched it through the commercial transitions, which is
> where things usually get weird.  We *have* seen some Mac video driver bugs,
> particularly on older models that moved to Yosemite.
> 
> Do you continue to see this if you disable Hardware Acceleration in Flash? 
> Just trying to narrow it down. 
> 
> Right-click on the video and choose Settings, then click the left-most tab
> and uncheck Enable Hardware Acceleration
> 
> The output of System Information would also be useful, I'd like to track
> down the exact model in our lab.

I disabled hardware acceleration (and didn't restart Firefox 38.0.5), and got this crash a couple of minutes after:

https://crash-stats.mozilla.com/report/index/b070d1c2-63cc-463b-ab38-2a14a2150612

(The video did appear to playback much more smoothly, to be sure, and seeking manually was fast and accurate, until I beach-balled and eventually crashed.)

I'll attach my System Report/Information next.
It looks like Mozilla's crash reporter wasn't able to resolve the symbols for that last crash report.  Do you guys need anything from us for that build?  I know that I saw some email traffic about switching to the new system, etc, but I thought we were good.
I filed ADBE 4006412 on this, but I can't do much without a symbolicated crash report.  I  also can't use the half-dozen reports that exist on 17 because of an unrelated problem with the build system and some missing symbol maps.
I am going to untrack it because it does not seems to be actionable. Please resubmit if we have a better idea on how to fix it.
We've closed this as Closed/NeverFix on our end as well.  Despite diligent effort to reproduce the issue, we're unable to replicate it, and have had no issues with this content across multiple machines of similar configs in multiple geographies using current Flash and Firefox versions.
Seems like this never got enough information to get close to fixing this -> INCOMPLETE.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.