The warning triangle misses from “Some extensions could not be verified” button

VERIFIED FIXED in Firefox 47

Status

()

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: vasilica.mihasca, Assigned: aswan)

Tracking

(Blocks: 1 bug, {ux-userfeedback, ux-visual-hierarchy})

Trunk
mozilla47
ux-userfeedback, ux-visual-hierarchy
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 affected, firefox47 verified)

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment, 1 obsolete attachment)

Reproducible on: Firefox 40.0a2 and Firefox 41.0a1 across all platforms

STR
1.Launch Firefox with clean profile.
2.Install an add-on from addons.allizom.org
3.Enable xpinstall.signatures.required from about:config.
4.Restart the browser.
5.Open about:addons 

ER
The warning triangle appears on “Some extensions could not be verified” button as in https://bug1148403.bugzilla.mozilla.org/attachment.cgi?id=8598783

AR
The warning triangle misses from “Some extensions could not be verified” button.

Additional notes:
- This issue is reproducible on Firefox 40.0a2 (2015-06-07/08) and Firefox 41.0a1 (2015-06-08) under Windows 7 64-bit, Ubuntu 14.04 32-bit, Mac OS X 10.9.5
- I am attaching a screenshot: http://i.imgur.com/Cx7MqmQ.jpg
Blocks: 1158200

Updated

3 years ago
Whiteboard: [good first bug]
In the example shown (last link in comment #0), the Add-ons Manager banner lacks not only the /!\ icon at the start but also the "…and has been disabled" phrase at the end; in addition, it is in rather neutral colours.

All this might seem of little importance if, as shown, the newly disabled add-ons are in plain view, each of them with a red warning including both the icon and the closing phrase. However, let us not forget that when several add-ons are installed, some of them enabled and some disabled, the enabled ones are usually listed first (except in the "Recent Updates" pane when sorted by date) with the disabled ones after them.

Thus, if enough enabled (and properly signed) add-ons are present, the newly disabled ones might be completely out of view until or unless the list is intentionally scrolled.
Keywords: ux-userfeedback, ux-visual-hierarchy

Updated

3 years ago
Assignee: nobody → aswan

Updated

3 years ago
Iteration: --- → 47.1 - Feb 8
Created attachment 8713287 [details] [diff] [review]
add warning icon to unsigned extensions warning button
Attachment #8713287 - Flags: review?(dtownsend)
Comment on attachment 8713287 [details] [diff] [review]
add warning icon to unsigned extensions warning button

Review of attachment 8713287 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/mozapps/extensions/content/extensions.xul
@@ +185,5 @@
>                    command="cmd_restartApp"/>
>          </hbox>
>          <button id="show-disabled-unsigned-extensions" hidden="true"
> +                dir="normal" orient="horizontal"
> +                image="chrome://mozapps/skin/extensions/alerticon-warning.svg"

We generally put style information like this in the css so it can be overridden by themes. You can add it with list-style-image in here: https://dxr.mozilla.org/mozilla-central/source/toolkit/themes/shared/extensions/extensions.inc.css
Attachment #8713287 - Flags: review?(dtownsend) → review-
Created attachment 8713318 [details] [diff] [review]
add warning icon to unsigned extensions warning button take 2
Attachment #8713318 - Flags: review?(dtownsend)
Comment on attachment 8713318 [details] [diff] [review]
add warning icon to unsigned extensions warning button take 2

Review of attachment 8713318 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!
Attachment #8713318 - Flags: review?(dtownsend) → review+
Attachment #8713287 - Attachment is obsolete: true
Keywords: checkin-needed
Status: NEW → ASSIGNED

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/103a122789a3
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Verified on Firefox 47.0a1 (2016-02-03) across all platforms and noticed the following:

[1] Mac OS X 10.11.1 - the triangle looks good: http://i.imgur.com/yswxNw8.png

[2] Windows 10 64-bit - there is no space between the triangle and the “Some” word: http://i.imgur.com/89fRCZq.jpg - It should be displayed as it appears for Mac platforms

[3] Ubuntu 14.04 32-bit and Ubuntu 13.10 64-bit - the triangle still misses from the button  http://i.imgur.com/Fpp1YDu.png



Should I reopen this bug or file separate ones for each platform ?
Flags: needinfo?(dtownsend)
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #8)
> Verified on Firefox 47.0a1 (2016-02-03) across all platforms and noticed the
> following:
> 
> [1] Mac OS X 10.11.1 - the triangle looks good:
> http://i.imgur.com/yswxNw8.png
> 
> [2] Windows 10 64-bit - there is no space between the triangle and the
> “Some” word: http://i.imgur.com/89fRCZq.jpg - It should be displayed as it
> appears for Mac platforms
> 
> [3] Ubuntu 14.04 32-bit and Ubuntu 13.10 64-bit - the triangle still misses
> from the button  http://i.imgur.com/Fpp1YDu.png
> 
> 
> 
> Should I reopen this bug or file separate ones for each platform ?

Probably just file one new bug for the follow-ups.
Flags: needinfo?(dtownsend)
(In reply to Dave Townsend [:mossop] from comment #9)

> Probably just file one new bug for the follow-ups.

Filed Bug 1246095

I am marking this bug as Verified since the other issue is tracked separately.
Status: RESOLVED → VERIFIED
status-firefox47: fixed → verified
Flags: qe-verify+
This seems to be responsible for the CSS error I'm suddenly seeing every time I run tests:

https://hg.mozilla.org/mozilla-central/rev/103a122789a3#l2.14
Depends on: 1250880
You need to log in before you can comment on or make changes to this bug.