Status

()

defect
RESOLVED DUPLICATE of bug 1176097
4 years ago
2 years ago

People

(Reporter: kaie, Unassigned)

Tracking

41 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 affected)

Details

Update to NSS 3.19.2

The purpose of the 3.19.2 release is to fix regression bug 1172128 that caused issues for library consumers.
I'd like to suggest that we use a shortened testing phase.

The only changes in 3.19.2 are:
- revert to previous core limits, and move the Logjam limits to the the SSL library
- fix memory leaks in an utility (not the library)
- use a better error code for one SSL scenario

I believe these are very low risk for Firefox.
I suggest that we tag the final release on Wednesday.
(In reply to Kai Engert (:kaie) from comment #2)
> I suggest that we tag the final release on Wednesday.

I concur.
NSS_3_19_2_RTM has been created.

Martin, could you please upgrade mozilla-central to pick it up?


Since Firefox 38.x might be used for SDK like scenarios, for example by people trying to use a xulrunner based on Firefox 38.x, I'd like to suggest that Firefox 38.x ESR gets udpated to pick up 3.19.2, too.


Also, I've created an additional
  NSS_3_19_2_WITH_CKBI_1_98_RTM
in case you'd like to update Firefox 31.x
This bug was overlooked and bug 1176097 has been used instead.

Marking as a duplicate.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1176097
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.