cardDAV: remote adressbooks do not work with @ in the username

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: support, Unassigned)

Tracking

31 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150518065406

Steps to reproduce:

Version: 31.7.0 Linux Fedora 20 64bit

if you use a remote addressbook url like :

http://cal.domain.com/index.php/addressbooks/xxxx@servicename/default/

TB ( or Lightning or Sogo ) does not even try to connect to the server.

the same url without the "@" works great:

http://cal.domain.com/index.php/addressbooks/xxxx-servicename/default/

It looks like the "@" is misintrepreted as the @ from such an url:

"http://user:password@domain/...." which it isn't, as it's clearly in the URI part.



Actual results:

TB ( or Lightning or Sogo ) does not even try to connect to the server.


Expected results:

TB ( or Lightning or Sogo ) should work normally, as the same CalDAV url with an @ in the username works as expected.

Comment 1

3 years ago
Please report it to Sogo. Bugs in extensions and such are not tracked in bugzilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.