Chinese Character encoding is not honored

VERIFIED DUPLICATE of bug 1174580

Status

P2
major
VERIFIED DUPLICATE of bug 1174580
3 years ago
3 years ago

People

(Reporter: luweitest, Unassigned)

Tracking

({regression})

38 Branch
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8622327 [details]
wrong.JPG

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

After upgraded to TB 38, all mails of one account displays wrong.


Actual results:

The chinese characters displays wrong, as if the encoding is not recognized. If I select character encoding manually from menu>view>character encoding>chinese simplified, it will display OK, but only temporary; switch to another message and back, it displays wrong again. I will attach screen shots and a sample eml.


Expected results:

It should display correctly as before.
(Reporter)

Comment 1

3 years ago
Created attachment 8622328 [details]
correct.JPG
(Reporter)

Comment 2

3 years ago
Created attachment 8622329 [details]
SAP系统维护通知.eml
(Reporter)

Updated

3 years ago
Severity: normal → major
Component: Untriaged → Message Reader UI
OS: Unspecified → Windows XP
Priority: -- → P2
Hardware: Unspecified → x86

Updated

3 years ago
tracking-thunderbird_esr38: --- → +
Keywords: regression

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
tracking-thunderbird_esr38: + → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1174580

Updated

3 years ago
Status: RESOLVED → VERIFIED
Summary: Character encoding is not honored → Chinese Character encoding is not honored
You need to log in before you can comment on or make changes to this bug.