In 256 color setting, running a applet in Apprunner cause a color palette problem

VERIFIED DUPLICATE of bug 77454

Status

Core Graveyard
Java: OJI
P3
normal
VERIFIED DUPLICATE of bug 77454
19 years ago
a year ago

People

(Reporter: Chris Petersen, Assigned: James.Melvin)

Tracking

({pp})

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Version: Apprunner
Build: 1999081108
Platform: Windows 98, 95, NT 4.0
Other Platforms: Doesn't occur on Mac 8.6
Expected result: The current color palette should remain the same when running a
applet just like Com 4.6 and I.E. 5.0.
What I got: As the applet runs, Apprunner's tool palettes are flashing in
different colors (green and yellow).

Steps to reproduce:

1)Set monitor to 256 color in the Dispaly setting's in the Display control panel.
2) After this is completed, launch apprunner.
3) Type in http://slip/projects/marvin/html/applet_align_top.html.
4) After the applet loads, notice the color palette problem occuring.

Updated

19 years ago
Assignee: don → malini
Component: Browser-General → Java FrontEnd

Updated

19 years ago
Assignee: malini → don
Component: Java FrontEnd → Browser-General

Comment 1

19 years ago
This bug has been wrongly assigned to the Java FE category. Java FE stands for
the project of putting a Java chrome over Gecko which is still in the works and
not yet checked in to the tree.

Updated

19 years ago
Assignee: don → beard
Component: Browser-General → Compositor

Updated

19 years ago
Assignee: beard → drapeau
Component: Compositor → OJI

Comment 2

19 years ago
This is probably due to OJI and the browser not agreeing on color palettes.
Reassigning to the OJI people.

Updated

19 years ago
Assignee: drapeau → edburns

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
QA Contact: leger → paw

Comment 3

19 years ago
Resetting QA contact from leger.

Updated

18 years ago
Keywords: pp

Updated

18 years ago
Summary: [PP]In 256 color setting, running a applet in Apprunner cause a color palette problem → In 256 color setting, running a applet in Apprunner cause a color palette problem

Comment 4

18 years ago
I can't test this until the applet is available outside netscape's firewall.  
If you tar up the html and class files and attach them to this bug, that would 
work fine.

Marking INVALID so the reporter will take action.

Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 5

18 years ago
Hey Chris is this still an issue?

Comment 6

18 years ago
Reopening. This is still an issue with WinNT at least. The entire browser
appears to be shaking at
http://java.sun.com/applets/other/ScrollingImages/index.html
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 7

17 years ago
The browser does indeed shake when visiting java.sun.com in 256 color mode.  At 
first I thought it was a browser problem, so I removed the java plugin from the 
equation and re-visited the page.  Unfortunately, the page did not blick when 
the plugin was not installed.  Something about the plugin's colormap causes the 
whole browser to flicker.

Re-assigning to jim.melvin.
Assignee: edburns → James.Melvin
Status: REOPENED → NEW

Updated

17 years ago
QA Contact: paw → shrir

Comment 8

17 years ago
Updating QA contact

Comment 9

17 years ago
Jim, will you please accept this bug?

Comment 10

17 years ago
hey, this is a dup of 77454

*** This bug has been marked as a duplicate of 77454 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 11

17 years ago
SPAM: reassigning OJI bugs to new QA, pmac. (227 bugs)
QA Contact: shrir → pmac

Comment 12

17 years ago
Verified dup.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.