java applet loaded with 256 color display shows weird colors on screen and flickers

VERIFIED FIXED

Status

Core Graveyard
Java: OJI
P3
normal
VERIFIED FIXED
17 years ago
8 years ago

People

(Reporter: shrirang khanzode, Assigned: stanley.ho)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
windows trunk 0424

steps:
1 Set display to 256 colors in control panel
2 go to the above page
3 Observe that as the page loads, weird colors appear and window flickers..

 happens with 4.x too.

Comment 1

17 years ago
blocked by bug 76921.
Depends on: 76921

Updated

17 years ago
No longer depends on: 76921

Comment 2

17 years ago
I do see this.  Stanley, can you please evaluate this?
Assignee: edburns → stanley.ho

Comment 3

17 years ago
p3
Priority: -- → P3
(Assignee)

Comment 4

17 years ago
Java2D is optimized for more than 256 colors. Try using a higher resolution 
will solve the problem. There is also a bug in Bugtraq: 4178909

http://java.sun.com/j2se/1.3/relnotes.html#2D

This issue has been fixed in 1.4.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

17 years ago
are we not bundling jre 1.4 in 6.x anytime soon? 
(Reporter)

Comment 6

17 years ago
*** Bug 11748 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

17 years ago
qa->pmac
QA Contact: shrir → pmac

Comment 8

17 years ago
If I use the high resolution rather than 256 color, the problem is gone.
Marking verified on commercial trunk: (2001-08-27-06-trunk) & Java(TM) Plug-in:
Version 1.3.0_01
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.