avm1_0x49_ActionEquals2 doesn't properly handle comparisons between objects and primitives

RESOLVED FIXED

Status

Firefox Graveyard
Shumway
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: till, Assigned: yury)

Tracking

Details

(URL)

(Reporter)

Description

3 years ago
The linked ad works fine except it doesn't fold up if the mouse is move out.

Seems to be caused by avm1_0x49_ActionEquals2 not handling some comparisons properly. In this case, a is `0.01`, while b is an object without a `valueOf` method, so an exception is thrown.

Marking as m4 blocker because it's likely to affect lots of content.
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1148709
(Assignee)

Comment 2

2 years ago
Fixed by https://github.com/mozilla/shumway/pull/2332
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.