Closed Bug 1175211 Opened 4 years ago Closed 4 years ago

CGI 4.14 no longer exports SERVER_PUSH(), making buglist.cgi to crash with Gecko-based browsers

Categories

(Bugzilla :: Query/Bug List, defect)

4.2.14
defect
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 4.2

People

(Reporter: jules.castron, Assigned: LpSolit)

Details

(Whiteboard: [Only affects 4.2 and older])

Attachments

(1 file)

User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; BRI/2)

Steps to reproduce:

Using search in Bugzilla on the Firefox browser. Works on other browsers (Chrome, IE, Konqueror) on Linux and Windows same results.

Error: Software error:

Undefined subroutine &Bugzilla::CGI::SERVER_PUSH called at Bugzilla/CGI.pm line 244.

Bugzilla 4.2.14
Apache 2.2.12
Perl 5.10


Actual results:

Software error:

Undefined subroutine &Bugzilla::CGI::SERVER_PUSH called at Bugzilla/CGI.pm line 244.


Expected results:

List the bugs
CGI 4.14 and newer no longer autoload SERVER_PUSH and so Bugzilla::CGI cannot use it anymore unless called explicitly. Bugzilla 4.4 and newer are not affected because this code is gone, see bug 761331.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Only affects 4.2 and older]
Assignee: general → LpSolit
Status: NEW → ASSIGNED
Attachment #8623234 - Flags: review?(dkl)
Flags: blocking4.2.15?
Target Milestone: --- → Bugzilla 4.2
The reason Firefox only is affected is because non-Gecko based browsers do not trigger the server push code.
Summary: Undefined subroutine &Bugzilla::CGI::SERVER_PUSH called at Bugzilla/CGI.pm line 244. → CGI 4.14 no longer exports SERVER_PUSH(), making buglist.cgi to crash with Gecko-based browsers
Component: Bugzilla-General → Query/Bug List
Hi,

I made the change and it's working! Thanks.
Comment on attachment 8623234 [details] [diff] [review]
patch for 4.0 and 4.2, v1

Review of attachment 8623234 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Attachment #8623234 - Flags: review?(dkl) → review+
Flags: approval4.2?
Flags: blocking4.2.15?
Flags: approval4.2?
Flags: approval4.2+
To ssh://gitolite3@git.mozilla.org/bugzilla/bugzilla.git
   8ee079b..cd9c691  4.2 -> 4.2
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.