Closed Bug 1175262 Opened 5 years ago Closed 2 years ago

integrate simple add-ons manager in about:preferences#addons

Categories

(Firefox :: Preferences, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1329970

People

(Reporter: designakt, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

So that a typical user with a handful of add-ons, can more easily manage them they should be able to view them in one place from within preferences.
This will unify user options and simplify the add-ons manager.
Right now this should be an experiment in Nightly to test how such a reduced add-ons manager will work and to evolve it from there.
As shown in the sketch the add-ons section should list (extensions, appearances, plugins, etc.) on one page under about:preferences#addons.
Blocks: 1175290
Dave, is this something that could be done in near future? How much effort would that be?
Flags: needinfo?(dtownsend)
(In reply to Markus Jaritz [:maritz] (UX) from comment #1)
> Dave, is this something that could be done in near future? How much effort
> would that be?

Without far more detailed designs I can't really estimate the work involved here, but in general an add-ons manager UI is never simple. We would likely be better off just restyling the existing UI and loading it in a frame in preferences instead of starting from scratch. Again depends on which pieces of the UI you want to include though.

I don't know if this could be done anytime soon, I'm not aware of any engineers available to work on it.
Flags: needinfo?(dtownsend)
Hm, this bug being in "Firefox/Preferences" apparently means that even if someday it gets FIXED (which according to comment #2 won't be any time soon) the existing Toolkit about:addons will thankfully remain for use by Thunderbird & SeaMonkey (and possibly Firefox as an alternate to this for users with different usecases).
Severity: normal → enhancement
OS: Unspecified → All
Hardware: Unspecified → All
Version: unspecified → Trunk
Blocks: 1387450
Still on the map with Photon?
See Also: → 1329970
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329970
You need to log in before you can comment on or make changes to this bug.