Duplicated messages in news

VERIFIED WORKSFORME

Status

MailNews Core
Backend
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Eric Vaandering (no email), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Just a guess that this is the back end...

When I open a news group with 0.9.7, a few of the messages are duplicated, show
up at the head of the list, in a weird threading mode (looks like they are
threaded).

Clicking on the thread icon a couple of times sorts things out.

I'll attach a screen shot.
(Reporter)

Comment 1

16 years ago
Created attachment 63158 [details]
Snapshot showing duplicated messages

The top six messages are the duplicated ones. At least four of them are, and
I've opened the threads containing those articles so they are easy to see.

I run the reader in unread (and threaded of course) mode.

Interestingly, when I click on the messages that appear to be properly
threaded, they appear, but the message line doesn't come "un-bolded" so they
still look like they are unread. (The green flag doesn't clear either).

Updated

16 years ago
QA Contact: esther → stephend

Comment 2

16 years ago
Have you seen this in more recent builds?  Stephen, have you ever seen this?

reassigning to sspitzer.
Assignee: mscott → sspitzer
No, I've never seen this, myself.  (But I couldn't argue with screenshots).
(Reporter)

Comment 4

16 years ago
I'll try with a 0.9.8 branch build in the next couple of days and see if the
problem is still there.

Comment 5

16 years ago
Please update this when you get the chance.
Status: NEW → ASSIGNED
(Reporter)

Comment 6

16 years ago
I still see this with 0.9.8-latest (2002012605 for linux).

My settings are Threaded mode, show Unread messages. Have you tried those
settings to reproduce this?

Also, you might want to use a news server that's not very fast. It seems looking
at how things come up that these messages show up in the wrong place after
rendering of the tree has begun, but messages are still being inserted.
*** Bug 127826 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

16 years ago
The behavior of this seems to have changed with 0.9.9. Now it looks like the
messages that aren't threaded are not duplicate messages, but unique ones.

Changing to OS All since duplicate was from Windows
Hardware: PC → All

Comment 9

16 years ago
This may have been a duplicate of bug 111895 - I saw this behaviour while
working on that bug.  This bug was that the threading was incorrect when you
first selected the group - thread children would not appear under their thread
header.  However, if you then attempted to open the thread header, the child
then also showed up in its correct threaded spot - hence you had the dupe - the
original in the incorrect spot, then in the correct spot when the thread was
expanded.
Blocks: 71728
(Reporter)

Comment 10

16 years ago
Mark,

It looks like your fix landed 9 days prior to 0.9.9 (what I'm using). Was it not
approved for that release? 

If not, I will grab a nightly or build from the tip and see if things are better
now and (if they are) close out the bug.

Please advise.
(Reporter)

Comment 11

16 years ago
Just built from the tip. I don't see this. Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
I haven't seen this either, recently with build 2002-03-26-08, Mandrake 8.1

I'll keep an eye out for this and other threading bugs, but in the meantime,
Verified WFM.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
No longer blocks: 71728
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.