account setting menu problem, after SMTP failure when sending "The message could not be sent because the connection to Outgoing server (SMTP) ... was lost" with shaw.ca

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
2 years ago

People

(Reporter: dpue1, Unassigned)

Tracking

({regression, regressionwindow-wanted})

38 Branch
regression, regressionwindow-wanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/600.6.3 (KHTML, like Gecko) Version/8.0.6 Safari/600.6.3

Steps to reproduce:

1) intermittent when I try to send a message. 
2) when I then go to the menu for Account settings and click on SMTP settings (OR any other option in the menu)


Actual results:

1) get this error message or the message takes a long time to be sent
"Sending of the message failed. The message could not be sent because the connection to Outgoing server (SMTP) mail.shaw.ca was lost in the middle of the transaction. Try again."
2) I get error Message "Account Wizard An account with this name already exists. Please enter a different account name."


Expected results:

1) message should be sent. TB worked well until I upgraded to v38.0.1.  Problems showed up right after upgrade
2) I should be able to see the individual settings. (TB mistakes the choice of option to look at settings as the option to create a new account.

NOTE: If I go to the Account settings when the program 1st opens, I can see the details of the setting fine.  It seems that 2) happens only after trying to send a message
I've seen other reports of "The message could not be sent because the connection to Outgoing server (SMTP) ... was lost"  

Putting this in account manager in case the two issues are related.
Component: Untriaged → Account Manager
Keywords: regression, regressionwindow-wanted
Summary: SMTP failure when sending; issue with account setting menu → issue with account setting menu after SMTP failure when sending "The message could not be sent because the connection to Outgoing server (SMTP) ... was lost"

Comment 2

4 years ago
(In reply to dpue1 from comment #0)
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3)
> AppleWebKit/600.6.3 (KHTML, like Gecko) Version/8.0.6 Safari/600.6.3
> 
> Steps to reproduce:
> 
> 1) intermittent when I try to send a message. 
> 2) when I then go to the menu for Account settings and click on SMTP
> settings (OR any other option in the menu)

I do not understand step 2. Is something missing here?

> Actual results:
> 
> 1) get this error message or the message takes a long time to be sent
> "Sending of the message failed. The message could not be sent because the
> connection to Outgoing server (SMTP) mail.shaw.ca was lost in the middle of
> the transaction. Try again."
> 2) I get error Message "Account Wizard An account with this name already
> exists. Please enter a different account name."

Where do you get this message? How does it relate to 1) ?

> 1) message should be sent. TB worked well until I upgraded to v38.0.1. 
> Problems showed up right after upgrade
> 2) I should be able to see the individual settings. (TB mistakes the choice
> of option to look at settings as the option to create a new account.

How do you mean this? Why would TB try to create a new account? Please check the NAMES of your mail accounts are unique (no duplication) and also for your SMTP accounts.
(Reporter)

Comment 3

4 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions)
 
Issues #1 and #2 are separate. Issue # 1 seems to have rectified itself (perhaps an issue with my ISP).

However, issue #2 is still a problem. When I use the [Tools] menu and access the [Account Settings] option (i.e. to modify the settings for my accounts) I get a window listing the accounts and the sub-sections (Server settings, junk settings, security, etc).  When I click on ANY of these sub-sections, instead of seeing the window with the details of that subsection,The whole window of the accounts and their sub-sections disappears and another window opens with the text "Account Wizard  An account with this name already exists. Please enter a different account name." and the option [OK].  When I click on [OK] the [accounts settings] window re-opens.

There are 2 options offered in the accounts settings window [cancel] or [OK] if I choose [OK] the window disappears and the "Account Wizard:  ..." error message appears.  Only if I cancel does the Accounts Settings window disappear and I return to the inbox window.

When I look at the list of Accounts in the Accounts Settings window, one of my accounts is listed twice. This second listing of my account is highlighted in the left hand pane of the window.  The message in the right hand pane says "The following is a special account. There are no identities associated with it."
In the listing on the left hand pane there are only 2 subsections for the duplicate account listing: Junk settings and disk space.

I have tried to use the add mail account pop-up menu to remove this account but the remove account option is greyed out.

Dave

Comment 4

4 years ago
You can't remove that special account, it one created by TB and is called Local folders by default.
But you can rename it. So you must rename one of the accounts that have the same name. Before entering account settings, select the account in the left folder pane. Then on the right pane (account central) select "view settings for this account". Then you are in the correct account and immediatelly change the name (in the "account name" inputbox).
(Reporter)

Comment 5

4 years ago
Thanks

I followed your procedure and re-named the extra "special" account as "local folders".  I then tried to use the sections of the Account settings.  I didn't get the error message. All seems to be well.

I have no idea how the account had the "local folders' name replaced by one of my account's name.  I don't remember doing it.

Unless the re-naming was done by the up-grading to 38.0.1, I guess we can close this bug

Dave

Comment 6

4 years ago
I get a similar smtp error (smtp server timeout) when I click send the first time (after opening thunderbird). I don't think its an actual timeout because the message pops up instantly when i release the mouse button after clicking the send button. Clicking on the send button again and subsequent messages works fine.

Comment 7

4 years ago
I have a similar message from when I installed the latest update of the 15/16th July 2015:

"Not possible sending the message using the outgoing email server (SMTP) mail.name.it for an unknown reason. Verify that outgoing server settings (SMTP) are correct and retry"

The smtp server is working properly, it's just from the lastest update of the program.

I tryed to reinstall thunderbird, delete and recreate the smtp, change the psw.

He continues to give me the error and the mail sending system is blocked.

Comment 8

4 years ago
(In reply to marco from comment #7)
> I have a similar message from when I installed the latest update of the
> 15/16th July 2015:
> 
> "Not possible sending the message using the outgoing email server (SMTP)
> mail.name.it for an unknown reason. Verify that outgoing server settings
> (SMTP) are correct and retry"
> 
> The smtp server is working properly, it's just from the lastest update of
> the program.
> 
> I tryed to reinstall thunderbird, delete and recreate the smtp, change the
> psw.
> 
> He continues to give me the error and the mail sending system is blocked.

Check the error console for error messages referring to Diffie-Hellman
From comments so far it doesn't sound like Thunderbird bug.  If you still see this problem please update the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
Summary: issue with account setting menu after SMTP failure when sending "The message could not be sent because the connection to Outgoing server (SMTP) ... was lost" → account setting menu problem, after SMTP failure when sending "The message could not be sent because the connection to Outgoing server (SMTP) ... was lost" with shaw.ca
You need to log in before you can comment on or make changes to this bug.