Closed Bug 1176078 Opened 9 years ago Closed 9 years ago

Unified autocomplete suggestions blink away & back whenever you type a character, which is jarring/distracting when you type rapidly in URL bar

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1047613
Tracking Status
firefox41 - unaffected

People

(Reporter: dholbert, Unassigned)

References

Details

(Whiteboard: [suggestions][fxsearch])

Attachments

(2 files)

STR:
 1. Start Nightly with a fresh profile.
 2. Type characters into the URL bar. Note the dropdown autocompletions that appear.

ACTUAL RESULTS:
For each character I type, the dropdown autocompletion area *entirely disappears* and then *immediately reappears*.  This is jarring & distracting, and it kinda hurts my eyes.

EXPECTED RESULTS:
Something more like how the awesomebar works in current nightly. Dropdown area should stay open, and change size gracefully as-needed. No flashing.
Here's a screencast of EXPECTED RESULTS - typing in URLbar in Firefox 38 (after I've populated my history with some results that include "aaaa...")
[Tracking Requested - why for this release]: New feature in version 41, makes my eyes hurt when I type in the URL bar.
Flags: firefox-backlog+
Whiteboard: [suggestions][fxsearch]
I was able to repro this bug on FF nightly install. Adding a tracking flag for FF41.
The key thing here seems to be Unified Autocomplete, actually -- not the fact that these results are coming from a search engine.

In particular: even if I disable search-engine-provided autocompletions in my main browsing profile (at the bottom of the Preferences|Privacy page), I can still reproduce this bug (with the autocompletions from my history/bookmarks). BUT, if I disable unified autocomplete (via pref "browser.urlbar.unifiedcomplete"), then this flashing goes away.
Summary: Search-engine-provided autocompletions blink away & back whenever you type a character, which is jarring/distracting when you type rapidly in URL bar → Unified autocomplete suggestions blink away & back whenever you type a character, which is jarring/distracting when you type rapidly in URL bar
Whiteboard: [suggestions][fxsearch] → [suggestions][fxsearch]
Blocks: 1168811
Flags: qe-verify+
QA Contact: andrei.vaida
all info about this is in bug 1047613, it's a known bug due to autofilling with completedefault index. fixing it properly would require deep refactoring in autocomplete, we can likely implement some visual workaround.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
the fact this doesn't happen in old autocomplete is because we don't show the completed text in the first popup entry there, so it doesn't need to be updated for every typed char.
Unified Autocomplete was disabled in FF41 (bug 1180205). Untracking this bug for 41 and marking it as unaffected, like done here https://bugzilla.mozilla.org/show_bug.cgi?id=1047613#c28.
You need to log in before you can comment on or make changes to this bug.