If there are no websites to list, don't say "No apps in the category"

RESOLVED FIXED

Status

Marketplace
Consumer Pages
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: krupa, Unassigned)

Tracking

Points:
---

Details

(Whiteboard: [good first bug])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8624540 [details]
IMG_8208.JPG

steps to reproduce:
1. Launch marketplace-dev app on your firefoxOS phone
2. Categories -> Entertainment
3. Filter to show "all websites"

expected behavior:
If there are no websites, we say "No websites in this category"

observed behavior:

If there are no websites, we say "No apps in this category"

Comment 1

2 years ago
Can i work on this? :)
Whiteboard: [good first bug]

Comment 2

2 years ago
Created attachment 8624872 [details] [review]
patch

patch has been added :) Can u check it?
Attachment #8624872 - Flags: review?(krupa.mozbugs)
https://github.com/mozilla/fireplace/commit/5159fbe063152c0df7200b9a6e1e365c736fae88
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Updated

2 years ago
Attachment #8624872 - Flags: review?(krupa.mozbugs) → review+

Comment 4

2 years ago
I have a question: 
-> when no websites or apps are available in a category, the message will be "No results found" and the in-filter bar should be: present or not?
I was checking on MP-stage - FF OS Flame device, and there is no filter-bar if there are no websites in the selected category. (e.g. Games)
Flags: needinfo?(mstriemer)
1) I wonder where did the filter bar gone after i select websites in Game category. Maybe a regression ? 
2) we can also specify different strings for apps & website (like mark suggested in an earlier pr)

For no. 1 (if you can reproduce the same issue) I think we should file a new bug.
for no. 2,  i think we can reopen the bug & specify different strings for apps & website.

Comment 6

2 years ago
(In reply to Atique Ahmed Ziad [:atiqueahmedziad] from comment #5)
> 1) I wonder where did the filter bar gone after i select websites in Game
> category. Maybe a regression ? 
> 2) we can also specify different strings for apps & website (like mark
> suggested in an earlier pr)
> 
> For no. 1 (if you can reproduce the same issue) I think we should file a new bug.
> For no. 2,  i think we can reopen the bug & specify different strings for
> apps & website.

For 1 - because there are no websites in the Games category....the bar is gone when that option is selected. I'll file another bug.

For 2 - please reopen this issue if you think different strings are "a must".
Flags: needinfo?(mstriemer)
You need to log in before you can comment on or make changes to this bug.