Unlisted add-on delete and resubmit error

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: cliodice, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

To correct an incorrectly configured submission, we followed these steps.

My Submissions:
1. Deleted unlisted add-on with id 9tffxtbr-rsl@free.internetspeedtracker.com

Submission process:

1. Step 2: Upload your add-on
2. Checked box for unlisted
3. Uploaded xpi with id 9tffxtbr-rsl@free.internetspeedtracker.com


Actual results:

Error with 9tffxtbr-rsl@free.internetspeedtracker.com.xpi

Your add-on failed validation with 1 error.
Duplicate UUID found


Expected results:

Since it was previously deleted, add-on should have passed validation for unique uuid
Try submitting again. We keep a list of deleted IDs and don't allow re-submission to avoid malicious developers from taking over known IDs and their users. I removed your ID from that list now.

Please don't delete a listing to make a correction.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.