ASSERTION: 3D transform found between fixedpos content and its viewport (should never happen): 'Error', file layout/base/nsLayoutUtils.cpp, line 1769

RESOLVED DUPLICATE of bug 1231538

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1231538
3 years ago
2 years ago

People

(Reporter: kats, Unassigned)

Tracking

({assertion})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8624867 [details]
position-fixed-3-ref.html

Load the attached test case, and it spits out the following assertion a few times:

ASSERTION: 3D transform found between fixedpos content and its viewport (should never happen): 'Error', file /Users/kats/zspace/mozilla-git/layout/base/nsLayoutUtils.cpp, line 1769

I wanted to use something like the attached as part of a reftest but since it's spewing assertions it causes the reftest to fail unless I whitelist the assertions which I'd rather not do.
I've definitely encountered this assertion before, but I can't find where at the moment...
See Also: → bug 1153841
I see many of these just by launching B2G-desktop. I don't have to do anything.
This assertion spams continuously to my terminal, if I view http://abcnews.go.com/US/nasa-astronaut-plays-ping-pong-ball-water-space/story?id=36455005 in a debug build.

I can confirm that the attached testcase triggers the assertion for me, as well.

Marking this as blocking bug 946502, which is where this assertion was added.  Maybe mattwoodrow could take a look? (he was reviewer on that bug and has been working with other 3d transform stuff recently)
Blocks: 946502
Flags: needinfo?(matt.woodrow)
Keywords: assertion
Summary: ASSERTION: 3D transform found between fixedpos content and its viewport (should never happen): 'Error', file /Users/kats/zspace/mozilla-git/layout/base/nsLayoutUtils.cpp, line 1769 → ASSERTION: 3D transform found between fixedpos content and its viewport (should never happen): 'Error', file layout/base/nsLayoutUtils.cpp, line 1769
This will be fixed by bug 1231538, just confirmed locally.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(matt.woodrow)
Resolution: --- → DUPLICATE
Duplicate of bug: 1231538
You need to log in before you can comment on or make changes to this bug.