Closed Bug 1231538 Opened 6 years ago Closed 6 years ago

Build a ContainerLayer for position:fixed

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox45 --- affected
firefox47 --- fixed

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

References

Details

Attachments

(1 file)

position:fixed creates a stacking context now, so we can create a ContainerLayer for it.

This will also let us remove the code dealing with position:fixed from FrameLayerBuilder.
Blocks: 1238571
It's not less code overall, but it removes some complexity from FrameLayerBuilder and moves it into it's own self-contained display item. I think that's worth having.
Attachment #8709685 - Flags: review?(roc)
Duplicate of this bug: 1176355
Comment on attachment 8709685 [details] [diff] [review]
Build a ContainerLayer for position:fixed and background-attachment:fixed

Review of attachment 8709685 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, much better
Attachment #8709685 - Flags: review?(roc) → review+
https://hg.mozilla.org/mozilla-central/rev/c99e8abb5e00
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Target Milestone: mozilla46 → mozilla47
Bug 1251527 is a pretty bad regression. Can we back this out Matt?
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(matt.woodrow)
Depends on: 1265237
Depends on: 1272801
Depends on: 1275411
You need to log in before you can comment on or make changes to this bug.