Closed Bug 1176959 Opened 7 years ago Closed 7 years ago

[e10s][GTK] Kakutei-Undo of Mozc doesn't work

Categories

(Core :: DOM: Content Processes, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla42
Tracking Status
e10s + ---
firefox41 --- affected
firefox42 --- fixed

People

(Reporter: masayuki, Assigned: masayuki)

References

Details

(Keywords: inputmethod)

Attachments

(1 file)

1. Install Mozc
2. Commit something
3. Ctrl + Backspace

Actual Result:

Starts new composition after committed string (IIRC)

Expected result:

Remove the committed string and restart composition.

# Could be dup of bug 1176955 but not sure yet.
Summary: [GTK] Kakutei-Undo of Mozc doesn't work → [e10s][GTK] Kakutei-Undo of Mozc doesn't work
OnSelectionChanged is called?  Then ResetIME will remove composition.
This is 2 issues.

- Selection is invalid by bug 1175392, DeleteText always return failure.
- Even if fixing bug 1178652, since set selection is async, mIsDeletingSurrounding is false.  It means OnSelectionChange will call ResetIME, then composition is reset.
Depends on: 1178652
Assignee: nobody → m_kato
Attached patch PatchSplinter Review
Same as TSF, we shouldn't notify IME of selection change which was requested by IME on GTK too.
Assignee: m_kato → masayuki
Status: NEW → ASSIGNED
Comment on attachment 8634008 [details] [diff] [review]
Patch

We can fix this bug with same approach as bug 1176955.
Attachment #8634008 - Flags: review?(m_kato)
Comment on attachment 8634008 [details] [diff] [review]
Patch

Review of attachment 8634008 [details] [diff] [review]:
-----------------------------------------------------------------

nsGtkIMModule::DeleteText posts several content queries, but NS_CONTENT_COMMAND_DELETE will causes selection change on non-e10s mode.

So, we cannot remove mIsDeletingSurrounding even if applying this fix...  So it is OK.
Attachment #8634008 - Flags: review?(m_kato) → review+
> nsGtkIMModule::DeleteText posts several content queries, but NS_CONTENT_COMMAND_DELETE will
> causes selection change on non-e10s mode.

Ah, good point. I guess we should mark it as caused by content command or something.
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/82af92db4420e296e6249fa4c305a9417cc382e3
changeset:  82af92db4420e296e6249fa4c305a9417cc382e3
user:       Masayuki Nakano <masayuki@d-toybox.com>
date:       Fri Jul 17 13:27:32 2015 +0900
description:
Bug 1176959 nsGtkIMModule shouldn't commit composition when a selection change is notified but it was caused by selection set event r=m_kato
https://hg.mozilla.org/mozilla-central/rev/82af92db4420
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.