[e10s] NOTIFY_IME_OF_COMPOSITION_UPDATE isn't notified on parent process

RESOLVED FIXED in Firefox 42

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

({regression})

Trunk
mozilla42
Unspecified
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox42 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
After bug 1175392, this event isn't fired on parent process.  If not e10s, it works.
(Assignee)

Comment 1

4 years ago
Also, we shouldn't check TextComposition since this event is notified when composition is committed too.
(Assignee)

Updated

4 years ago
Blocks: 1176959
(Assignee)

Updated

4 years ago
Assignee: nobody → m_kato
(Assignee)

Updated

4 years ago
Keywords: regression
tracking-e10s: --- → +
(Assignee)

Comment 2

4 years ago
Created attachment 8628153 [details] [diff] [review]
Send NOTIFY_IME_OF_COMPOSITION_UPDATE to parent correctly
(Assignee)

Comment 3

4 years ago
Comment on attachment 8628153 [details] [diff] [review]
Send NOTIFY_IME_OF_COMPOSITION_UPDATE to parent correctly

This is a regression by bug 1175392.

When PuppetWidget's composition update has to reply to parent process.  But after bug 1175392, this notification isn't received on parent process's widget.

If child process's notification, TextComposition is on child process.  So we shouldn't check TextComposition on parent process if from child process.
Attachment #8628153 - Flags: review?(masayuki)
Comment on attachment 8628153 [details] [diff] [review]
Send NOTIFY_IME_OF_COMPOSITION_UPDATE to parent correctly

Thank you!
Attachment #8628153 - Flags: review?(masayuki) → review+

Updated

4 years ago
Duplicate of this bug: 1179661
https://hg.mozilla.org/mozilla-central/rev/1a014f15d1f7
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox42: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.