Clicking a menu button doesn't collapse when clicking on the dropmarker.

RESOLVED FIXED in Firefox 42

Status

()

Core
XUL
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: arni2033, Assigned: Neil Deakin)

Tracking

40 Branch
mozilla42
All
Windows
Points:
---

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

3 years ago
Created attachment 8625607 [details]
Select-like buttons in UI not working properly on click.webm

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

1. Go to testcase_1.html. There's mixed content - it's the easiest way to get UI drop-down lists
2. Click shield icon in urlbar and then click dropmaker to open drop-down list.
3. Click dropmaker again to close drop-down list


Actual results:

Drop-down list stayed visible
(Reporter)

Comment 1

3 years ago
Created attachment 8625609 [details]
testcase_1.html

I have checked this only on Windows
(Reporter)

Comment 2

3 years ago
Comment on attachment 8625609 [details]
testcase_1.html

<html><head>
<meta http-equiv="content-type" content="text/html; charset=UTF-8"></head><body>
<iframe src="http://www.youtube.com/embed/9pmPa_KxsAM?feature=player_detailpage" allowfullscreen="" frameborder="0" height="360" width="640"></iframe>
</body></html>
(Reporter)

Comment 3

3 years ago
Created attachment 8625610 [details]
testcase_1.html
Attachment #8625609 - Attachment is obsolete: true

Comment 4

3 years ago
Did you test with FF40 or FF38?
I tested with Aurora+Nightly and I'm not able to reproduce your issue. Are your versions up-to-date?

If you tested with FF40, could you test with e10s disabled in the General options, please.
Flags: needinfo?(arni2033)
(Reporter)

Comment 5

3 years ago
Created attachment 8626008 [details]
Select-like buttons in UI not working properly on click 1.webm

Maybe this is OS-dependent? I use Windows7 and Firefox 32 bit (3 versions).
I have tested this on 38, 40, 41 (Release, DevEdition[Aurora], Nightly) and the behavior is the same, regardless of Hardware acceleration/e10s are ON/OFF.
This bug is presented for a long time.
Attachment #8625607 - Attachment is obsolete: true
Flags: needinfo?(arni2033)

Comment 6

3 years ago
Ok, I see. There are many bugs in your report (about the same issue).

About the drop-down list of the location bar, it's a recent regression, see bug 1148716.
About, the 2 others (notification and search bar), I dont know.

Comment 7

3 years ago
About the search bar, I think the issue is present since Mozilla added the new customize mode.
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=beddd6d4bcdf&tochange=ba9ecdea3a90

Comment 8

3 years ago
Gijs, do you know if there is a bug open about the drop-down list of the Search bar moved to the Customize panel which cannot be closed when clicking again on the doorhanger?

I found you worked on a similar bug in the past (bug 879985).
Flags: needinfo?(gijskruitbosch+bugs)

Comment 9

3 years ago
Neil would know better than me about the select element in the mixed content popup.

Florian is probably a better bet for the search dropdown. Not sure what that is doing, but I imagine there is code to close the popup inside there, and that somehow interacts with the code in the panel to close popups, or something.
Flags: needinfo?(gijskruitbosch+bugs)
Flags: needinfo?(florian)
Flags: needinfo?(enndeakin)

Comment 10

3 years ago
I can confirm the behavior showed in the video while combo boxes in bugzilla seem to have the proper behavior.

I tested in the rest of Windows and it appears that clicking a second time on such dropdowns is supposed to close it, so this is not the correct behavior.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 11

3 years ago
Comment on attachment 8625607 [details]
Select-like buttons in UI not working properly on click.webm

(In reply to :Gijs Kruitbosch from comment #9)
> about the select element in the mixed content popup.
This doesn't only refer to mixed-content popup; It happens for me with all drop-down lists, e.g. after installing extension and getting a prompt to restart the browser. (Watch another attached video)

(In reply to Loic from comment #6)
> Ok, I see. There are many bugs in your report (about the same issue)
I considered this bug to be about "select-like" buttons, just recorded other issues on the video because they may be somehow connected (sorry).
I try to file 1 bug per report. Please edit title if needed.
Attachment #8625607 - Attachment is obsolete: false

Comment 12

3 years ago
(In reply to arni2033 from comment #11)
> (In reply to :Gijs Kruitbosch from comment #9)
> > about the select element in the mixed content popup.
> This doesn't only refer to mixed-content popup; It happens for me with all
> drop-down lists, e.g. after installing extension and getting a prompt to
> restart the browser. (Watch another attached video)

This isn't a select/menulist dropdown, though, but a type="menu-button" button (split button). Neil would probably still be the right person to talk to.
(Assignee)

Comment 13

3 years ago
Created attachment 8626259 [details] [diff] [review]
Possible fix

This is because when a menu type button is itself inside a popup, we are checking for the trigger of the outer popup, rather than the menu.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Flags: needinfo?(enndeakin)
(Assignee)

Updated

3 years ago
Summary: Select-like drop-down lists in UI don't collapse by clicking on dropmarker. → Clicking a menu button doesn't collapse when clicking on the dropmarker.

Comment 14

3 years ago
Will it fix too the regression you introduced when clicking on the dropmarker of the location bar in bug 1148716?
(Assignee)

Comment 15

3 years ago
> Will it fix too the regression you introduced when clicking on the
> dropmarker of the location bar in bug 1148716?

No.
OS: Unspecified → Windows
Hardware: Unspecified → All
(Assignee)

Comment 16

3 years ago
Created attachment 8627655 [details] [diff] [review]
Fix with better comments
Attachment #8626259 - Attachment is obsolete: true
Attachment #8627655 - Flags: review?(neil)
(In reply to :Gijs Kruitbosch from comment #9)

> Florian is probably a better bet for the search dropdown. Not sure what that
> is doing, but I imagine there is code to close the popup inside there, and
> that somehow interacts with the code in the panel to close popups, or
> something.

Sorry for the delay in replying here. If Neil's fix doesn't address the search panel case, I think it would be preferable to figure out what's going on in that panel in a separate bug (I thought we already had one, but couldn't find any).
Flags: needinfo?(florian)
Comment on attachment 8627655 [details] [diff] [review]
Fix with better comments

(Sorry for the delay.)
Attachment #8627655 - Flags: review?(neil) → review+

Comment 19

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/46c5af10adc5
https://hg.mozilla.org/mozilla-central/rev/46c5af10adc5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42

Updated

2 years ago
Component: Untriaged → XUL
Product: Firefox → Core
Target Milestone: Firefox 42 → mozilla42
(Reporter)

Updated

2 years ago
See Also: → bug 1198156
(Reporter)

Updated

2 years ago
See Also: → bug 1199875
(Reporter)

Updated

2 years ago
See Also: → bug 1188066
You need to log in before you can comment on or make changes to this bug.