camera fails to save image after presessing the hardware button more than once

VERIFIED FIXED in Firefox OS master

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: vladikoff, Assigned: aosmond)

Tracking

({foxfood})

unspecified
FxOS-S5 (21Aug)
foxfood

Firefox Tracking Flags

(b2g-master verified)

Details

(Whiteboard: [bzlite])

Attachments

(2 attachments, 14 obsolete attachments)

46 bytes, text/x-github-pull-request
aosmond
: review+
Details | Review | Splinter Review
3.25 MB, video/3gpp
Details
(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
(Reporter)

Comment 1

3 years ago
Created attachment 8625757 [details]
system-b2g-application.ini
(Reporter)

Comment 2

3 years ago
Created attachment 8625758 [details]
proc-version.log
(Reporter)

Comment 3

3 years ago
Created attachment 8625759 [details]
proc-vmallocinfo.log
(Reporter)

Comment 4

3 years ago
Created attachment 8625760 [details]
proc-vmstat.log
(Reporter)

Comment 5

3 years ago
Created attachment 8625761 [details]
proc-uptime.log
(Reporter)

Comment 6

3 years ago
Created attachment 8625762 [details]
proc-meminfo.log
(Reporter)

Comment 7

3 years ago
Created attachment 8625763 [details]
proc-kmsg.log
(Reporter)

Comment 8

3 years ago
Created attachment 8625764 [details]
proc-cmdline.log
(Reporter)

Comment 9

3 years ago
Created attachment 8625765 [details]
dev-log-radio.log
(Reporter)

Comment 10

3 years ago
Created attachment 8625766 [details]
dev-log-system.log
(Reporter)

Comment 11

3 years ago
Created attachment 8625767 [details]
dev-log-main.log
(Reporter)

Comment 12

3 years ago
Created attachment 8625768 [details]
properties.log
(Reporter)

Comment 13

3 years ago
Created attachment 8625769 [details]
screenshot.png

Updated

3 years ago
Component: Gaia::Feedback → Gaia::Camera
Flags: needinfo?(aosmond)
(Assignee)

Updated

3 years ago
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Flags: needinfo?(aosmond)
(Assignee)

Comment 14

3 years ago
Created attachment 8628412 [details] [review]
[gaia] aosmond:bug1177110 > mozilla-b2g:master
Attachment #8625757 - Attachment is obsolete: true
Attachment #8625758 - Attachment is obsolete: true
Attachment #8625759 - Attachment is obsolete: true
Attachment #8625760 - Attachment is obsolete: true
Attachment #8625761 - Attachment is obsolete: true
Attachment #8625762 - Attachment is obsolete: true
Attachment #8625763 - Attachment is obsolete: true
Attachment #8625764 - Attachment is obsolete: true
Attachment #8625765 - Attachment is obsolete: true
Attachment #8625766 - Attachment is obsolete: true
Attachment #8625767 - Attachment is obsolete: true
Attachment #8625768 - Attachment is obsolete: true
Attachment #8625769 - Attachment is obsolete: true
Attachment #8628412 - Flags: review?(jdarcangelo)
Comment on attachment 8628412 [details] [review]
[gaia] aosmond:bug1177110 > mozilla-b2g:master

LGTM, thanks!
Attachment #8628412 - Flags: review?(jdarcangelo) → review+
Keywords: foxfood
Keywords: dogfood
QA Whiteboard: [foxfood-triage]
Created attachment 8647520 [details] [review]
[gaia] aosmond:bug1177110 > mozilla-b2g:master
(Assignee)

Comment 17

3 years ago
Comment on attachment 8647520 [details] [review]
[gaia] aosmond:bug1177110 > mozilla-b2g:master

Carry justindarc r+.
Attachment #8647520 - Flags: review+
(Assignee)

Updated

3 years ago
Attachment #8628412 - Attachment is obsolete: true
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1193099
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/58540be4ca8b36f5727e1d25b301b25d96209757
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S5 (21Aug)
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5.

STR:
1. Open Camera app. 
2. Press volume down button or shutter button for several times (>1) as fast as possible to take  pictures.

Actual results: After pressing the hardware button more than once, all pictures taken from the camera are saved properly. 
See attachment: verified_AriesKK_v2.5.3gp
Reproduce rate: 0/15


Device: Flame KK 2.5 (Pass)
Build ID               20150818150207
Gaia Revision          507ba38fb64b27f87d11f4104dfcc58448e12b1a
Gaia Date              2015-08-18 10:50:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c272af993c23e803f6ea7798a812b0c8abfad4d
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150818.184156
Firmware Date          Tue Aug 18 18:42:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20150818233027
Gaia Revision          1e1197e0e8e64307aa382ffba4711d1c661de7ca
Gaia Date              2015-08-18 16:54:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/88e1d293ffa9faf065b2a944c94a2705aabf1fb9
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150818.225517
Firmware Date          Tue Aug 18 22:55:24 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [foxfood-triage] → [foxfood-triage][MGSEI-Triage+]
status-b2g-master: fixed → verified
Created attachment 8649663 [details]
verified_AriesKK_v2.5.3gp
You need to log in before you can comment on or make changes to this bug.