[Contacts]"? Selected " string will change to "contacts", after user backs to delete contact view.

RESOLVED WONTFIX

Status

defect
P2
normal
RESOLVED WONTFIX
4 years ago
a year ago

People

(Reporter: xiongfuchao, Unassigned)

Tracking

unspecified
All
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(2 attachments)

Posted file logcat_425.txt
[1.Description]:
[Flame v2.2 & v3.0][Nexus 5 v2.2 & v3.0][Dialer]If user tries to delete contacts, after selecting them at Contacts view, title of this view changes  to "? selected". Tap Delete to open delete contacts view. Tap Cancel and back, "? Selected " string changes to "Contacts" even there are contacts selected.
Found time:04:25
See attachment:logcat_425.txt & video.3gp

[2.Testing Steps]: 
Prerequisite:There are contacts in device.
1.Open contacts.
2.Open delete contacts page.
3.Select 2 contacts.
4.Tap "delete".
5.Tap "cancel" button.

[3.Expected Result]: 
5.Title should be "2 Selected".

[4.Actual Result]: 
5.Title changes to "Contacts".

[5.Reproduction build]: 
Device: Flame 2.2 version(Affected):
Build ID               20150624162504
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2f8b845e5fa3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.195750
Firmware Date          Wed Jun 24 19:58:02 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 version(Affected):
Build ID               20150624080416
Gaia Revision          eb0d4aefa62b20420d6fa0642515a110daca5d97
Gaia Date              2015-06-24 01:48:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4cdc1a95a672
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.153831
Firmware Date          Wed Jun 24 15:38:44 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 version(Affected):
Build ID               20150624002503
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3268ab642b70
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150624.034819
Firmware Date          Wed Jun 24 03:48:36 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5_3.0 version(Affected):
Build ID               20150624010204
Gaia Revision          311c4e59936a407e64509f54fecb440d8a78e3c8
Gaia Date              2015-06-20 20:21:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be81b8d6fae9
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150624.043116
Firmware Date          Wed Jun 24 04:31:35 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Posted video video.3GP
[Blocking Requested - why for this release]: We might have lived with it for several releases, however this will probably confuse who made a mistake.
blocking-b2g: --- → 3.0?
A ugly one, but definitely I wouldn't hold a release for this ;)
Comms triage: Not confusing enough to hold a release.
blocking-b2g: 2.5? → ---
Priority: -- → P2
Duplicate of this bug: 1191732

Comment 6

a year ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.