Closed Bug 1177360 Opened 8 years ago Closed 6 years ago

Amazon pages offer Reader Mode, produce either random review content or Amazon Prime / shipping offers - should work better or not be offered

Categories

(Toolkit :: Reader Mode, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox41 --- affected
firefox54 --- fixed

People

(Reporter: vtamas, Assigned: evanxd)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [reader-mode-readability-algorithm])

Attachments

(3 files)

Reproducible on:  Firefox 38.0.5, Firefox 39 RC,Firefox 40.0a2 and Firefox 41.0a1 across all platforms

STR
1.Launch Firefox with clean profile.
2.Navigate to http://goo.gl/BnnMDN (Amazon page)
3.Click on “Reader view” button from location bar.

ER
The page is correctly displayed in Reader View Mode.

AR
A piece of code is displayed instead of the text.

Additional notes:
- This issue is reproducible on Firefox 38.0.5 (20150521175336), Firefox 39 RC (20150624153222), Firefox 40.0a2 (2015-06-24) and Firefox 41.0a1 (2015-06-24) across Windows 8.1 32-bit, Mac OS X 10.9.5 and Ubuntu 12.04 32-bit.
- I am attaching a screenshot: http://i.imgur.com/iEUvdbv.jpg
 
Examples of pages where this issue is reproducible: 
- http://www.amazon.com/gp/product/B007JUFKLI/ref=s9_al_bw_g147_i8?pf_rd_m=ATVPDKIKX0DER&pf_rd_s=merchandised-search-7&pf_rd_r=0AWFN000PWMTAB68HN7R&pf_rd_t=101&pf_rd_p=1980639382&pf_rd_i=524136
- http://www.amazon.com/gp/product/B00MV9EL6M?ref_=gbsl_img_l-1_8122_0db51347&smid=ATVPDKIKX0DER
- http://www.amazon.com/Q-See-QT5682-8E3-1-8-Channel-Surveillance-High-Resolution/dp/B00I3DOZHK/ref=lp_14241611_1_2?s=security-surveillance&ie=UTF8&qid=1435225351&sr=1-2
- http://www.amazon.com/VTech-DM221-Sound-Digital-Monitor/dp/B007NG5UF4/ref=sr_1_3?s=baby-products&ie=UTF8&qid=1435225374&sr=1-3
Only the last three examples still offer reader mode:

- http://www.amazon.com/gp/product/B00MV9EL6M?ref_=gbsl_img_l-1_8122_0db51347&smid=ATVPDKIKX0DER
- http://www.amazon.com/Q-See-QT5682-8E3-1-8-Channel-Surveillance-High-Resolution/dp/B00I3DOZHK/ref=lp_14241611_1_2?s=security-surveillance&ie=UTF8&qid=1435225351&sr=1-2
- http://www.amazon.com/VTech-DM221-Sound-Digital-Monitor/dp/B007NG5UF4/ref=sr_1_3?s=baby-products&ie=UTF8&qid=1435225374&sr=1-3

all of these offer real text, but it's probably not useful to offer reader mode on this page.
Summary: Amazon page incorrect displayed in Reader View Mode → Amazon pages offer Reader Mode, produce either random review content or Amazon Prime / shipping offers - should work better or not be offered
Priority: -- → P3
Whiteboard: [reader-mode-readability-algorithm]
Blocks: 1324630
> but it's probably not useful to offer reader
> mode on this page.

Agreed, I think we don't need to show reader mode button for product description pages in shopping websites. I would say it might be not useful.

But it's quite difficult to determine which page is a product description page in a shopping website or not. Maybe we could make a list of top shopping websites to deal with top shopping websites. I know hard-code thing is always a good idea. But I don't other better ideas for it yet. Let's try to come up with better ideas.

What do you think? Let's try to disable reader mode button for Amazon product description pages even the pages in other shopping websites.
Flags: needinfo?(gijskruitbosch+bugs)
And the safari browser doesn't show reader button for the web pages listed on Comment 0.
(In reply to Evan Tseng [:evanxd] from comment #2)
> > but it's probably not useful to offer reader
> > mode on this page.
> 
> Agreed, I think we don't need to show reader mode button for product
> description pages in shopping websites. I would say it might be not useful.
> 
> But it's quite difficult to determine which page is a product description
> page in a shopping website or not. Maybe we could make a list of top
> shopping websites to deal with top shopping websites. I know hard-code thing
> is always a good idea. But I don't other better ideas for it yet. Let's try
> to come up with better ideas.
> 
> What do you think? Let's try to disable reader mode button for Amazon
> product description pages even the pages in other shopping websites.

Firefox already has a builtin blocklist. The simple solution here is adding amazon to that.

If we need an alternative, the question should be: why do we offer the reader mode icon and how could we change the code that is judging there's "readable" content here so that we no longer offer it, without impacting performance too much?

If there is no easy answer to this, we can add it to the blocklist and move on.
Flags: needinfo?(gijskruitbosch+bugs)
> Firefox already has a builtin blocklist. The simple solution here is adding
> amazon to that.
> 
> If we need an alternative, the question should be: why do we offer the
> reader mode icon and how could we change the code that is judging there's
> "readable" content here so that we no longer offer it, without impacting
> performance too much?
> 
> If there is no easy answer to this, we can add it to the blocklist and move
> on.

I would say there is no easy answer to it. Using the blocklist could be a good and simple solution. But I don't know we have a blocklist to disable reader mode or other features when visiting some websites. Could you tell me where can I find it? Thanks.

One more reason of using the blocklist, we can disable reader mode button for the top websites(not only shopping websites for all top websites) supported not well yet then we could re-enable them one by one during the process of making our Readability algorithm have good/better support for them.

What do you think?
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Evan Tseng [:evanxd] (Away 2/25 - 2/28) from comment #5)
> > Firefox already has a builtin blocklist. The simple solution here is adding
> > amazon to that.
> > 
> > If we need an alternative, the question should be: why do we offer the
> > reader mode icon and how could we change the code that is judging there's
> > "readable" content here so that we no longer offer it, without impacting
> > performance too much?
> > 
> > If there is no easy answer to this, we can add it to the blocklist and move
> > on.
> 
> I would say there is no easy answer to it. Using the blocklist could be a
> good and simple solution. But I don't know we have a blocklist to disable
> reader mode or other features when visiting some websites. Could you tell me
> where can I find it? Thanks.
> 
> One more reason of using the blocklist, we can disable reader mode button
> for the top websites(not only shopping websites for all top websites)
> supported not well yet then we could re-enable them one by one during the
> process of making our Readability algorithm have good/better support for
> them.
> 
> What do you think?

https://dxr.mozilla.org/mozilla-central/rev/a08ec245fa24d573fc99e81210ecc09de734cdd3/toolkit/components/reader/ReaderMode.jsm#379-386

I think we should add amazon. I think for other things we should consider them on a case-by-case basis. I'm more comfortable adding sites where users don't expect reader mode to work and it's not clear how to disable detection in another, reasonable, way (like amazon), than with adding sites where the readability result is maybe not perfect in some cases (e.g. nytimes before some of our fixes), but where users do expect a reader mode result.

One other thing to consider for this particular bug is whether amazon has an online kindle/epub/ebook thing. I don't know if they do, but if so we should probably make sure we don't disable support there assuming it works OK.
Flags: needinfo?(gijskruitbosch+bugs)
Assignee: nobody → evan
Attached image amazon-reader-1.png
Attached image amazon-reader-2.png
Comment on attachment 8842367 [details]
Bug 1177360 - Disable reader mode button for amazon.com,

https://reviewboard.mozilla.org/r/116238/#review117796

::: toolkit/components/reader/ReaderMode.jsm:380
(Diff revision 1)
>      if (this.DEBUG)
>        dump("Reader: " + msg);
>    },
>  
>    _blockedHosts: [
> -    "mail.google.com",
> +    "amazon.com",

```
One other thing to consider for this particular bug is whether amazon has an online kindle/epub/ebook thing. I don't know if they do, but if so we should probably make sure we don't disable support there assuming it works OK.
```
Replied the Comment 6[1] here.

Yes, there is a Kindle Cloud Reader[2] for kindle users. But I think we shouldn't enable reader mode button for it because that is a web-based reader application(maybe a single page application?) for users to read books. It doesn't load full content of a book into a webpage at one time. It only loads two pages tat one time, like the screenshots[3],[4]. What do you think?

[1]: https://bugzilla.mozilla.org/show_bug.cgi?id=1177360#c6
[2]: https://read.amazon.com
[3]: https://bug1177360.bmoattachments.org/attachment.cgi?id=8842368
[4]: https://bug1177360.bmoattachments.org/attachment.cgi?id=8842369
Comment on attachment 8842367 [details]
Bug 1177360 - Disable reader mode button for amazon.com,

https://reviewboard.mozilla.org/r/116238/#review117818

Alright, let's do it.
Attachment #8842367 - Flags: review?(gijskruitbosch+bugs) → review+
Thanks for reviewing, Gijs.
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/af332c1ddc74
Disable reader mode button for amazon.com, r=Gijs
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/af332c1ddc74
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.