Closed Bug 1178087 Opened 9 years ago Closed 8 years ago

Dead and useless Links in Menu 'Debug → Verifications' , complete menu item should be dropped

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set
minor

Tracking

(seamonkey2.43 affected)

RESOLVED DUPLICATE of bug 1258226
Tracking Status
seamonkey2.43 --- affected

People

(Reporter: RainerBielefeldNG, Unassigned, Mentored)

Details

(Whiteboard: [good first bug])

Attachments

(1 file)

Menu 'Debug → Verifications' of  DE SeaMonkey 2.35(γ)  (Windows NT 6.1; WOW64; rv:38.0 nightly by Adrian Kalla)  Gecko/20100101 Build 20150616034436 (Classic Theme) on German WIN7 64bit contains some dead links:

a) Larger page: does not exist, Error 404
b) Smaller page: does not exist, Error 404
c) city.net: Page not found
d) Mirabilis: forwarded to http://www.icq.com/de

The rest of the links seem rather useless to me, show an arbitrary selection of web pages without any explication fro what that demo should be useful.

I think the menu item "Verifications" should be dropped.
i would like to work on this bug
(In reply to tannishk sharma from comment #1)
Great! Do you already know how to start or do you need some hints (where to find the source code ...)?
Generally such UI issues are a good possibility to get familiar with code and project. 
In "Bug 188255 - element properties items misaligned" currently dhanvicse@gmail.com is doing some first steps in the code, may be you can do some coworking and exchange of experiences?

@Tummala Dhanvi: are you interested in some cowork?
@Philip: Can you do some first mentoring or pass the task?
Assignee: nobody → RainerBielefeldNG
Mentor: philip.chee
Yes I am interested in co-work :)
yes i need some help where is the source code and which file to remove the menu item from ??
Update:- 

@tannishk sharma has contacted me via email on getting started with cloning the source code and building the  SM I have pointed him to https://developer.mozilla.org/en-US/docs/Simple_SeaMonkey_build and asked him to contact me if he was struck some where 

I am waiting for his response to on his progress :)
Here is a proposed patch that replaces the dead `Larger Page,' `Smaller Page,' and 'GIF Images' portions of the verification pane with links to their 'http://www-archive.mozilla.org' counterparts. As for Mirabilis and city.net; those sites seem to be remnants of the 90s and at this point should probably just be removed (also included in patch).
(In reply to John Duncan from comment #6)
> Created attachment 8666478 [details] [diff] [review]
> Updates dead links to redirect to Mozilla's archived versions
> 
> Here is a proposed patch that replaces the dead `Larger Page,' `Smaller
> Page,' and 'GIF Images' portions of the verification pane with links to
> their 'http://www-archive.mozilla.org' counterparts. As for Mirabilis and
> city.net; those sites seem to be remnants of the 90s and at this point
> should probably just be removed (also included in patch).

Well this bug is being worked by https://bugzilla.mozilla.org/user_profile?login=tannishk%40gmail.com 

it's suggested that you comment on the bug before starting to work on it. 

so that one will come to know that you are working on it and don't want some one else working on it. 

also make use of the Need more information form and the review ? flag for the patch
Hm, yes, the SeaMonkey Debug & QA UI is badly outdated. I suppose this problem should be fixed first on trunk, and then ported (or not) to aurora etc.
OS: Unspecified → All
Hardware: Unspecified → All
Version: SeaMonkey 2.35 Branch → Trunk
NEW due to <https://blog.seamonkey-project.org/2015/11/25/my-unconfirmed-bug-reports/>

Anything new concerning fixing this? questions, suggestions?

Still REPRODUCIBLE with  English SeaMonkey 2.43a1  (X11; Linux x86_64; rv:46.0)  Gecko/20100101 Firefox/46.0 Build 20160109003001  (Default Theme) on VirtualBox Ubuntu 14.04 LTS
Assignee: RainerBielefeldNG → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
Just found this by accident. Looks like I fixed this in Bug 1258226. 

John if you put another patch up set review? or feedback? so that it doesn't get lost in time.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: