Overhaul debugQA extension in Seamonkey and remove obsolete items

RESOLVED FIXED

Status

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

SeaMonkey Tracking Flags

(seamonkey2.44 wontfix, seamonkey2.45 wontfix, seamonkey2.46 wontfix, seamonkey2.47 wontfix, seamonkey2.48 fixed)

Details

()

Attachments

(2 attachments, 7 obsolete attachments)

I propose to remove the debugQA extension from Seamonkey. Half the urls are dead and every changed one always would need to be changed in the code. It's also not localized and causes problems in l10n builds.  

The working urls could be put on a website. 

http://www.seamonkey-project.org/dev/get-involved

would be a good candidate because it's displayed after nightly installation.
Posted file debugQA hyperlink test results (obsolete) —
I would prefer a less radical solution, but indeed, in the current shape the menu item is not acceptable.
My suggestion: 
- drop from SeaMonkey
- reworked Version to AMO
- Link to add-on on AMO on "Get Involved"
Attachment #8732705 - Attachment is obsolete: true
> Tree Status; Permissions required, currently useless
We can use:
https://treeherder.mozilla.org/#/jobs?repo=comm-central
(However this is actually Thunderbird.

or
https://api.pub.build.mozilla.org/treestatus/details/comm-central-seamonkey
I prefer this one.
Posted patch 1258226-remove-debugqa.patch (obsolete) — Splinter Review
This patch kills debugqa. I am not setting review? right now until there is a consensus that it should go and what the replacement should be. 

We could also add a permanent section in bookmarks.html.in or an extra bookmarks section one that is only put in aurora and central builds.

My favorite is still to put the links somewhere on http://www.seamonkey-project.org so that they can changed outside of the browser source tree.
There are a number of different parts to DebugQA
1/ The Debug and QA menus in browser
I would say that there is only one useful item in the Debug menu, but the QA menu still serves a purpose it needs some love.
2/ The Debug menu in composer
I would say this has a lot of useful items in, though some of them might be better suited to other menus.
3/ The Debug preferences
I would say this is still very useful.
(In reply to Ian Neal from comment #6)
> There are a number of different parts to DebugQA
Indeed, the extension contains much more than some links (most of them not working), I wasn't aware of that. It would be a bad idea to drop that all.

On the other hand I share FRG's assessment that the current debugQA is very problematic and may be more or less irredeemable. Half of the add-on has become obsolete, there is no Help contents for it, it's a mess.

My suggestions: see <https://wiki.mozilla.org/SeaMonkey/Tasks_%26_Projects/debugQA2#ToDos>
What the heck does the Form Field function in Composer - Debug?
Summary: Remove debugQA from Seamonkey → Remove debugQA from Seamonkey or overhaul it removing obsolete items
See Also: → 456628
I'd go with Rainer's point 3: Drop DebugQA from SeaMonkey bundle, but make it available on AMO.
Posted patch 1258226-debugqa-cleanup.patch (obsolete) — Splinter Review
For a start how about removing all the dead links and other stuff.

I also see no value in the verification links to more or less popular websites which just do nothing other than opening the website.
Assignee: nobody → frgrahl
Attachment #8734873 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8778703 - Flags: review?(philip.chee)
Attachment #8778703 - Flags: review?(iann_bugzilla)
Comment on attachment 8778703 [details] [diff] [review]
1258226-debugqa-cleanup.patch

>+++ b/suite/debugQA/content/EditorInitPage.html
>@@ -28,19 +28,19 @@ under development.  It's also a great pl
> 
> <p>
> Here is an acute entity: "&aacute;".
> This&nbsp;&nbsp;sentence&nbsp;&nbsp;has&nbsp;&nbsp;two&nbsp;&nbsp;&amp;nbsp;&nbsp;&nbsp;tags&nbsp;&nbsp;between&nbsp;&nbsp;each&nbsp;&nbsp;word.
> </p>
> <hr size="2" width="100%"/>
> <div>
> <p>
>-This paragraph is inside a &lt;div&gt;. <a href="http://www.mozilla.org">Here is some
>+This paragraph is inside a &lt;div&gt;. <a href="http://www.seamonkey-project.org/">Here is some
> rather boring text that is a link.</a>  Now is the time for all good men (and women)
>-to come to the mozilla.org party.  And bring the quick brown fox and the lazy dog with you.
>+to come to the seamonkey-project party.  And bring the quick brown fox and the lazy dog with you.
Nice :)

>+++ b/suite/debugQA/content/debugQAMenuOverlay.xul

>+            <menuitem label="Animated png demos" oncommand="openTopWin('https://people.mozilla.org/~dolske/apng/demo.html');"/>
PNG rather than png perhaps? Either way should be consistent.
>             <menuitem label="PNG Images" oncommand="openTopWin('http://www.libpng.org/pub/png/png-MagnoliaAlpha.html');"/>

This below is meant to be a list of important sites that it would be bad to break in.
>+            <menuitem label="Seamonkey"
Nit: SeaMonkey (or would an entity work here)?
>+                      oncommand="openTopWin('http://www.seamonkey-project.org/');"/>
>             <menuitem label="Mozilla"
>                       oncommand="openTopWin('http://www.mozilla.org');"/>
>-            <menuitem label="Yahoo"
>-                      oncommand="openTopWin('http://www.yahoo.com');"/>
Could keep.
>-            <menuitem label="Netscape"
>-                      oncommand="openTopWin('http://www.netscape.com');"/>
Change to AOL?
>-            <menuitem label="Excite"
>-                      oncommand="openTopWin('http://www.excite.com');"/>
Remove.
>-            <menuitem label="Microsoft"
>-                      oncommand="openTopWin('http://www.microsoft.com');"/>
Could keep.
>-            <menuitem label="city.net"
>-                      oncommand="openTopWin('http://www.city.net');"/>
Not sure what it used to be but maybe change to Bloomberg?
>-            <menuitem label="Mirabilis"
>-                      oncommand="openTopWin('http://www.mirabilis.com');"/>
Well ICQ still exists (apparently), but maybe change to another computer software company?
>-            <menuitem label="Time"
>-                      oncommand="openTopWin('http://www.time.com');"/>
Could keep.
>-            <menuitem label="Warner Bros."
>-                      oncommand="openTopWin('http://www.warnerbros.com');"/>
Could keep.
>-            <menuitem label="CNN"
>-                      oncommand="openTopWin('http://www.cnn.com');"/>
Could keep.
>-            <menuitem label="USA Today"
>-                      oncommand="openTopWin('http://www.usatoday.com');"/>
Could keep.
>-            <menuitem label="Disney"
>-                      oncommand="openTopWin('http://www.disney.go.com');"/>
Could keep but URL needs updating.
>-            <menuitem label="Hotwired"
>-                      oncommand="openTopWin('http://www.hotwired.com');"/>
Could keep (Wired) but URL needs updating.
>-            <menuitem label="Hotbot"
>-                      oncommand="openTopWin('http://www.hotbot.com');"/>
Never heard of them, either remove or change to something else.

>     <menu id="qaMenu" accesskey="Q" label="QA" insertbefore="menu_Help">
>       <menupopup id="qaMenuPopup">
>         <menuitem label="Getting Involved"
>                   oncommand="openTopWin('http://www.seamonkey-project.org/start/');"/>
Should we insert a link to the SeaMonkey QA page here - https://wiki.mozilla.org/SeaMonkey:QA
>         <menuitem label="Mozilla QA Overview"
>                   oncommand="openTopWin('http://www.mozilla.org/quality/');"/>

f+/r- as I would like to see the new patch.
Attachment #8778703 - Flags: review?(iann_bugzilla)
Attachment #8778703 - Flags: review-
Attachment #8778703 - Flags: feedback+
Comment on attachment 8778703 [details] [diff] [review]
1258226-debugqa-cleanup.patch

> -            <menuitem label="GIF Images" oncommand="openTopWin('http://www.mozilla.org/quality/browser/debugtc/bft_browser_imagemap.html');"/>
> -            <menuitem label="Larger page" oncommand="openTopWin('http://www.mozilla.org/quality/browser/debugtc/bft_browser_html_mix3.html');"/>
> -            <menuitem label="Smaller page" oncommand="openTopWin('http://www.mozilla.org/quality/browser/debugtc/bft_browser_link.html');"/>
I found these at http://www-archive.mozilla.org/... so these can stay if you repoint them.

> This below is meant to be a list of important sites that it would be bad to break in.
We could use Alexa top 10 or top 20 perhaps.

> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test0.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test1.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test2.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test3.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test4.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test5.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test6.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test7.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test8.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test9.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test10.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test11.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test12.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test13.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test14.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test15.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/newlayout/samples/test16.html');"/>
http://www-archive.mozilla.org/newlayout/samples/...

> -                      oncommand="openTopWin('http://www.mozilla.org/projects/xbl/test0/test.xul');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/projects/xbl/test1/test.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/projects/xbl/test2/test.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/projects/xbl/test3/test.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/projects/xbl/test4/test.html');"/>
> -                      oncommand="openTopWin('http://www.mozilla.org/projects/xbl/test5/test.html');"/>
http://www-archive.mozilla.org/projects/xbl/...
We would also need to add XUL/XBL permissions to www-archive.org via the Data Manager.
Note to self: Integrate "Remote XUL Manager" extension to debugQA, or to the Data Manager.

> -                      oncommand="openTopWin('about:bloat?new');"/>
How about switching this to about:memory? We could also add a help link to:
https://developer.mozilla.org/docs/Mozilla/Performance/about:memory

Or to https://developer.mozilla.org/docs/Mozilla/Performance#Memory_profiling_and_leak_detection_tools
Which lists about:memory and using the Developer Tools "Memory" panel"

> -                  oncommand="openTopWin('http://www.mozilla.org/quality/bug-writing-guidelines.html');"/>
> +                  oncommand="openTopWin('https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines');"/>
Remove the /en-US/ part and let DevMo do language sniffing and redirect to a localized page if available.

> Smoke Tests; dead link
The successor to Smoke tests is moztrap
https://moztrap.mozilla.org/results/runs/

The Thunderbird section appears to be actively managed by wsmwk. Perhaps we can ask him how to set up a section for SeaMonkey.
https://moztrap.mozilla.org/manage/productversions/

> Pre-Checkin tests; dead link
http://www-archive.mozilla.org/quality/precheckin-tests.html
Outdated and not very relevant any more. Kill.
Attachment #8778703 - Flags: review?(philip.chee)
Attachment #8778703 - Flags: review-
Attachment #8778703 - Flags: feedback+
Cleaned, mangled, updated and inspected.

Set version to 1.0 and min version to 2.45 because about:performance is not available in lesser versions and you need to start somewhere.
Attachment #8778703 - Attachment is obsolete: true
Attachment #8787961 - Flags: feedback?(philip.chee)
Attachment #8787961 - Flags: feedback?(iann_bugzilla)
Posted file debugQA-2.48a1.xpi (obsolete) —
If someone who doesn't compile locally wants to do a test drive here is a binary. Verified working on 2.46 but should work on any 2.45+ to 2.48a1.

Unlike the old versions I didn't uninstall it immediately so it might actually be ok :)
Summary: Remove debugQA from Seamonkey or overhaul it removing obsolete items → Overhaul debugQA extension in Seamonkey and remove obsolete items
I noticed that Larger and Smaller Page are not really Images and Media so I moved them to a General Page Rendering submenu.
Attachment #8787961 - Attachment is obsolete: true
Attachment #8787961 - Flags: feedback?(philip.chee)
Attachment #8787961 - Flags: feedback?(iann_bugzilla)
Attachment #8787983 - Flags: feedback?(philip.chee)
Attachment #8787983 - Flags: feedback?(iann_bugzilla)
Posted file debugQA-2.48a1.xpi (obsolete) —
And a new xpi for the compiler challenged.
Attachment #8787962 - Attachment is obsolete: true
Comment on attachment 8787983 [details] [diff] [review]
1258226-debugqa-cleanup-V3.patch

> oncommand="openTopWin('https://support.mozilla.org/en-US/kb/how-does-phishing-and-malware-protection-work');"/>
Remove the /en-US/ and let support.mozilla.org redirect to a localized page (if it exists)

>         <menuitem label="File a Bug"
>                    oncommand="openTopWin('https://bugzilla.mozilla.org/enter_bug.cgi?format=guided');"/>

You can make that link with SeaMonkey pre-selected:
https://bugzilla.mozilla.org/enter_bug.cgi?format=guided#h=dupes|SeaMonkey

> -    <em:version>1.0pre</em:version>
> +    <em:version>1.0</em:version>
Lets go with a big bang and set the version to 2.0 !!!
Attachment #8787983 - Flags: review+
Attachment #8787983 - Flags: feedback?(philip.chee)
Attachment #8787983 - Flags: feedback+
See Also: 456628
Duplicate of this bug: 456628
Comment on attachment 8787983 [details] [diff] [review]
1258226-debugqa-cleanup-V3.patch

>+            <menu label="Images and Media">
>+              <menupopup>
>+                <menuitem label="GIF Images"
>+                          oncommand="openTopWin('http://www-archive.mozilla.org/quality/browser/debugtc/bft_browser_imagemap.html');"/>
>+                <menuitem label="PNG Images"
>+                          oncommand="openTopWin('http://www.libpng.org/pub/png/png-MagnoliaAlpha.html');"/>
>+                <menuitem label="Animated png demos"
>+                          oncommand="openTopWin('https://people.mozilla.org/~dolske/apng/demo.html');"/>
PNG rather than png?
Attachment #8787983 - Flags: feedback?(iann_bugzilla) → feedback+
After years in the making a reviewable version. I included the feedback but set the version to 2.0.0 instead of only 2.0. This way very minor changes can increment the last version. This will avoid version "bloat" and in case of Nightly it will auto update itself because of the version change.
Attachment #8787983 - Attachment is obsolete: true
Attachment #8787985 - Attachment is obsolete: true
Attachment #8790018 - Flags: review?(philip.chee)
Attachment #8790018 - Flags: review?(iann_bugzilla)
Comment on attachment 8790018 [details] [diff] [review]
1258226-debugqa-cleanup-V4.patch

LGTM r/a=me
Attachment #8790018 - Flags: review?(iann_bugzilla) → review+
Comment on attachment 8790018 [details] [diff] [review]
1258226-debugqa-cleanup-V4.patch

Fixed
https://hg.mozilla.org/comm-central/rev/accb8d46284c
Attachment #8790018 - Flags: review?(philip.chee)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1171331
Duplicate of this bug: 1170914
Duplicate of this bug: 532069
Duplicate of this bug: 1172269
Duplicate of this bug: 1178087
You need to log in before you can comment on or make changes to this bug.