Update libvpx to more recent git version (1.4.x)

RESOLVED FIXED in Firefox 40

Status

()

Core
Audio/Video
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Jan Gerber, Assigned: Jan Gerber)

Tracking

(Blocks: 1 bug)

Trunk
mozilla42
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox39 wontfix, firefox40 verified, firefox41 fixed, firefox42 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

3 years ago
libvpx got quite some updates in git. Would be good to update to a more recent version. Chromium uses e67d45d4ce92468ba193288b59093fef0a502662 with one patch.
(Assignee)

Comment 1

3 years ago
Created attachment 8627129 [details] [diff] [review]
Bug1178215_update_update.py.patch
Attachment #8627129 - Flags: review?(giles)
(Assignee)

Comment 2

3 years ago
Created attachment 8627130 [details] [diff] [review]
Bug1178215_update_libvpx.patch
Attachment #8627130 - Flags: review?(giles)
Comment on attachment 8627129 [details] [diff] [review]
Bug1178215_update_update.py.patch

Review of attachment 8627129 [details] [diff] [review]:
-----------------------------------------------------------------

Please split the update.py, patch and README_MOZILLA changes into a separate commit from the config updates which result from running the new update.py, so we have a clear point of reproducibility. r=me with that change.
Attachment #8627129 - Flags: review?(giles) → review+
Comment on attachment 8627130 [details] [diff] [review]
Bug1178215_update_libvpx.patch

Review of attachment 8627130 [details] [diff] [review]:
-----------------------------------------------------------------

Likewise, r=me with the update.py results split into either this commit, or a third patch.

Thanks for the update.
Attachment #8627130 - Flags: review?(giles) → review+
(Assignee)

Comment 5

3 years ago
Created attachment 8627371 [details] [diff] [review]
Bug1178215_update_update.py.patch
Attachment #8627129 - Attachment is obsolete: true
(Assignee)

Comment 6

3 years ago
Created attachment 8627373 [details] [diff] [review]
Bug1178215_update_libvpx.patch
Attachment #8627130 - Attachment is obsolete: true
(Assignee)

Comment 7

3 years ago
now fully untangled, time for a try push?
Flags: needinfo?(giles)
Comment on attachment 8627371 [details] [diff] [review]
Bug1178215_update_update.py.patch

Review of attachment 8627371 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +5592,5 @@
>        AC_MSG_WARN([No assembler or assembly support for libvpx. Using unoptimized C routines.])
>      fi
> +
> +    dnl native libvpx no longer has vpx_mem_set_functions
> +    AC_DEFINE(MOZ_VPX_NO_MEM_REPORTING)

We should patch this back in. I filed bug 1178831 for that.
Attachment #8627371 - Flags: review+
Blocks: 1177948
*** No rule to make target `/home/worker/workspace/gecko/media/libvpx/vp8/common/x86/variance_mmx.c', needed by `variance_mmx.o'.  Stop.

Pushed again with CLOBBER update. Try used to auto-clobber, but maybe that's changed? Looks like the familiar mach bug with moved files.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ce5c88684b39
Flags: needinfo?(giles)
Try looks good.
https://hg.mozilla.org/mozilla-central/rev/fa9904c62103
https://hg.mozilla.org/mozilla-central/rev/a5efc589a3d6
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41

Updated

3 years ago
Target Milestone: mozilla41 → mozilla42
Blocks: 1178148
Comment on attachment 8627373 [details] [diff] [review]
Bug1178215_update_libvpx.patch

Requesting uplift of both patches for Aurora and Beta.

Approval Request Comment
[Feature/regressing bug #]: Bug 1151175
[User impact if declined]: We need to take this for security and stability.
[Describe test coverage new/current, TreeHerder]: Landed on m-c some weeks ago.
[Risks and why]: This is an update to the same third-party snapshot chrome is shipping. I don't expect any issues.
[String/UUID change made/needed]: None.
Flags: needinfo?(abillings)
Attachment #8627373 - Flags: approval-mozilla-beta?
Attachment #8627373 - Flags: approval-mozilla-aurora?
status-firefox39: --- → wontfix
status-firefox40: --- → affected
status-firefox41: --- → affected
Comment on attachment 8627373 [details] [diff] [review]
Bug1178215_update_libvpx.patch

This update has been on m-c for a week. We're still early enough in Beta to take a bigger change like this.

Ralph - While you don't expect any issues, how will regressions due to this change appear in the browser if they are to appear? Or, what should we test for?

Beta+ Aurora+
Attachment #8627373 - Flags: approval-mozilla-beta?
Attachment #8627373 - Flags: approval-mozilla-beta+
Attachment #8627373 - Flags: approval-mozilla-aurora?
Attachment #8627373 - Flags: approval-mozilla-aurora+
Flags: needinfo?(abillings)
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #15)

> Ralph - While you don't expect any issues, how will regressions due to this
> change appear in the browser if they are to appear? Or, what should we test
> for?

Regressions would show primarily as video corruption or crashes in desktop-to-desktop webrtc (mozilla hello) sessions. Also the same for webm playback in the <video> element, but that's not broadly used in these firefox versions.
We have performed today regression testing using Firefox 40 Beta 3 (BuildID=20150709163524) and focused on Hello functionality and Video/Audio compatibility. There were no issues encountered related to video corruption for either Hello calls between different desktop machines, or Video playback. Detailed test results are available at: https://goo.gl/bWDsSd. 

Marking this as verified for Firefox 40 based on our testing results.
status-firefox40: fixed → verified
You need to log in before you can comment on or make changes to this bug.