location bar shows "search with Google" as the default action even when keyword.enabled is false

RESOLVED FIXED in Firefox 42

Status

()

Firefox
Location Bar
P2
normal
Rank:
23
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Bob49, Assigned: mak)

Tracking

({regression})

42 Branch
Firefox 42
regression
Points:
---
Bug Flags:
firefox-backlog +
in-testsuite +

Firefox Tracking Flags

(firefox42 fixed)

Details

(Whiteboard: [unifiedcomplete bug][fxsearch])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150630030204

Steps to reproduce:

1. set keyword.enabled to false
2. type gaston into the location bar

and unchecked box ...
http://getwebb.org/v/qwv4ZLom

Verified Safe Mode and New Profile


Actual results:

actual outcome:
- the default action is "gaston" - search with google" ! 


Expected results:

expected outcome:
- the default action should be displayed as "gaston" in bookmark or historical !

Updated

2 years ago
Component: Untriaged → Location Bar
(Assignee)

Comment 1

2 years ago
According to this comment (http://mxr.mozilla.org/mozilla-central/source/toolkit/components/places/UnifiedComplete.js#1092) we should show a "visit" entry and not a "search with" entry... So maybe something is wrong in that code assumption.
Blocks: 995091
Flags: firefox-backlog+
Priority: -- → P3
Whiteboard: [unifiedcomplete][fxsearch]
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1085796
(Assignee)

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

2 years ago
not identical bug:1085796 

Fx 42 and FX41 only affected by this bug.
No bug Fx 40 and Fx 39.

Updated

2 years ago
Rank: 23
Keywords: regression
Priority: P3 → P2

Updated

2 years ago
Whiteboard: [unifiedcomplete][fxsearch] → [unifiedcomplete bug][fxsearch]
(Assignee)

Comment 4

2 years ago
(In reply to Bob49 from comment #3)
> not identical bug:1085796 
> 
> Fx 42 and FX41 only affected by this bug.

41 is no more affected, we disabled the feature there.
(Reporter)

Comment 5

2 years ago
ok for 41. Users appreciate
(Assignee)

Updated

2 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
(Assignee)

Comment 6

2 years ago
Created attachment 8637146 [details] [diff] [review]
patch v1
Attachment #8637146 - Flags: review?(adw)
(Assignee)

Comment 7

2 years ago
Comment on attachment 8637146 [details] [diff] [review]
patch v1

rebalancing reviews load
Attachment #8637146 - Flags: review?(adw) → review?(dtownsend)
(Assignee)

Comment 8

2 years ago
Created attachment 8639755 [details] [diff] [review]
patch v1.1

minor unbitrot
Attachment #8637146 - Attachment is obsolete: true
Attachment #8637146 - Flags: review?(dtownsend)
Attachment #8639755 - Flags: review?(dtownsend)
Attachment #8639755 - Flags: review?(dtownsend) → review+

Comment 9

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/5c091530338b
(Assignee)

Updated

2 years ago
Flags: in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/5c091530338b
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42

Updated

2 years ago
Iteration: --- → 42.3 - Aug 10
You need to log in before you can comment on or make changes to this bug.