Closed Bug 1179249 Opened 4 years ago Closed 4 years ago

Firefox no longer provides an option to make it a default .html browser

Categories

(Firefox :: Shell Integration, defect)

All
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 42
Tracking Status
firefox40 --- fixed
firefox41 --- verified
firefox42 --- verified

People

(Reporter: petruta.rasa, Assigned: emk)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1173357 +++

Steps to reproduce:
1. Launch Firefox on Windows 10 (having Microsoft Edge set as default browser)
2. Go to Options > General.
3. Clink the [Make Default] button.
4. Choose Firefox as a default browser.
5. Double click an .html file on the Desktop.

Actual result:
Microsoft Edge will open the .html file.

Expected result:
Firefox should open the .html file.

See https://bugzilla.mozilla.org/show_bug.cgi?id=1173357#c18
Petruta, can you go to about:config and see what value you have for `browser.shell.windows10DefaultBrowserABTest` ?
Flags: needinfo?(petruta.rasa)
Blocks: windows-10
Build 10159 improved the modern settings dialog. Now the dialog will set all associations to the selected browser, not only http/https.
So we should always use the modern dialog for the [Make Default] button.
`browser.shell.windows10DefaultBrowserABTest` pref doesn't exist in Firefox 39RC build 6.

On a Win 10 x64 machine where I previously tested, after setting Firefox as default, the .html files from desktop changed their icon with Firefox icon (instead of edge) and were correctly opened with Firefox.

On another machine with Win 10 (x86), with Chrome set as default, the .html files were opened with Edge before and after setting Firefox as Default.

I will try again with 10159 build mentioned by :emk and Nightly.
Flags: needinfo?(petruta.rasa)
We don't have to force claimAllTypes=false anymore. After bug 1172724, Firefox will never use the classic control panel on Windows 10.
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Attachment #8628768 - Flags: review?(jaws)
Attachment #8628768 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/f0fbcfe0a7a7
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Flags: qe-verify+
Comment on attachment 8628768 [details] [diff] [review]
Always use the modern settings dialog in Preferences on Windows 10

Approval Request Comment
[Feature/regressing bug #]: 1172724
[User impact if declined]: Half of users (depending on the A/B test setting that are introduced by bug 1176112) will have no way to set Firefox as the default .html handler in Firefox UI.
[Describe test coverage new/current, TreeHerder]: manual testing
[Risks and why]: Very low. The UI is already provided to the other half of users.
[String/UUID change made/needed]: none
Attachment #8628768 - Flags: approval-mozilla-aurora?
(In reply to Masatoshi Kimura [:emk] from comment #2)
> Build 10159 improved the modern settings dialog. Now the dialog will set all
> associations to the selected browser, not only http/https.
So we should
> always use the modern dialog for the [Make Default] button.

This was a bit inaccurate. The modern dialog will set .html/.htm handler. as well as https/http handlers. (That would be a good thing because the dialog will not take over the .pdf handler when Microsoft Edge is selected as the default browser.)
Andrei, I noticed you have set the qe-verify:+ on this one. I would like to uplift this patch to Aurora but prefer to do it once it has been verified by QE. Has this been verified or in the works? Thank you for your help here!
Flags: needinfo?(andrei.vaida)
I can confirm that this issue is indeed fixed for Latest Nightly 42.0a1 (build ID: 20150709030206) on Windows 10 64-bit, build 10166.
Status: RESOLVED → VERIFIED
Flags: needinfo?(andrei.vaida)
QA Contact: cornel.ionce
Comment on attachment 8628768 [details] [diff] [review]
Always use the modern settings dialog in Preferences on Windows 10

Low-risk, verified, see Comment 7/
Attachment #8628768 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Also confirming the fix for the latest 41.0a2 Aurora.
Firefox correctly opened the .html file.
This should have requested uplift to Firefox 40 (mozilla-beta, at the time), resulting in bug 1193196 being discovered after Firefox 40 was released today. As a result we're uplifting it to mozilla-release and spinning a 40.0.1 with it and a couple other fixes.

https://hg.mozilla.org/releases/mozilla-release/rev/8567de70fdd5

(already discussed and approved with lmandel)
Blocks: 1193196
You need to log in before you can comment on or make changes to this bug.