Firefox no longer provides an option to make it a default .html browser

RESOLVED FIXED in Firefox 39

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: emk, Assigned: jaws)

Tracking

({regression})

unspecified
Firefox 41
All
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox39 verified, firefox40 fixed, firefox41 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
Steps to reproduce:
1. Launch Firefox on Windows 8 or later.
2. Go to Options > General.
3. Clink the [Make Default] button.
4. Choose Firefox as a default browser.
5. Double click an .html file on the Desktop.

Actual result:
Microsoft Edge will open the .html file.

Expected result:
Firefox should open the .html file.

A regression from bug 1167294. This is because the Modern Default Apps dialog will only change the http/https handler.
We should use the classic Default Programs control panel here. Note that it is NOT blocked on Windows 10.
Comment hidden (typo)
It is not blocked on Windows 10, but it is a subpar experience as you have to scroll through the list of apps to find Firefox and then click on another button to make it the default for all file types.

The modern Default Apps dialog is only a tiny bit better, but does have the downside that you have described.

Philip, which do you think we should do? If we think one is better than the other, should we make that one be launched from both the startup dialog as well as preferences? Or should we keep Preferences opening up the more "advanced" dialog (which comment #0 is advocating for)?
Flags: needinfo?(philipp)
Reporter

Comment 3

4 years ago
Please don't forget this bug also affects Windows 8. On Windows 8, the modern popup is much better than the classic control panel.

My recommendation is:
Always use the classic control panel in preferences.
Use the modern popup at startup on Windows 8.
We definitely need to use the modern control panel on Windows 10 since that OS doesn't give us any better options (and the classic control panel is too complex for most people to figure out what to do).

Given that it is questionable how long the classic control panel will stay around, I would avoid using it on Windows 10. Could we restrict the changes from bug 1167294 to Windows 10?
Flags: needinfo?(philipp)
Reporter

Comment 5

4 years ago
I found the modern dialog had "Set defaults by app" button to open the classic control panel.
Still no luck on Windows 8.

(In reply to Philipp Sackl [:phlsa] please use needinfo from comment #4)
> Could we restrict the changes
> from bug 1167294 to Windows 10?

Good idea.
No longer blocks: windows-10
Posted patch PatchSplinter Review
This keeps the control panel dialog for Windows 8.1 and lower in the preferences. Maybe we can assume users who go through the Preferences are more "advanced"?
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8621039 - Flags: review?(gijskruitbosch+bugs)

Updated

4 years ago
Attachment #8621039 - Flags: review?(gijskruitbosch+bugs) → review+

Updated

4 years ago
Depends on: 1165321

Updated

4 years ago
Depends on: 1172890
https://hg.mozilla.org/mozilla-central/rev/8bdd7c1ef5d2
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Comment on attachment 8621039 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: regression from bug 1167294
[User impact if declined]: users who click on HTML files from their machine won't necessarily open firefox
[Describe test coverage new/current, TreeHerder]: manual testing
[Risks and why]: none expected, simply changed the minimum version for the change in behavior to windows 10 instead of windows 8.
[String/UUID change made/needed]: none
Attachment #8621039 - Flags: approval-mozilla-aurora?
Comment on attachment 8621039 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: windows 10 default browser (bug 1170803)
[User impact if declined]: windows 8 users will see a change in behavior that isn't necessary
[Describe test coverage new/current, TreeHerder]: manual testing
[Risks and why]: reduces scope of bug 1170803 to only windows 10+ instead of windows 8+
[String/UUID change made/needed]: none

(this is part of a approval-mozilla-beta request in conjunction with bug 1170803 and bug 1167294)
Attachment #8621039 - Flags: approval-mozilla-beta?

Updated

4 years ago
No longer depends on: 1172890

Updated

4 years ago
No longer depends on: 1165321
Comment on attachment 8621039 [details] [diff] [review]
Patch

We want a great support of Windows 10 in 40. However, I am not sure we should take it in beta. Liz will make the call.
Attachment #8621039 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8621039 [details] [diff] [review]
Patch

For this one thing (several bugs) I am taking it though we are late in beta because I don't want us to lose people who have Firefox set as their default browser.  The rest of the windows 10 fixes will ride with 40 and 41.
Attachment #8621039 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
I'm not able to reproduce this issue on older builds: Nightly from 2015-06-09 nor 39.0b4 (Build ID: 20150609130336).
With the above mentioned Firefox builds and the latest 39 beta 7 (Build ID: 20150618135210), the .html file is properly opened via Fx after performing STR from comment 0. Tested under Window 8 x64 and Windows 10 x86.
Masatoshi Kimura, could you please confirm that this is no longer an issue for you with latest beta build [1]? Thanks in advance!

[1] http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/39.0b7-candidates/build1/
Flags: needinfo?(VYV03354)
Reporter

Comment 16

4 years ago
Did set set Microsoft Edge as default first? (Sorry I forgot to mention it in the STR.)
I can still reproduce this with the 39.0b7 candidate on Windows 10 x64 (This is expected, the fix is only applicable on Windows 8).
Flags: needinfo?(VYV03354)
I see no changes in behavior when opening a .html file under Win 8 32-bit.

Under Win 10, opening a .html file for the first time shows the panel to choose an app for it. Firefox can be selected and it opens the file. The next times, Microsoft Edge will open the file with no option to select another app. Shouldn't this be tracked separately? 

I'm removing the keyword since this issue cannot be completely verified.
Flags: qe-verify+
(In reply to Petruta Rasa [QA] [:petruta] from comment #17)
> Under Win 10, opening a .html file for the first time shows the panel to
> choose an app for it. Firefox can be selected and it opens the file. The
> next times, Microsoft Edge will open the file with no option to select
> another app. Shouldn't this be tracked separately? 

Yes, can you please file a new bug for this?
You need to log in before you can comment on or make changes to this bug.