Closed Bug 1179285 Opened 5 years ago Closed 5 years ago

text-combine-upright should be behind a disabled pref

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla42
Tracking Status
firefox41 + verified
firefox42 --- verified

People

(Reporter: dbaron, Assigned: jfkthame)

References

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

Now that we're shipping the pref to enable writing-mode, that currently enables text-combine-upright.  Since it looks (though double-check me, please!) like we have parsing for text-combine-upright but no other support for it, we should switch text-combine-upright to being behind a different pref.  (Should be a one-line patch plus a tweak to property-database.js.)
Flags: needinfo?(jfkthame)
You're right, we should keep this disabled until we actually support it.
Flags: needinfo?(jfkthame)
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
As you'll see, I also removed ALWAYS_ENABLED_IN_UA_SHEETS from text-combine-upright; it got included when that was assigned to the rest of the vertical-text-related properties, but I don't think there's any need for it there.
Setting dev-doc-needed as I've added it to Fx 41 for devs and I need to remember to remove it (and somebody else is working on that page right now :-) )
Keywords: dev-doc-needed
Attachment #8628457 - Flags: review?(dbaron) → review+
Thanks for fixing this so quickly.

Also, don't forget that it will need uplift to Aurora, since we don't want to ship this in 41.
I added a note about this at https://developer.mozilla.org/en-US/docs/Web/CSS/text-combine-upright#Browser_compatibility.

@teoli: As you obviously already removed the property from the Firefox 41 for devs page, I set dev-doc-complete.

Sebastian
https://hg.mozilla.org/mozilla-central/rev/643d8e8d61a2
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Comment on attachment 8628457 [details] [diff] [review]
Give text-combine-upright its own pref, separate from writing-mode (vertical-text), so that we can keep it disabled until we actually have a layout implementation backing the CSS property

Approval Request Comment
[Feature/regressing bug #]: enabling writing-mode (bug 1138384)
[User impact if declined]: the text-combine-upright property will be parsed in CSS and exposed to JS even though not actually implemented in layout
[Describe test coverage new/current, TreeHerder]: covered by layout/style mochitests
[Risks and why]: low risk, just moves the CSS property behind a separate default-false pref
[String/UUID change made/needed]: n/a
Attachment #8628457 - Flags: approval-mozilla-aurora?
Tracking for 41 because affected.
Comment on attachment 8628457 [details] [diff] [review]
Give text-combine-upright its own pref, separate from writing-mode (vertical-text), so that we can keep it disabled until we actually have a layout implementation backing the CSS property

Approving for uplift to Aurora. Patch has been in m-c for a few days and it looks safe upon review.
Attachment #8628457 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Requesting QE to verify this CSS property is disabled.
Flags: qe-verify+
Verified fixed on Firefox 41.0b2 (20150817163452) and Aurora 42.0a2 (2015-08-18), using Windows 7 (x64), Mac OS X 10.10.4 and Ubuntu 14.04 (x86).

I've confirmed that "layout.css.text-combine-upright.enabled" is false by default and that the "text-combine-upright" CSS property is disabled, using this testcase [1]. 


[1] https://www.dropbox.com/s/lswdmjnm95rz9ok/testcase.html?dl=0.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.