Bug 1138384 (enable-writing-mode-release)

enable CSS writing-mode support in release channels

RESOLVED FIXED in Firefox 41

Status

()

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: jfkthame, Assigned: jfkthame)

Tracking

(Depends on 1 bug, Blocks 2 bugs, {dev-doc-complete})

unspecified
mozilla41
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 fixed, relnote-firefox -)

Details

Attachments

(1 attachment)

Assignee

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1099032 +++

Bug 1099032 will enable writing-mode support by default for developer channels. We intend to hold back from enabling it on release channels until more CSS layout features are properly vertical-enabled; those bugs should block this one.
Depends on: 1156996
Depends on: 1157951
Assignee

Updated

4 years ago
Depends on: 1158549
Depends on: 1164835
Assignee

Updated

4 years ago
No longer depends on: 1164835
Assignee

Comment 1

4 years ago
Once we land the various table-layout patches that are currently in flight, I think we're in good enough shape to do this.
Attachment #8626600 - Flags: review?(smontagu)
Attachment #8626600 - Flags: review?(dholbert)
Attachment #8626600 - Flags: review?(dbaron)
Assignee

Updated

4 years ago
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
What about flexbox and the underline stuff?
Flexbox is largely already logicalized, and I've got work-in-progress patches to finish it off. (once I finish with my reviews) 

(Not sure what the underline stuff is.)
No longer depends on: 1156996
(In reply to Daniel Holbert [:dholbert] from comment #3)
> (Not sure what the underline stuff is.)

Bug 1111955. The default position of underline is not very right for Japanese. The problem is that there is a pending issue on the spec, which doesn't seem to be clear yet.

Probably that shouldn't be a blocker of this bug, since our behavior currently matches that of all other browsers. Although we probably want to fix the eventually, it could happen later.
Assignee

Comment 5

4 years ago
(In reply to Xidorn Quan [:xidorn] (UTC+12) from comment #4)
> (In reply to Daniel Holbert [:dholbert] from comment #3)
> > (Not sure what the underline stuff is.)
> 
> Bug 1111955. The default position of underline is not very right for
> Japanese. The problem is that there is a pending issue on the spec, which
> doesn't seem to be clear yet.

As an interim solution, pending spec finalization, this has been fixed in bug 1175789. So I don't think we need to block on it here.
Assignee

Updated

4 years ago
No longer depends on: 1111955
Attachment #8626600 - Flags: review?(dbaron) → review+
Depends on: 1118103
Blocks: 1118103
No longer depends on: 1118103
Alias: enable-writing-mode-release
Comment on attachment 8626600 [details] [diff] [review]
Enable CSS writing-mode support for all channels

As with all feature-enablings, we should be open to backing this out on release channels (and punting for a release), if we uncover any serious brokenness [particularly on real sites] without an easily-backportable fix.

r=me with that in mind.
Attachment #8626600 - Flags: review?(dholbert) → review+
Assignee

Comment 7

4 years ago
(In reply to Daniel Holbert [:dholbert] from comment #6)
> As with all feature-enablings, we should be open to backing this out on
> release channels (and punting for a release), if we uncover any serious
> brokenness [particularly on real sites] without an easily-backportable fix.

Yes, definitely.

Pushing to inbound, in the hope it'll merge to central sometime before the uplift...
https://hg.mozilla.org/integration/mozilla-inbound/rev/f561d08e9077
Attachment #8626600 - Flags: review?(smontagu) → review+
https://hg.mozilla.org/mozilla-central/rev/f561d08e9077
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
I've updated https://developer.mozilla.org/en-US/Firefox/Releases/41#CSS
and the compat table
of the logical properties, writing-mode and text-orientation (but not text-combine-upright)

Comment 11

4 years ago
Release Note Request (optional, but appreciated)
[Why is this notable]: better l10n/i18n support for the Web
[Suggested wording]: Implemented CSS3 Writing Modes
[Links (documentation, blog post, etc)]: (MDN see comment 10)
relnote-firefox: --- → ?
I think this should go in the documentation it's already in (comment 10), but should not be in the release notes unless we have a coherent policy for choosing which developer-facing things go in the release notes.  Instead, the release notes should point to the developer documentation that we already have and is quite thorough.
Since this is already in the developer notes for FF41 here: https://developer.mozilla.org/en-US/Firefox/Releases/41#CSS, we do not need to add it to FF41 release notes.
I think that means this bug should be marked as "relnote-firefox:41+",though, right? (not "relnote-firefox:-)

According to [1], relnote-firefox:- means "this bug does not meet the bar for inclusion in release notes", whereas relnote-firefox:41+ would mean "Drivers have determined this bug will be included in Firefox41 release notes."  It seems like the latter is correct.

[1] https://wiki.mozilla.org/Release_Management/Relnotes_rules
Flags: needinfo?(rkothari)
(In reply to Daniel Holbert [:dholbert] from comment #14)
> I think that means this bug should be marked as
> "relnote-firefox:41+",though, right? (not "relnote-firefox:-)
> 
> According to [1], relnote-firefox:- means "this bug does not meet the bar
> for inclusion in release notes", whereas relnote-firefox:41+ would mean
> "Drivers have determined this bug will be included in Firefox41 release
> notes."  It seems like the latter is correct.
> 
> [1] https://wiki.mozilla.org/Release_Management/Relnotes_rules

Daniel, AFAIK, there are two different sets of release notes. 
1) https://www.mozilla.org/en-US/firefox/releases/ and, 
2) https://developer.mozilla.org/en-US/Firefox/Releases

RelMan team (including me) work on 1) and use relnote-firefox flag to track which bug fix makes into which release version notes. The developer notes 2) are managed by MDN folks and I think they use dev-doc-needed keywords.
Flags: needinfo?(rkothari)
Thanks -- I don't think that quite addresses what I was asking. I wasn't talking about dev-doc-needed or any MDN-related stuff. I'm asking about "relnote-firefox" and making sure that "-" is actually correct here.

The Release Management wiki page that I linked to in comment 14 describes the definitions of the various "relnote-firefox" values, and it seems to differ from how you set that flag here -- if that page is no longer correct, could you or someone else update it to reflect the current semantics?  (Or, if the wiki page is indeed correct, then I think perhaps this bug should actually be "relnote-firefox:41+"?)
Daniel, that page was updated (revamped) about 2 months ago by me. :) I do not see the inconsistency. However, I will update that page to mention that if a note is included in MDN and also nominated for FF release notes inclusion, it will be denied and relnote-firefox will be set to "-".

Again, this bug does not meet the bar for inclusion in release notes for FF41 and therefore relnote-firefox set to "-". The reason it does not meet the bar is because we do not want to copy MDN developer notes into FF release notes. Hope that helps!
Ah, I see -- I mistook the link in comment 13 as being an actual release notes link. That makes sense now -- thanks!

> However, I will update that page to mention that
> if a note is included in MDN and also nominated for FF release notes
> inclusion, it will be denied and relnote-firefox will be set to "-".

That would be great & would help clarify this for future folks who may be confused like I was -- thanks!
You need to log in before you can comment on or make changes to this bug.