Assert/Crash running "fetch-event-async-respond-with.https.html" wpt service worker test in Nightly

RESOLVED FIXED in Firefox 43

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: noemi, Assigned: Ehsan)

Tracking

Trunk
mozilla44
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 affected, firefox43+ fixed, firefox44+ fixed)

Details

Attachments

(2 attachments)

Reporter

Description

4 years ago
A Nightly crash occurs when executing "fetch-event-async-respond-with.https.html" wpt test such as |./mach web-platform-tests _mozilla/service-workers/service-worker/fetch-event-async-respond-with.https.html| with today's (7/1) master build

The assertion failure shown is as follows:
"Assertion failure: workerPrivate, at /Users/noef/Documents/mozilla-central/dom/workers/ServiceWorker.cpp:93"

Please find attached the crash report corresponding to this
Assignee

Comment 1

4 years ago
This is another instance of bug 1179401.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1179401
Reporter

Comment 2

4 years ago
Hi,

just checked on m-c (89732fcdb0ba revision) once bug 1179401 has been landed and the result obtained when running |./mach web-platform-tests _mozilla/service-workers/service-worker/fetch-event-async-respond-with.https.html| is as follows:

Summary

Harness status: OK

Found 1 tests
1 Fail
Details

Result
Fail

Test Name
Calling respondWith asynchronously throws an exception	

Message
promise_test: Unhandled rejection with value: object "InvalidStateError: An attempt was made to use an object t..."

@https://web-platform.test:8443/_mozilla/service-workers/service-worker/fetch-event-async-respond-with.https.html:7:1

Ehsan, should we open a new bug?. Thanks!
Flags: needinfo?(ehsan)
Assignee

Comment 3

4 years ago
No, we can reopen this one.
Status: RESOLVED → REOPENED
Flags: needinfo?(ehsan)
Resolution: DUPLICATE → ---
Assignee

Updated

4 years ago
Assignee: nobody → ehsan
Attachment #8671024 - Flags: review?(josh) → review+
Assignee

Comment 6

4 years ago
Comment on attachment 8671024 [details] [diff] [review]
Disallow FetchEvent.respondWith() when the dispatch flag is unset

Approval Request Comment
[Feature/regressing bug #]: service workers
[User impact if declined]: spec compliance issue
[Describe test coverage new/current, TreeHerder]: locally
[Risks and why]: no risk
[String/UUID change made/needed]: none
Attachment #8671024 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/0dd6a4a5da3d
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Reporter

Comment 8

4 years ago
Hi,

just checked on m-c (0b69d304f861 revision) and the test successfully runs. Thanks for fixing it!

Summary

Harness status: OK

Found 1 tests
1 Pass
Details
Result	Test Name
Pass	Calling respondWith asynchronously throws an exception
Comment on attachment 8671024 [details] [diff] [review]
Disallow FetchEvent.respondWith() when the dispatch flag is unset

Fix for crash in service workers, ok to uplift to aurora.
Attachment #8671024 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Tracking since this is a regression and part of a feature we're aiming at 43.
Sorry had to backout and recheckin this since this turned innocent for a memory leaks, sorry for the hassle
You need to log in before you can comment on or make changes to this bug.