Themes window positioned too high on OS X

REOPENED
Assigned to

Status

Instantbird
Preferences
REOPENED
3 years ago
a year ago

People

(Reporter: arlolra, Assigned: aleth)

Tracking

trunk
Instantbird 42

Details

(Whiteboard: [1.6-wanted])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.130 Safari/537.36

Steps to reproduce:

https://trac.torproject.org/projects/tor/ticket/16476

but I see the same in Instantbird nightly.
(Reporter)

Comment 1

3 years ago
> When I open Tor Messenger Themes Preference, the content is positioned too high in the window, obscuring part of the Theme selector, and perhaps other content.
> This issue also affects the Advanced preferences.
> Changing between preferences is a workaround for this issue.
(Assignee)

Comment 2

3 years ago
STR
Select "General" preference tab.
Then, close and reopen preferences.
Now, switch to "Themes" and the bug should appear.
Whiteboard: [1.6-wanted]
(Assignee)

Comment 3

3 years ago
Created attachment 8638217 [details] [diff] [review]
themespanejump.diff

The pane would scroll up as messages were being added, because convbrowser scrolls to the last added message by default and that apparently sometimes has side effects on the pane position. viewlog.js does something similar to this patch (the log viewer also wants to turn off scrolling to the last message).
Assignee: nobody → aleth
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8638217 - Flags: review?(clokep)
Attachment #8638217 - Flags: review?(clokep) → review+
https://hg.mozilla.org/comm-central/rev/810eb0e26473
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.6
(Assignee)

Comment 5

3 years ago
Created attachment 8638482 [details] [diff] [review]
themepanelcommentfix.diff

Improved comment.
Attachment #8638482 - Flags: review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Updating milestone from 1.6 to 42.
Target Milestone: 1.6 → Instantbird 42
(Assignee)

Updated

2 years ago
Depends on: 1222238
(Reporter)

Comment 8

a year ago
I'm seeing this same problem again on nightly.
(Assignee)

Comment 9

a year ago
:-(
(Assignee)

Updated

a year ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

a year ago
I wonder if this is related to the autoscroll issues we've been seeing on nightly more generally.
We should probably open a new bug. This bug was 'fixed' 10 versions again.
You need to log in before you can comment on or make changes to this bug.